X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I change search engines?

Posted

My search engine by choice is Google but last week I decided to use Bing. I changed the search to Bing, did my search and then attempted to change the search engine back to Google. FF 4.0 Beta would not keep Google as the default search engine. It would always revert back to Bing after every change and search on Google. I had to stop using FF and switch to another browser until I rebooted the machine and everything has been fine since.

Modified by dour224

Additional System Details

This happened

Just once or twice

Installed Plug-ins

  • npmnqmp 989898989877
  • Garmin Communicator Plug-In 2.9.3.0
  • Google Talk Plugin Video Accelerator version:0.1.43.5
  • Version 1.9.2.0
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • OpenOffice.org Plug-in handles all its documents
  • Google Update
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • 6.0.0.0
  • DivX Web Player version 2.0.0.254
  • npdivxplayerplugin
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The Joost Plugin enables you to watch Joost TV. For more information, visit the Joost Web site.
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60129.0
  • MSN® Toolbar
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • NBC Direct Firefox Plugin
  • Google Updater pluginhttp://pack.google.com/
  • Package Installer & Install Conduit
  • Rhapsody Player Engine Plugin
  • Loki Plugin v.3.1.0.05
  • Version 0.9.16, copyright 2008-2010 Veetle Inchttp://www.veetle.com/
  • Version 0.9.16, Copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Version 0.9.16, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • Version 1.1.7, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24405 answers

Are you talking about the Firefox Search bar, that is to the right of where you type web addresses? By default, the Search bar is part of the Navigation toolbar - but it can be moved to another toolbar by the user.

Or is that a search function part of the MSN@Toolbar that shows in plugins as being installed?

Rokakoma 0 solutions 1 answers

Enter "about:config" into location bar (where you enter internet addresses otherwise)

Then scroll down to "browser.search.defaultengine"

Change it to "Google.com"

and that is it!

Modified by Rokakoma

tazdad092067 0 solutions 1 answers

I have changed the "about:config" settings mentioned here and the "Keyword.url" setting as well several times. No matter what I do, it keeps defaulting back to Bing. Unfortunately, Bing is blocked from my workplace firewall for whatever reason and I keep getting "STOP" screens when I search.

Modified by tazdad092067

achasse001 0 solutions 2 answers

Helpful Reply

At the top right hand corner of your Fire Fox browser there is the search BOX you type in when you do a search. Just on the left side of that BOX there is a drop down menu. Choose which one you want to use by clicking on it. That will work!

I had the same problem with Bing and couldn't find it anywhere and no matter what I did I couldn't get rid of it.

But I found this solution and I hope it works for you.

Thanks Girlybear

Monish Kumar Attri 0 solutions 1 answers

Helpful Reply

Found an answer !!!

Go to "about:config" settings and do these two things =>

1. Type "Keyword.url" in the search box. Right click it & reset it.

2. Type "browser.search.defaultengine" in the search box. Right click it & reset it.

Voila ! It is done...

~ M.k.A™