X
Tap here to go to the mobile version of the site.

Support Forum

Flash not working in Firefox Beta 7 on OSX 10.6.5

Posted

As suggested, I'm creating a new question for this issue, as the question we were using previously has been marked solved. Details up to now can be referenced here:

https://support.mozilla.com/en-US/questions/763917

Alice,

Flash does work fine in Safari, so it seems to be just beta 7 that has this problem. I don't see any extensions that might be blocking flash (and haven't installed anything new between beta 6 and 7), but I will try a testing profile shortly.

Looking over the release notes, I don't see anything particularly specific to this. Possibly WebGL is interfering, or the new accelerated rendering that went in? I'm not sure how to go about checking if either of those caused the problem.

As suggested, I'm creating a new question for this issue, as the question we were using previously has been marked solved. Details up to now can be referenced here: https://support.mozilla.com/en-US/questions/763917 Alice, Flash does work fine in Safari, so it seems to be just beta 7 that has this problem. I don't see any extensions that might be blocking flash (and haven't installed anything new between beta 6 and 7), but I will try a testing profile shortly. Looking over the release notes, I don't see anything particularly specific to this. Possibly WebGL is interfering, or the new accelerated rendering that went in? I'm not sure how to go about checking if either of those caused the problem.

Chosen solution

OK, I did some googling around and found this, as a possible workaround to get Flash working in Firefox 4.0 Beta 7:

http://boomswaggerboom.wordpress.com/2010/11/10/firefox-4-for-mac-os-x-under-the-hood/

BenE says:
November 16, 2010 at 8:47 am

To get Flash streams (like YouTube) to run on OS X 10.6.4 using Firefox 4 beta 7, I had to go to the Get info for FF and ENABLE 32-bit mode.

jhz says:
November 17, 2010 at 6:15 pm

Same problem with Flash not running (OSX 10.6.5), and same solution works : using Get info to instruct FF 4 ß7 to start in 32-bit mode
.

In other words, control-click the Firefox.app icon, select "Get Info", and then check the box, "Open in 32-bit mode".

Let me know if that helps.


P.S. I found another topic started by a Mac OS X 10.6 user on the same issue, in case you want to watch it for replies:

http://support.mozilla.com/en-US/questions/764078 Flash videos and games on are missing/show up as black boxes with firefox 4 beta 7

Disabling hardware acceleration via Firefox Preferences (Advanced -> uncheck "use hardware acceleration where available") was suggested in that thread, as well.

Read this answer in context 20

Additional System Details

Installed Plug-ins

  • npmnqmp 071101000050
  • Octoshape Streaming Services web integration browser plug-in
  • iPhoto6
  • DivX Content Upload Plug-In: Uploads DivX video in your browser!
  • DivX Browser Plug-In: Plays DivX video in your browser!
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Garmin Communicator Plug-in Version 2.7.3.0
  • 4.0.50401.0
  • Version 1.5.1.10420
  • Google Talk Plugin Video Accelerator version:0.1.43.3
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

More Information

Question owner

Tried using a new profile, but the problem is still there.

Tried using a new profile, but the problem is still there.

Question owner

Did some looking around and found some suggestions to turn hardware acceleration off in Firefox itself. I've tried that, but it didn't fix anything.

Did some looking around and found some suggestions to turn hardware acceleration off in Firefox itself. I've tried that, but it didn't fix anything.
AliceWyman
  • Moderator
194 solutions 2256 answers

Chosen Solution

OK, I did some googling around and found this, as a possible workaround to get Flash working in Firefox 4.0 Beta 7:

http://boomswaggerboom.wordpress.com/2010/11/10/firefox-4-for-mac-os-x-under-the-hood/

BenE says:
November 16, 2010 at 8:47 am

To get Flash streams (like YouTube) to run on OS X 10.6.4 using Firefox 4 beta 7, I had to go to the Get info for FF and ENABLE 32-bit mode.

jhz says:
November 17, 2010 at 6:15 pm

Same problem with Flash not running (OSX 10.6.5), and same solution works : using Get info to instruct FF 4 ß7 to start in 32-bit mode
.

In other words, control-click the Firefox.app icon, select "Get Info", and then check the box, "Open in 32-bit mode".

Let me know if that helps.


P.S. I found another topic started by a Mac OS X 10.6 user on the same issue, in case you want to watch it for replies:

http://support.mozilla.com/en-US/questions/764078 Flash videos and games on are missing/show up as black boxes with firefox 4 beta 7

Disabling hardware acceleration via Firefox Preferences (Advanced -> uncheck "use hardware acceleration where available") was suggested in that thread, as well.

OK, I did some googling around and found this, as a possible workaround to get Flash working in Firefox 4.0 Beta 7: http://boomswaggerboom.wordpress.com/2010/11/10/firefox-4-for-mac-os-x-under-the-hood/ '''''BenE says:<br>November 16, 2010 at 8:47 am<br><br>To get Flash streams (like YouTube) to run on OS X 10.6.4 using Firefox 4 beta 7, I had to go to the Get info for FF and ENABLE 32-bit mode.''''' '''''jhz says:<br>November 17, 2010 at 6:15 pm<br><br>Same problem with Flash not running (OSX 10.6.5), and same solution works : using Get info to instruct FF 4 ß7 to start in 32-bit mode'''''. In other words, control-click the Firefox.app icon, select "Get Info", and then check the box, "Open in 32-bit mode". Let me know if that helps. ----- P.S. I found another topic started by a Mac OS X 10.6 user on the same issue, in case you want to watch it for replies: http://support.mozilla.com/en-US/questions/764078 Flash videos and games on are missing/show up as black boxes with firefox 4 beta 7 Disabling hardware acceleration via Firefox Preferences (Advanced -> uncheck "use hardware acceleration where available") was suggested in that thread, as well.

Modified by AliceWyman

lfom 0 solutions 1 answers

Either use Firefox 4.0b7 in 32-bit mode, or download and install the latest Flash "Square" beta, that runs in 64-bit mode. http://labs.adobe.com/downloads/flashplayer10.html

Either use Firefox 4.0b7 in 32-bit mode, or download and install the latest Flash "Square" beta, that runs in 64-bit mode. http://labs.adobe.com/downloads/flashplayer10.html

Question owner

That did it. Running in 32-bit mode fixed it up for me. Thanks so much for sticking with me on this!

That did it. Running in 32-bit mode fixed it up for me. Thanks so much for sticking with me on this!
AliceWyman
  • Moderator
194 solutions 2256 answers

Hey, glad it worked!

You can mark this topic as "solved" now ;-)

Hey, glad it worked! You can mark this topic as "solved" now ;-)
ramram 0 solutions 2 answers

Hi folks!

Had my hopes up reading the post on this page, baaaat....

my problem is that flash crashes intermittently on my MBP i7, OS 10.6.5. (e.g. youtube, gmail et al.)

So, I tried the 32-bit mode, but to no avail.

I made another attempt using the 64-bit flashplayer version, un-selecting 32-bit for FF, but again no luck. In fact this time all videos had trouble playing at all, while the audio track ran fine (for youtube vids).

Also, no changes when turning off Hardware Acceleration in FF preferences.

The only difference I did notice is that now I have the choice to "report" the crash to Mozilla, which before I did not.

Sorry, NOT "solved" for me.... :'•(

Hi folks! Had my hopes up reading the post on this page, baaaat.... my problem is that flash crashes intermittently on my MBP i7, OS 10.6.5. (e.g. youtube, gmail et al.) So, I tried the 32-bit mode, but to no avail. I made another attempt using the 64-bit flashplayer version, un-selecting 32-bit for FF, but again no luck. In fact this time all videos had trouble playing at all, while the audio track ran fine (for youtube vids). Also, no changes when turning off Hardware Acceleration in FF preferences. The only difference I did notice is that now I have the choice to "report" the crash to Mozilla, which before I did not. Sorry, NOT "''solved''" for me.... :'•(
ramram 0 solutions 2 answers

OK, ok, ok ok, now we have something...then again I think it's SQ1!

After uninstalling the 64-bit flashplayer (using Flash Player "Square" for Mac OS X uninstaller from the Adobe site) and reinstalling it from the 'missing plugin' prompt, Flash is now able to play again.

But, while holding my breath listening to Van Morrison...Baby please don't go! I got yet another Crash of Flash! This time "No report available", so I'm thinking that's not available in the 64 bit version.

Leaves me wondering if I had the 64-bit version installed at the beginning of this sequence. Hm?

Anyone?

OK, ok, ok ok, now we have something...then again I think it's SQ1! After '''uninstalling''' the 64-bit flashplayer (using Flash Player "Square" for Mac OS X uninstaller from the Adobe site) and reinstalling it from the 'missing plugin' prompt, Flash is now '''able''' to play again. But, while holding my breath listening to Van Morrison...Baby please don't go! I got yet another Crash of Flash! This time "No report available", so I'm thinking that's not available in the 64 bit version. Leaves me wondering if I had the 64-bit version installed at the beginning of this sequence. Hm? Anyone?

Modified by ramram

AliceWyman
  • Moderator
194 solutions 2256 answers

ramram,

Crashes in the Flash plugin are different than Flash not working at all on Mac OS X 10.6 using Firefox 4 Beta 7 .... which is what this thread is about. Try the other suggestions that best describe your issue in these articles, under "Troubleshooting":

If you need more help, you will get a better response if you ask a new question in the Support Forum, since this thread is now "solved".

'''ramram,''' Crashes in the Flash plugin are different than Flash not working at all on Mac OS X 10.6 using Firefox 4 Beta 7 .... which is what this thread is about. Try the other suggestions that best describe your issue in these articles, under "Troubleshooting": * http://kb.mozillazine.org/Flash *[[Managing the Flash plugin]] If you need more help, you will get a better response if you [[ask a question|ask a new question]] in the Support Forum, since this thread is now "solved".
dr.nixon 0 solutions 2 answers

The 64-bit flash helps but does not solve the problem. YouTube videos don't play but Flash works elsewhere fairly well. To get videos to play, going full-screen fixes the issue. It's not Flash itself, it seems to be a conflict between the Firefox UI chrome and Flash. Hiding the Firefox UI by going full-screen makes the conflict go away. This is going to be a big issue and in my opinion is enough to block an official release IF the problem truly is on Firefox's end and not Adobe's.

The 64-bit flash helps but does not solve the problem. YouTube videos don't play but Flash works elsewhere fairly well. To get videos to play, going full-screen fixes the issue. It's not Flash itself, it seems to be a conflict between the Firefox UI chrome and Flash. Hiding the Firefox UI by going full-screen makes the conflict go away. This is going to be a big issue and in my opinion is enough to block an official release IF the problem truly is on Firefox's end and not Adobe's.
vic.leiwang 0 solutions 1 answers

i have exactly the same problem.. have you found a way to fix this problem yet? or are you waiting for firefox 4 beta 8?

i have exactly the same problem.. have you found a way to fix this problem yet? or are you waiting for firefox 4 beta 8?
cor-el
  • Top 10 Contributor
  • Moderator
12907 solutions 118375 answers

If you use a Firefox 4.0 beta version then you can also try to disable hardware acceleration:
Tools > Options > Advanced : General: Browsing: [ ] "Use hardware acceleration when available"

If you use a Firefox 4.0 beta version then you can also try to disable hardware acceleration:<br /> Tools > Options > Advanced : General: Browsing: [ ] "Use hardware acceleration when available"
AliceWyman
  • Moderator
194 solutions 2256 answers

^^^ On Mac OS, "Tools > Options" is "Firefox > Preferences...".

^^^ On Mac OS, "Tools > Options" is "Firefox > Preferences...".
tarobun 0 solutions 1 answers

Helpful Reply

This worked for me:

1. Removed Flash Player 10.2 using the uninstaller at the bottom of the page http://labs.adobe.com/downloads/flashplayer10.html

2. Installed Flash Player version 10.1.102.64 from http://get.adobe.com/flashplayer/

"Use hardware acceleration when available" (Firefox) and "Enable hardware acceleration" (Flash Player) both enabled.

This worked for me: 1. Removed Flash Player 10.2 using the uninstaller at the bottom of the page http://labs.adobe.com/downloads/flashplayer10.html 2. Installed Flash Player version 10.1.102.64 from http://get.adobe.com/flashplayer/ "Use hardware acceleration when available" (Firefox) and "Enable hardware acceleration" (Flash Player) both enabled.
Tyyy 0 solutions 5 answers

Firefox 4 beta 8 does not fix this problem. And I still don't fully understand, why this isn't existing in 3.6.x. I think Mozilla should step up and adress this and make it clear to the user what is happening here and when this will be fixed. So I will have to be in 32-bit mode all the time because of an old Flash version???

Firefox 4 beta 8 does not fix this problem. And I still don't fully understand, why this isn't existing in 3.6.x. I think Mozilla should step up and adress this and make it clear to the user what is happening here and when this will be fixed. So I will have to be in 32-bit mode all the time because of an old Flash version???
AliceWyman
  • Moderator
194 solutions 2256 answers

So I will have to be in 32-bit mode all the time because of an old Flash version?

Tryy,
If you are using an old Flash plugin (previous to 10.1) such as Flash 10.0 then yes... only Flash 10.1 or above will run in Firefox 4 in the default 64-bit mode on Mac OS 10.6 ( reference and background)

However, some Mac OS X 10.6 users, like luminoth (the original poster of this thread) are unable to view Flash content in Firefox 4 Beta 7 or above , even though they have Flash 10.1 or higher installed (such as Flash 10.1 r102). For those users, running Firefox 4 Beta in 32-bit mode seems to be the best workaround.

Note for others reading: The steps to start Firefox 4 on Mac OS in 32-bit mode are now given in the Troubleshooting section of this article (viewable for Mac OS, Firefox 4): Flash Plugin - Keep it up to date and troubleshoot problems
......and here is a screenshot I made, showing the "Open in 32-bit mode" checkbox in the "Firefox Info" window.

The "bug" that results in Flash 10.1 plugin failure in Firefox 4 Beta 7 and above occurs on some (older?) Mac 10.6 systems. I don't see the issue myself. Flash 10.1 works fine with Firefox 4 Beta 7 running in 64-bit mode on my new iMac.

P.S. Here is an (unconfirmed) bug that seems to describe the problem:

https://bugzilla.mozilla.org/show_bug.cgi?id=610526
Bug 610526 - Firefox never loads flash in "out of process" mode

''So I will have to be in 32-bit mode all the time because of an old Flash version?'' '''Tryy,''' <br> If you are using an old Flash plugin (previous to 10.1) such as Flash 10.0 then yes... only Flash 10.1 or above will run in Firefox 4 in the default 64-bit mode on Mac OS 10.6 ( [https://bugzilla.mozilla.org/show_bug.cgi?id=589670#c9 reference] and [http://boomswaggerboom.wordpress.com/2010/11/10/firefox-4-for-mac-os-x-under-the-hood/ background]) However, some Mac OS X 10.6 users, like''' luminoth''' (the original poster of this thread) are unable to view Flash content in Firefox 4 Beta 7 or above , even though they have Flash 10.1 or higher installed (such as Flash 10.1 r102). For those users, running Firefox 4 Beta in 32-bit mode seems to be the best workaround. Note for others reading: The steps to start Firefox 4 on Mac OS in 32-bit mode are now given in the Troubleshooting section of this article (viewable for Mac OS, Firefox 4): [[Managing the Flash plugin]] <br>......and here is a [http://img256.imageshack.us/img256/5470/fx4b7getinfo.png screenshot] I made, showing the "Open in 32-bit mode" checkbox in the "Firefox Info" window. The "bug" that results in Flash 10.1 plugin failure in Firefox 4 Beta 7 and above occurs on some (older?) Mac 10.6 systems. I don't see the issue myself. Flash 10.1 works fine with Firefox 4 Beta 7 running in 64-bit mode on my new iMac. P.S. Here is an (unconfirmed) bug that seems to describe the problem: https://bugzilla.mozilla.org/show_bug.cgi?id=610526 <br> Bug 610526 - Firefox never loads flash in "out of process" mode

Modified by AliceWyman

lmh2154 0 solutions 1 answers

Thanks! It took me FOREVER trying to find a solution to this problem, but I found this link, it solved it immediately.

Thanks! It took me FOREVER trying to find a solution to this problem, but I found this link, it solved it immediately.
AliceWyman
  • Moderator
194 solutions 2256 answers

You're welcome.

Anyone seeing this problem in Mac OS X 10.6 (Snow Leopard): Do you have at least Flash 10.1 installed? If so, and if Flash does not work unless you run Firefox 4 Beta in 32-bit mode, you may want to sign up for a Bugzilla account and then add information about your Mac system to bug 610526, or simply vote for the bug to keep track of its progress.

If and when a fix is found you can restore Firefox 4 Beta to 64-bit mode (which has some performance improvements) by unchecking the "Open in 32-bit mode" checkbox in the Firefox.app Get Info window.

You're welcome. Anyone seeing this problem in Mac OS X 10.6 (Snow Leopard): Do you have at least Flash 10.1 installed? If so, and if Flash does not work unless you run Firefox 4 Beta in 32-bit mode, you may want to sign up for a [https://bugzilla.mozilla.org/ Bugzilla] account and then add information about your Mac system to [https://bugzilla.mozilla.org/show_bug.cgi?id=610526 bug 610526], or simply vote for the bug to keep track of its progress. If and when a fix is found you can restore Firefox 4 Beta to 64-bit mode (which has some performance improvements) by unchecking the "Open in 32-bit mode" checkbox in the Firefox.app Get Info window.

Modified by AliceWyman