Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

HTTPs Only Mode

  • 7 replies
  • 1 has this problem
  • 1 view
  • Last reply by Mike Kaply

more options

Hello, I have a problem with setting up HTTPs only Mode in my Organization, I read a lot about that, but I dont see the "dom.security.https_only_mode" switch in GPO, we have the newest admx for Firefox. We need that to specific container, but still I dont know how to set it up, even via regedit, or preferences. Can someone describe me when can I set it up ? It could be using json file (which exactly file and how?), registry or just gpo. Regards, M.

Hello, I have a problem with setting up HTTPs only Mode in my Organization, I read a lot about that, but I dont see the "dom.security.https_only_mode" switch in GPO, we have the newest admx for Firefox. We need that to specific container, but still I dont know how to set it up, even via regedit, or preferences. Can someone describe me when can I set it up ? It could be using json file (which exactly file and how?), registry or just gpo. Regards, M.
Attached screenshots

Chosen solution

For mozilla.cfg, you would just add

pref("dom.security.https_only_mode", true);

What do you see when you to about:policies where policy isn't working?

I would strongly recommend you move away from mozilla.cfg if you can, we have much better options now.

Read this answer in context 👍 1

All Replies (7)

more options

That's the old preferences policy that only set a subset of preferences.

You can now set arbitrary preferences using the Preferences policy:

https://mozilla.github.io/policy-templates/#preferences

Helpful?

more options

should I configure it in a policies.json file, localized at C:\Program Files\Mozilla Firefox\distribution ? Which policies is responsible for HTTPs only mode? I don't see any responding to this. I dont even know if that file works, I set it like this for the test:

{

 "policies": {
   "DisableAppUpdate": true,
   "DisableTelemetry": true,
   "DisableDefaultBrowserAgent": false,
   "DisplayBookmarksToolbar": "never"
 }

}

and every time I open FF, I see a bookmarks toolbar. Should I set something else on cfg or somewhere to that policies.json file works ?

I think in our version ESR, we are using mozilla.cfg file to config any options, is there any idea to configure HTTPs Only Mode in this file? Or do You know any samples or variables in configuration mozilla.cfg file?

Helpful?

more options

Chosen Solution

For mozilla.cfg, you would just add

pref("dom.security.https_only_mode", true);

What do you see when you to about:policies where policy isn't working?

I would strongly recommend you move away from mozilla.cfg if you can, we have much better options now.

Helpful?

more options

ok I found where and what to change in mozilla.cfg file to set that, thanks for Help Mike

Helpful?

more options

If you need help moving from mozilla.cfg, feel free to reach out to me.

Helpful?

more options

Soon I think I will need help to moving from mozilla.cfg to policies.json :) but not for now, is it hard to change that major config file?

Helpful?

more options

It depends on how many settings you have :).

I'd go through and figure out what you need in policy.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.