Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Sites won't stay logged in after 1 day: Help!?

  • 4 replies
  • 1 has this problem
  • 38 views
  • Last reply by ko220

more options

FF won't keep me logged into any sites that I ask to stay logged into. By the next day I have to log back into everything. I have my settings set to: Enhanced Tracking: Standard; Cookies & Site Data (unchecked delete cookies & site data); History (only close browsing & download history when FF closes, nothing else). I don't use CC Cleaner or anything like that. Can anyone help?

FF won't keep me logged into any sites that I ask to stay logged into. By the next day I have to log back into everything. I have my settings set to: Enhanced Tracking: Standard; Cookies & Site Data (unchecked delete cookies & site data); History (only close browsing & download history when FF closes, nothing else). I don't use CC Cleaner or anything like that. Can anyone help?

Modified by ko220

Chosen solution

SOLVED!! Thank you FredMcD. Private Browsing was not checked, and my settings were set properly. After I have tried everything, yesterday I "refreshed" FF (which seems like it's a sort of uninstall and reinstall, but safer) and today it remembered all my sites that I wanted to stay logged into. Something in the program must have been corrupted. Thank you very much for your suggestions.

Read this answer in context 👍 0

All Replies (4)

more options

Profile data can be removed or not recorded in several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings; (In the address bar, type about:preferences#privacy<enter>)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers
    Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

more options

Chosen Solution

SOLVED!! Thank you FredMcD. Private Browsing was not checked, and my settings were set properly. After I have tried everything, yesterday I "refreshed" FF (which seems like it's a sort of uninstall and reinstall, but safer) and today it remembered all my sites that I wanted to stay logged into. Something in the program must have been corrupted. Thank you very much for your suggestions.

Modified by ko220

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

more options

Thanks! I couldn't mark my own post as Solved, but I marked your last one. Hopefully it will help others.