Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop new tabs from opening

  • 6 replies
  • 2 have this problem
  • 1436 views
  • Last reply by alentia

more options

Hi. I am using Firefox as my default browser on my pixel 3 xl and every time I go to perform a search, fire fox opens a new tab. Before I know it, I have a million tabs open. How do I stop this behavior? I want to only use one tab.

Chosen solution

No problem, glad we could help.

Read this answer in context 👍 0

All Replies (6)

more options

Hey there,

I'm having some trouble replicating this on my end. What search engine are you using? Could you also check that Firefox has been updated to the most recent version?

You can find your version by going to about:firefox in your address bar. The most recent version is 68.4.2

more options

Hello. Thanks for responding. The version of Firefox I have is 68.4.2. On my phone, I have Firefox set as my default browser. In the Google app, I have it set to show search results externally from the app. So, when I click a link, it opens up Firefox. The issue that I am having is that every time I do this, the results open a new tab in the browser. I see no option in Firefox to disable this. The desired action is for Firefox to use the tab already open, provided there is one.

more options

Hi

I do not think this is an issue with Firefox for Android, it is a consequence of the Google app looking to open a new browser every time that you do a search.

more options

Oh, I see. I will take this issue over to the Google forum. Thank you.

more options

Chosen Solution

No problem, glad we could help.

more options

Windows 10, well, new tabs opening all the time, and they are hiding between pinned tabs and new tab button, millions of them. it is always happens with ebay, weedmaps, coindesk and many other websites, instead of reusing the same tab for the link, ff like no other browser opens new tab for whatever reason. How can I stop that? Is there setting "reuse existing tab" = 1 as a default?