I can't install Facebook Container on Firefox 57+

The Facebook Container add-on requires Firefox version 57 or higher.

If you're on version 57+ and still unable to install Facebook Container, you might have another extension or configuration that causes Firefox to conceal its version.

To work around this, copy and paste this link into your address bar: https://addons.mozilla.org/firefox/downloads/latest/facebook-container/platform:2/addon-954390-latest.xpi.

Firefox may ask for your permission to install the add-on. If it does, click the Add button.

// These fine people helped write this article:AliceWyman, Joni. You can help too - find out how.

Was this article helpful? Please wait...

Volunteer for Mozilla Support