How to Install and Use another Language in the Dictionary on Thunderbird

Revision Information
  • Revision id: 102481
  • Created:
  • Creator: Lan
  • Comment: Reorganized article, added more info
  • Reviewed: No
  • Ready for localization: No
Revision Source
Revision Content

If you send messages in more than one language, you can install additional spell-checking dictionaries to Thunderbird. After installing a dictionary, it is easy to switch from one language to another.

Language dictionaries are available as Thunderbird add-ons. See the Thunderbird add-ons - frequently asked questions for more information.

Install a new language dictionary

  1. At the top of the Thunderbird window, click the Tools menu and select OptionsIn the menu bar, click the Thunderbird menu and select PreferencesAt the top of the Thunderbird window, click the Edit menu and select Preferences, or click the menu button New Fx Menu fx57menu and choose OptionsPreferences.
  2. Click on the Composition panel.
  3. On the Spelling tab, click Download More Dictionaries.
  4. Scroll through the alphabetic list of dictionaries to find the one you want.
  5. Click Download Dictionary next to the language you want.
  6. In the Software Installation window, click Install Now.
  7. Restart Thunderbird if prompted.

That is it! Your new dictionary is installed. To uninstall it, open the Add-ons Manager, find the dictionary on the Dictionaries or Extensions tab and click Remove next to it.

Switch between different languages

For particular message

Right-clickHold down the Ctrl key while you click on the message you are writing and select a language in the Languages menu.

TB switch dictionaries

Set the default language for all messages

  1. At the top of the Thunderbird window, click the Tools menu and select OptionsIn the menu bar, click the Thunderbird menu and select PreferencesAt the top of the Thunderbird window, click the Edit menu and select Preferences, or click the menu button New Fx Menu fx57menu and choose OptionsPreferences.
  2. Click on Composition.
  3. On the Spelling tab, select the desired language from the drop-down list.
  4. Click OK to close the dialog.

Dictionary popup menu