Forum response - Can't attach files in Gmail

Firefox's pop-up blocker may have prevented the file upload window from opening. Please try adding Gmail to your list of allowed sites by following the steps below:

Mac:

  1. Click on the menu button new fx menu and choose Preferences.
  2. Click on the Content panel.
  3. Click on the Exceptions button next to Block pop-up windows.
  4. In the Allowed Sites window, type in mail.google.com in the address field.
  5. Click Allow to finish.

Windows:

  1. Click on the menu button new fx menu and choose Options.
  2. Select the Content panel.
  3. Click on the Exceptions button next Block pop-up windows.
  4. In the Allowed Sites window, type in mail.google.com in the address field, then click Allow to add it to the list.
  5. Click Close to finish.

Linux:

  1. Click on the menu button new fx menu and choose Preferences.
  2. Select the Content panel.
  3. Click on the Exceptions button next Block pop-up windows.
  4. In the Allowed Sites window, type in mail.google.com in the address field.
  5. Click Allow to add it to the list, then Close to finish.


Did that fix the problem? Please let us know.

// These fine people helped write this article:Joni. You can help too - find out how.

Was this article helpful? Please wait...

Volunteer for Mozilla Support