Fix "The bookmarks and history system will not be functional" error message

Revision Information
  • Revision id: 7754
  • Created:
  • Creator: pbb
  • Comment: wikicode cleanup
  • Reviewed: Yes
  • Reviewed:
  • Reviewed by: AliceWyman
  • Is approved? Yes
  • Is current revision? No
  • Ready for localization: No
Revision Source
Revision Content
This article applies to Firefox 3.5 and above. If you are having problems with your bookmarks in Firefox 3.0.x, see Bookmarks and toolbar buttons not working after upgrading for a solution.

Do you see this error message when you start Firefox?

The bookmarks and history system will not be functional because one of Firefox's files is in use by another application. Some security software can cause this problem

That happens when the file (named places.sqlite) that stores your bookmarks and browsing history can’t be accessed by Firefox. This article covers two possible solutions.

If you don't see the error above, then you should try one of these articles instead:

Solution 1: Restart your computer

The most common causes of this error are another program using the file or a problem with the file that was caused when the computer was shut off unexpectedly (like a power failure). The good news is that most of the time, simply restarting your computer and then restarting Firefox is the fix for both problems.

Solution 2: Create a new places database

If restarting your computer doesn’t take care of things, you can fix this by making Firefox create a new places database for you. Don’t worry, it’s not as hard as it sounds.

Part 1 – Open your profile folder

Firefox 3.6

  1. At the top of the Firefox windowOn the menu bar, click on the Help menu and select Troubleshooting Information.... The Troubleshooting Information tab will open.
  2. Under the Application Basics section, click on Open Containing FolderShow in Finder. A window with your profile files will open. Don't do anything with it yet – skip to Part 2.

Firefox 3.5

Windows Vista and 7

  1. Click the Windows Start button and type %APPDATA%\Mozilla\Firefox\Profiles\ in the Search box at the bottom of the Start menu, without pressing Enter. A list of profiles will appear at the top of the Start menu.
  2. Click on the profile with “default” in the name to open it in a window.

    ab167bec686b081a25849c98d6bf9ea7-1258940859-69-1.png

Windows 2000 and XP

  1. Click the Windows Start button, and select Run....

    win-run.png
  2. Type in %APPDATA%\Mozilla\Firefox\Profiles\ then click OK.

    win-rundialog.png
  3. A window will open containing profile folders.
  4. Double-click the folder with “default” in the name to open it.
  1. Open Finder and go to your home folder. Note: your home folder is usually the name of your Mac user account
  2. From your home folder open /Library/, then /Application Support/, then /Firefox/, then /Profiles/. Your​ prof​ile ​fold​er is with​in this​ fold​er.
  1. (Ubuntu) Click the Places menu on the top right of the screen and select Home Folder. A File Browser window will appear.
  2. Click the View menu and select Show Hidden Files if it isn't already checked.
  3. Double click the folder marked .mozilla.
  4. Double click the folder marked firefox. Your profile folder is within this folder.

Part 2 – Create the database

  1. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

    Firefox will quit.
  2. In the Firefox profile folder, find and rename the files places.sqlite and places.sqlite-journal (if it exists).
    • To rename a file, right-click on it and select rename from the menuclick on it once to select it and then click a second time on the file name to make it editable. Then add .old to the end of it’s name.
  3. Finally, reopen Firefox.
    • When Firefox reopens it will create a new places database. Your browsing history will be lost but Firefox will automatically import your bookmarks from the most recent backup file.
    • If your bookmarks weren’t restored after creating a new places database, try the Recover lost or missing Bookmarks article.

Help! This didn’t fix the problem.

This problem has symptoms that are similar to a number of other problems. Maybe one of these articles better describes your problem.