X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox won't open YouTube or Facebook webpages

Được đăng

Both sites worked fine until this morning. I checked via Chrome and Brave and both websites work fine under those browsers so I'm not sure why these sites will no longer load. Other websites will open with Firefox, just not YouTube or Facebook. Other websites with embedded YT videos will load, but the videos will not appear.

I updated my anti-virus (Avast!) and also tried disabling and then removing my VPN extension from Firefox and restarting the PC but the websites still won't load.

Both sites worked fine until this morning. I checked via Chrome and Brave and both websites work fine under those browsers so I'm not sure why these sites will no longer load. Other websites will open with Firefox, just not YouTube or Facebook. Other websites with embedded YT videos will load, but the videos will not appear. I updated my anti-virus (Avast!) and also tried disabling and then removing my VPN extension from Firefox and restarting the PC but the websites still won't load.

Giải pháp được chọn

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can check for problems with preferences.

Đọc câu trả lời này trong ngữ cảnh 0
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

OpenH264 Flash 32.0 r0 Widevine content decryption module.

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4229 giải pháp 59018 câu trả lời
Được đăng

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

https://support.mozilla.org/en-US/kb/what-happened-tracking-protection?redirectlocale=en-US&redirectslug=tracking-protection

https://support.mozilla.org/en-US/kb/content-blocking

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link} https://support.mozilla.org/en-US/kb/what-happened-tracking-protection?redirectlocale=en-US&redirectslug=tracking-protection https://support.mozilla.org/en-US/kb/content-blocking
Bài viết này có hữu ích với bạn không?
Trích dẫn
Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 giải pháp 10657 câu trả lời
Được đăng

Please update to Firefox 67.0.4, which is the most recent version.

I'd also suggest you remove Avast entirely, and instead install Security essentials and malwarebytes.

Please update to Firefox 67.0.4, which is the most recent version. I'd also suggest you remove Avast entirely, and instead install Security essentials and malwarebytes.
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17421 giải pháp 157414 câu trả lời
Được đăng

Do you possibly use "Resist Fingerprinting"?

When resist fingerprinting (RFP) is enabled then some items are spoofed (TimeZone: UTC, UserAgent: Firefox 60 ESR on Windows 7).

You can check this pref on the about:config page to see if resist fingerprinting (RFP) is enabled and if this pref is user set (bold) reset to false via the right-click context menu.

  • privacy.resistFingerprinting = false
Do you possibly use "Resist Fingerprinting"? *https://support.mozilla.org/en-US/kb/firefox-protection-against-fingerprinting When resist fingerprinting (RFP) is enabled then some items are spoofed (TimeZone: UTC, UserAgent: Firefox 60 ESR on Windows 7). You can check this pref on the <b>about:config</b> page to see if resist fingerprinting (RFP) is enabled and if this pref is user set (bold) reset to false via the right-click context menu. *privacy.resistFingerprinting = false
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Tried SafeMode but the websites still won't load.

No shield or padlock in the address bar when I try to load either YouTube or Facebook. The browser just times out.

Tried SafeMode but the websites still won't load. No shield or padlock in the address bar when I try to load either YouTube or Facebook. The browser just times out.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Tyler Downer said

Please update to Firefox 67.0.4, which is the most recent version. I'd also suggest you remove Avast entirely, and instead install Security essentials and malwarebytes.

Sorry. I entered the wrong version of Firefox in my question. I am already running 67.0.4, not 60.0.

''Tyler Downer [[#answer-1231897|said]]'' <blockquote> Please update to Firefox 67.0.4, which is the most recent version. I'd also suggest you remove Avast entirely, and instead install Security essentials and malwarebytes. </blockquote> Sorry. I entered the wrong version of Firefox in my question. I am already running 67.0.4, not 60.0.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 giải pháp 10657 câu trả lời
Được đăng

Then you must have resist fingerprint enabled. Please disable that

Then you must have resist fingerprint enabled. Please disable that
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

cor-el said

Do you possibly use "Resist Fingerprinting"? When resist fingerprinting (RFP) is enabled then some items are spoofed (TimeZone: UTC, UserAgent: Firefox 60 ESR on Windows 7). You can check this pref on the about:config page to see if resist fingerprinting (RFP) is enabled and if this pref is user set (bold) reset to false via the right-click context menu.
  • privacy.resistFingerprinting = false


Tried that. No change. The websites still won't open.

''cor-el [[#answer-1231900|said]]'' <blockquote> Do you possibly use "Resist Fingerprinting"? *https://support.mozilla.org/en-US/kb/firefox-protection-against-fingerprinting When resist fingerprinting (RFP) is enabled then some items are spoofed (TimeZone: UTC, UserAgent: Firefox 60 ESR on Windows 7). You can check this pref on the <b>about:config</b> page to see if resist fingerprinting (RFP) is enabled and if this pref is user set (bold) reset to false via the right-click context menu. *privacy.resistFingerprinting = false </blockquote> Tried that. No change. The websites still won't open.
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17421 giải pháp 157414 câu trả lời
Được đăng

What Windows version are you using and what Firefox version?


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
What Windows version are you using and what Firefox version? ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Still no joy.

Still no joy.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

I tried reinstalling Firefox and that worked but when I copied over my backup profile, the issue started again.

I tried reinstalling Firefox and that worked but when I copied over my backup profile, the issue started again.
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17421 giải pháp 157414 câu trả lời
Được đăng

Giải pháp được chọn

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can check for problems with preferences.

You can check the connection settings. *Options/Preferences -> General -> Network: Connection -> Settings If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can You can check for problems with preferences. *delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases *http://kb.mozillazine.org/preferences_not_saved *http://kb.mozillazine.org/resetting_preferences
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Looks like it was an issue with a VPN called proxmate. Had to clear it out but once it was gone, things are working again. Thanks for the help everyone.

Looks like it was an issue with a VPN called proxmate. Had to clear it out but once it was gone, things are working again. Thanks for the help everyone.
Bài viết này có hữu ích với bạn không?
Trích dẫn
FredMcD
  • Top 10 Contributor
4229 giải pháp 59018 câu trả lời
Được đăng

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.