Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How can I enable warning message when opening multiple tabs?

  • 10 trả lời
  • 3 gặp vấn đề này
  • 1 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

In old Firefox version was the abillity to turn on in settings warning message, when opening multiple tabs.

"Warn me when opening multiple tabs might slow down Firefox"

or in about:config

browser.tabs.maxOpenBeforeWarn;15 browser.tabs.warnOnOpen;true

This function is necessary for me now, but it is absent in settings, and changing the parameters in about:config didn't give a result. I tried in various FireFox versions from 38 to 44, it doesn't work. Also I started in the safe mode with the disabled additions - no effect.

Could you tell me, please, how to fix (set) viewing the warning message, when opening multiple tabs. (If it not possible with settings, than may be with addons).

In old Firefox version was the abillity to turn on in settings warning message, when opening multiple tabs. "Warn me when opening multiple tabs might slow down Firefox" or in about:config browser.tabs.maxOpenBeforeWarn;15 browser.tabs.warnOnOpen;true This function is necessary for me now, but it is absent in settings, and changing the parameters in about:config didn't give a result. I tried in various FireFox versions from 38 to 44, it doesn't work. Also I started in the safe mode with the disabled additions - no effect. Could you tell me, please, how to fix (set) viewing the warning message, when opening multiple tabs. (If it not possible with settings, than may be with addons).

Tất cả các câu trả lời (10)

more options

Those prefs still work for me when I open all bookmarks in a folder. I usually set the pref to 1to avoid opening a lot of tabs by accident.

The Tab warn items in "Options/Preferences > General or Tabs" are hidden when the related prefs have the default value. They only show when you toggle the prefs on the about:config page. Note that this may require to close and restart Firefox.

  • "Warn me when closing multiple tabs" (browser.tabs.warnOnClose)
  • "Warn me when opening multiple tabs might slow down Firefox" (browser.tabs.warnOnOpen)
more options

Even though I can only attest to Firefox 42, this feature still exists in the "live" code base on https://dxr.mozilla.org/mozilla-central/source/browser/components/places/PlacesUIUtils.jsm#695

Do you use any tab-related extensions that might modify this feature?

more options

Note that your System Details List shows multiple Flash plugins.

  • Shockwave Flash 19.0 d0
  • Shockwave Flash 20.0 d0

You can find the installation path of all plugins on the about:plugins page.

You can check the Flash player installation folder for multiple Flash player plugins and remove older version(s) of the plugin (NPSWF32) and possibly (re)install the latest Flash player.

  • (32 bit Windows) C:\Windows\System32\Macromed\Flash\
  • (64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\
more options

1) Changing browser.tabs.warnOnOpen to true - didn't effect. 2) Disabling all addons - didn't effect. 3) Enabling 'Warn me when opening multiple tabs might slow down Firefox' in Options/Preferences after changing it to false in about:config - didn't effect. 4) Deleting Shockwave Flash 19.0 d0 - didn't effect.

more options

Were the warn items set to false or already true (default)/ Do the Warn items appear in "Options > General" if you set the warn prefs to false?

Note that you should leave the warnings enabled, so change the prefs only for testing and close and restart Firefox after modifying these prefs or if you place a checkmark in Options.


Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

In first place the warn items in about:config were enabled (true), and "Options > General" had no record of Warn items, and the browser didn't gave any warn messages. After that I launched browser in Safe Mode with DEFAULT theme, and opened 20 tabs, but the browser still didn't gave any warn messages. Then I changed browser.tabs.warnOnOpen to false, restart browser and checked Warn me when opening multiple tabs might slow down Firefox in Options/Preferences - still no effect. At the end I installed new Windows 10 and Firefox Developer Edition 44 version only, without any addons and plugins, but warning messages still didn't appeared.

If the browser.tabs.warnOnOpen not working in Firefox DE 44, maybe there is any addon with the same function?!

more options

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Nizaury said

In first place the warn items in about:config were enabled (true), and "Options > General" had no record of Warn items, and the browser didn't gave any warn messages.
After that I launched browser in Safe Mode with DEFAULT theme, and opened 20 tabs, but the browser still didn't gave any warn messages. Then I changed browser.tabs.warnOnOpen to false, restart browser and checked Warn me when opening multiple tabs might slow down Firefox in Options/Preferences - still no effect.

How did you open the 20 tabs? I believe this warning is for when you open a folder of 15 or more bookmarks using the item "Open All in Tabs" and may not appear in any other situations. Did it used to appear in other situations?

more options

jscher2000 said

Nizaury said
In first place the warn items in about:config were enabled (true), and "Options > General" had no record of Warn items, and the browser didn't gave any warn messages.
After that I launched browser in Safe Mode with DEFAULT theme, and opened 20 tabs, but the browser still didn't gave any warn messages. Then I changed browser.tabs.warnOnOpen to false, restart browser and checked Warn me when opening multiple tabs might slow down Firefox in Options/Preferences - still no effect.

How did you open the 20 tabs? I believe this warning is for when you open a folder of 15 or more bookmarks using the item "Open All in Tabs" and may not appear in any other situations. Did it used to appear in other situations?

When I tried to open more then 15 bookmarks at the same time the warning message working normally (appears), but when I open one by one - I can open a lot of them, and I don't see any message.

more options

The warning message only work if you open multiple links at once like happens with "Open All in Tabs". You won't need such a warning if you open each of the links individually in tabs because then you are in control yourself. Showing a warning in that case wouldn't make sense.