Impossível adicionar, alterar ou guardar marcadores - Como corrigir

Este artigo mostra-lhe o que fazer se não consegue adicionar marcadores ou efetuar outras alterações aos seus marcadores.

Nota: Se tem conseguido guardar marcadores mas estes agora desapareceram, consulte Recuperar marcadores perdidos ou em falta.

Não consigo adicionar ou alterar marcadores

Se não consegue adicionar novos marcadores ou se as alterações que você efetua à barra de ferramentas não são guardadas quando reinicia Firefox, consulte Alterações às barras de ferramentas e tamanhos da janela não são guardadas.

Se não consegue adicionar novos marcadores ou se as alterações aos seus marcadores e tem uma extensão do Firefox relacionada com marcadores instalada (por exemplo, uma que sincroniza marcadores), siga as instruções em Resolver problemas com extensões, temas e aceleração de hardware para resolver problemas frequentes no Firefox para determinar se uma extensão está a causar o problema.

Consigo adicionar ou alterar marcadores mas estes desaparecem quando reinicio o Firefox

Se consegue adicionar, eliminar, reordenar e efetuar outras alterações aos seus marcadores, mas as suas alterações perdem-se sempre que reinicia o Firefox, experimente estas soluções.

Nota: É recomendado que desative quaisquer alterações relacionadas a marcadores, como explicado aqui, antes de continuar com as sugestões sugeridas abaixo.

Corrigir o ficheiro de marcadores

Se as alterações que efetuou aos seus marcadores não aparecem quando reinicia o Firefox, o problema poderá ser que o ficheiro dos seus marcadores é protegido contra gravação. Um ficheiro protegido contra gravação não pode ser alterado, o que impede que o Firefox guarde quaisquer alterações que tenha efetuado.

Permitir que o Firefox guarde as alterações aos marcadores:

  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a Resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaAbrir pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair.

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Clique com o botão direito no ficheiro places.sqlite e selecione Propriedades para abrir a janela Propriedades.
  6. Na janela Propriedades, selecione o separador Geral. Próximo do fundo da janela, verifique que o Apenas de leitura NÃO está selecionado.

    bookmarksnotsaved-readonly.png

Para ativar a gravação do ficheiro dos seus marcadores:

  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a Resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaAbrir pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair.

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Selecione o ficheiro places.sqlite.
  6. A partir da barra de menu, selecione o menu Ficheiro e selecione Obter informações. A janela de informações places.sqlite irá abrir.
  7. Na janela de informações places.sqlite, desmarque a caixa de seleção Bloqueado.

Criar um novo ficheiro de Marcadores

Os marcadores e o histórico de navegação são armazenados na pasta de perfil do Firefox no ficheiro places.sqlite. Se existir algum problema com este ficheiro, as suas alterações aos marcadores poderão ser perdidas sempre que reiniciar o Firefox. Pode forçar o Firefox a criar outro ficheiro places.sqlite eliminando (ou renomeando) o existente.

Aconselhamos a imprimir ou copiar estas instruções para referência, pois terá que fechar o Firefox para eliminar ou renomear os ficheiros.

Aviso: Assim que eliminar o ficheiro places.sqlite, irá perder todo o seu histórico de navegação. O Firefox mantém apenas uma cópia deste ficheiro para o histórico de navegação.
  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a Resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaAbrir pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair.

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Na sua pasta de perfil, encontre e elimine os ficheiros places.sqlite e {places.sqlite-journal} (se existir) ou renomeie-os, por exemplo, para places.sqliteOLD, para manter o ficheiro antigo como uma cópia de segurança) .

O Firefox irá criar um novo ficheiro places.sqlite e importar automaticamente o ficheiro de cópia de segurança de marcadores mais recente. Será criada uma cópia de segurança dos seus marcadores, mas irá perder todo o seu histórico de navegação. Nota que o histórico de navegação é utilizado para a funcionalidade de preenchimento automático da barra de endereço.




Baseado na informação de Bookmarks not saved (mozillaZine KB)

Este artigo foi útil? Por favor, aguarde...

Essas pessoas maravilhosas ajudaram a escrever este artigo: albertdecastro. Você também pode ajudar - descubra como.