Soluções de problemas com plugins como Flash ou Java | Resolução de problemas

Soluções de problemas com plugins como Flash ou Java

Se estiver com problema para ver páginas que usam plugins (como o adobe Flash, Java e outros), verifique se não é o plugin, o causador do problema.

Importante: Atualmente a nova versão de 64 bits do Firefox para Windows só reconhece e suporta o plugin Adobe Flash. Veja este artigo no blog da Mozilla para mais detalhes.
Importante: Atualmente a nova versão de 64 bits do Firefox para Windows só reconhece e suporta os plugins Adobe Flash e Microsoft Silverlight.

Os problemas mais comuns causados por plugins são:

Este artigo descreve como solucionar problemas com plugins. Se estiver tendo problema com extensões ou temas, veja o artigo: Solucione problemas com extensões, temas e aceleração de hardware para resolver problemas comuns do Firefox. Para obter mais informações sobre plugins, veja o artigo: Usar plugins para reproduzir áudio, vídeo, jogos e mais.

Determinando se o problema é um plugin

Os plugins podem ser desativados, enquanto o Firefox é executado. Se suspeitar de um plug-in, desative-o primeiro e verifique se o problema continua. Se não souber qual plug-in desabilitar:

  1. Na parte superior da janela, clique no botão FirefoxNa barra de menu do Firefox, clique em FerramentasNa parte superior da janela, clique em Ferramentas, e depois em Complementos para abrir a aba do gerenciador de complementos. Clique no botão de menu New Fx Menu e selecione Complementos para abrir a aba do gerenciador de complementos.

  2. No gerenciador de complementos, selecione o painel Plugins.
  3. Selecione um plugin da lista e marque Nunca Ativar. Repita este passo para cada plugin na lista, até que todos eles estarem desativados. Será necessário reiniciar o Firefox para que as alterações entrem em vigor.
  4. Verifique se o problema ainda ocorre. Caso não ocorra, volte para a janela de complementos e reative os plugins um por um até encontrar o causador do problema.

Se desativando um plugin corrigiu o problema, continue seguindo os passos descritos neste artigo.

Atualizando e reinstalando seus plugins

Muitos problemas podem ser resolvidos através da atualização do plugin. Para verificar se algum plugin instalado está desatualizado, visite a página de verificação de plugins.

Se a atualização ou a reinstalação do plugin não resolver o problema, você pode deixá-lo desabilitado.

Desinstalando manualmente um plugin

Se não for possível usar um desinstalador para remover um plugin, você pode removê-lo manualmente:

  1. Digite about:plugins na barra de endereço e pressione EnterReturn para ver a página Sobre Plug-ins.
  2. Cada entrada na página Sobre Plugins tem o "Caminho:", que mostra a localização do plugin. Use o Windows Explorer para navegar para o arquivo.
  3. Renomeie o arquivo, por exemplo de npswf32 para Xnpswf32

O plugin será removido.

Reinicializando o banco de dados de plugins

Em alguns casos, pode ser impossível instalar ou reinstalar um plugin. Reinicializar o banco de dados de plugins pode corrigir esse problema:

  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no botão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba com os dados para suporte será aberta.Clique no botão New Fx Menu , depois em ajuda Help-29 e então em Dados para suporte. A aba com os dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se não conseguir abrir ou usar o Firefox, siga as instruções para encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Exclua o arquivo pluginreg.dat.
  6. Abra o Firefox
  7. Na barra de localização digite about:plugins e pressione EnterReturn para ver a lista de plugins do Firefox.
Este artigo foi útil?

Por favor, aguarde...

Contribuidores que ajudaram a escrever esse artigo: Seta00, Apocalypse, ouesten, brwolfgang. Você também pode ajudar - descubra como.

Última atualização: 2016-03-25

Obter suporte para outra plataforma:
Personalizar esse artigo

Firefox