Firefox si blocca

Quando Firefox si blocca, non accetta più i comandi di chi lo sta utilizzando e non risponde ad alcun tipo di azione. Inoltre, verrà visualizzata un'etichetta "(non risponde)" nella barra del titolo e il cursore, quando è posizionato sopra la finestra di Firefox, assume la forma di una rotella che gira (modalità di attesa).Inoltre, il cursore, quando è posizionato sopra la finestra di Firefox, assume la forma di una rotella che gira (modalità di attesa) Questo articolo fornisce le soluzioni relative ai blocchi di Firefox a seconda dei casi in cui si verificano e delle diverse tipologie di blocco.

Per risolvere casi di blocco del programma non specificatamente menzionati in questo articolo o se le soluzioni proposte non consentono la risoluzione del problema, consultare l'articolo Procedure standard per la risoluzione dei problemi.

Nota: La funzione di ripristino di Firefox può essere risolutiva in molte occasioni in quanto consente di riportare Firefox ai suoi valori predefiniti effettuando contemporaneamente il salvataggio delle informazioni personali. È da prendere sicuramente in considerazione prima di avventurarsi in lunghe procedure di risoluzione dei problemi.
Nota: se si acconsente di inviare i dati relative alle prestazioni, gli sviluppatori di Mozilla potranno raccogliere alcuni dati tra cui quelli relativi ai blocchi di Firefox in modo da migliorare le prossime versioni del programma.

Firefox si blocca in maniera casuale

Se il blocco di Firefox si verifica casualmente e non in seguito ad un'azione specifica (ad esempio mentre si sta scaricando un file o alla chiusura del browser), provare le soluzioni proposte in questa sezione.

Creare un nuovo database di places

Se i blocchi sono periodici, potrebbero essere causati da un database di places danneggiato. Per creare un nuovo database di places, seguire la seguente procedura:

Attenzione: la creazione del nuovo database comporterà l'azzeramento di tutta la cronologia di navigazione e la perdita dei segnalibri salvati nell'arco della giornata.
  1. Aprire la cartella del profilo:

    Dal menu in alto nella finestra di Firefox, fare clic sul pulsante Firefox, spostarsi sul menu AiutoSulla barra dei menu, fare clic su AiutoDal menu in alto nella finestra di Firefox, fare clic su Aiuto e selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di aiuto Help-29 , quindi selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.

  2. Nella sezione Informazioni di base, fare clic sul pulsante Mostra cartellaMostra nel FinderApri percorso. Verrà aperta una finestra con i filela cartella del profilo.
  3. Nota: nel caso in cui non sia possibile aprire o utilizzare Firefox, seguire le istruzioni contenute in Individuare il profilo senza avviare Firefox.

  4. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

    Attendere la chiusura completa di Firefox.
  5. All'interno della cartella del profilo di Firefox cercare e rinominare i file places.sqlite in places.sqlite.old e places.sqlite-journal in places.sqlite-journal.old (se presente).
    • Per rinominare un file, fare clic sul file col tasto destro del mouse e nel menu selezionare Rinominafare clic sul nome del file per selezionarlo quindi fare nuovamente clic per poterne modificare il nome. Aggiungere quindi .old alla parte finale del nome del file.
  6. Riavviare quindi Firefox.
    • Al riavvio di Firefox verrà creato un nuovo database di places. La creazione del nuovo database comporterà la perdita della cronologia di navigazione ma verranno reimportati automaticamente in Firefox i segnalibri recuperati dal più recente file di backup (copia di sicurezza).

Disattivare l'accelerazione hardware

Con alcune schede grafiche e impostazioni dei driver grafici, Firefox potrebbe bloccarsi quando si utilizza l'accelerazione hardware. Provare a disattivare l'accelerazione hardware per verificare se il problema si risolve.

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e selezionare Opzioni.Dal menu in alto nella finestra di Firefox fare clic sul menu Strumenti e selezionare Opzioni.Dalla barra dei menu fare clic sul menu Firefox e selezionare Preferenze....Dal menu in alto nella finestra di Firefox fare clic sul menu Modifica e selezionare Preferenze.

    Fare clic sul pulsante dei menu New Fx Menu e selezionare OpzioniPreferenze.

  2. Selezionare il pannello Avanzate e la scheda Generale.
  3. Deselezionare la casella Utilizza l'accelerazione hardware quando disponibile.
  4. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  5. Avviare Firefox normalmente.

Se il problema non si verifica più, allora la probabile causa era dovuta all'utilizzo dell'accelerazione hardware. Provare ad aggiornare i driver grafici per verificare se il problema si risolve o semplicemente non utilizzare l'accelerazione grafica.

Risolvere i problemi causati dai plugin

I siti web che utilizzano plugin come Java, Adobe Reader o Flash, possono causare il blocco di Firefox. Per ottenere informazioni sulla risoluzione dei problemi relativi ai plugin e per determinare se un plugin sta causando problemi, leggere l'articolo Risoluzione dei problemi relativi ai plugin.

Eliminare i file di ripristino sessione duplicati

Firefox potrebbe risultare lento nel rispondere ai comandi o bloccarsi se sono state create più copie del file che controlla il Ripristino della sessione:

  1. Aprire la cartella del profilo:

    Dal menu in alto nella finestra di Firefox, fare clic sul pulsante Firefox, spostarsi sul menu AiutoSulla barra dei menu, fare clic su AiutoDal menu in alto nella finestra di Firefox, fare clic su Aiuto e selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di aiuto Help-29 , quindi selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.

  2. Nella sezione Informazioni di base, fare clic sul pulsante Mostra cartellaMostra nel FinderApri percorso. Verrà aperta una finestra con i filela cartella del profilo.
  3. Nota: nel caso in cui non sia possibile aprire o utilizzare Firefox, seguire le istruzioni contenute in Individuare il profilo senza avviare Firefox.

  4. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  5. Individuare ed eliminare il file sessionstore.js e qualsiasi copia come ad esempio sessionstore-1.js, sessionstore-2.js.

Cambiare la configurazione PAC

Se si sta utilizzando un file di configurazione automatica dei proxy (PAC), Firefox può bloccarsi mentre si cerca di caricare siti inesistenti o che non sono stati aperti di recente. Per determinare se si sta utilizzando un file di configurazione automatica dei proxy:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e selezionare Opzioni.Dal menu in alto nella finestra di Firefox fare clic sul menu Strumenti e selezionare Opzioni.Dalla barra dei menu fare clic sul menu Firefox e selezionare Preferenze....Dal menu in alto nella finestra di Firefox fare clic sul menu Modifica e selezionare Preferenze.

    Fare clic sul pulsante dei menu New Fx Menu e selezionare OpzioniPreferenze.

  2. Fare clic sull'icona Avanzate.
  3. Fare clic sulla scheda Rete.
  4. Fare clic su Impostazioni. Verrà visualizzata la finestra di dialogo Impostazioni di connessione.
  5. Se è selezionata l'opzione Configurazione automatica dei proxy (URL):, si sta utilizzando un file di configurazione automatica dei proxy. Non è opportuno disattivare questa opzione poiché si potrebbe impedire a Firefox l'accesso a Internet; fornire invece questo link al proprio amministratore di rete.
  6. Fare clic su Annulla.

Blocco di Firefox durante la riproduzione di filmati Flash

Leggere Blocco di Firefox durante la riproduzione di filmati Flash.

Blocco di Firefox dopo un utilizzo prolungato

Aggiornare Firefox

Le ultime versioni di Firefox includono miglioramenti sull'uso della memoria anche durante lunghe sessioni. Aggiornare Firefox alla versione più recente.

Riavviare Firefox

Firefox può bloccarsi se viene lasciato aperto per lunghi periodi. Per risolvere il problema, riavviare Firefox.

Se è consuetudine lasciare Firefox aperto per ritornare solo in seguito alla sessione in uso, è consigliabile utilizzare la funzione di ripristino sessione. Per maggiori informazioni, leggere Personalizzare il ripristino delle sessioni.

Blocco di Firefox durante il caricamento della finestra della pagina iniziale

Accelerare il ripristino della sessione

In caso di ripristino di molte schede, potrebbe verificarsi un blocco di Firefox mentre carica quei siti. Assicurarsi che sia selezionata la casella Non caricare le schede prima che vengano selezionate nel pannello Schede della finestra delle OpzioniPreferenze in modo che all'avvio venga caricata solo l'ultima scheda selezionata. Si può anche provare ad utilizzare i Gruppi di schede in modo che vengano caricati per primi solo i siti web presenti nella scheda visiva del gruppo.

Blocco di Firefox durante il download di file o il salvataggio di immagini

Se Firefox si blocca mentre si esegue il download di un file o il salvataggio di un'immagine, provare le soluzioni riportate di seguito:

Cancellare la cronologia dei download

Firefox può bloccarsi mentre si esegue il download di file se l'elenco dei file scaricati è diventato troppo lungo. Per cancellare la cronologia dei download:

  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox (menu Strumenti in Windows XP) e selezionare DownloadSulla barra dei menu, fare clic sul menu Strumenti e selezionare DownloadNella parte superiore della finestra di Firefox, fare clic sul menu Strumenti e selezionare Download. Verrà visualizzata la finestra di dialogo Download.Fare clic sul pulsante Download fx20 download icon e selezionare Visualizza tutti i download per aprire la finestra della Libreria.
  2. Fare clic su Cancella elenco per cancellare la cronologia dei download.Cancella elenco download per cancellare la cronologia dei download.
  3. Eseguire il download di uno o più file per verificare se l'errore continua a presentarsi.

Utilizzare una cartella di destinazione diversa per i file scaricati

Firefox potrebbe bloccarsi se l'ultima cartella di destinazione scelta per salvare i file scaricati (per esempio una cartella condivisa o un'unità rimovibile USB) non è più disponibile. Per risolvere questo problema:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e selezionare Opzioni.Dal menu in alto nella finestra di Firefox fare clic sul menu Strumenti e selezionare Opzioni.Dalla barra dei menu fare clic sul menu Firefox e selezionare Preferenze....Dal menu in alto nella finestra di Firefox fare clic sul menu Modifica e selezionare Preferenze.

    Fare clic sul pulsante dei menu New Fx Menu e selezionare OpzioniPreferenze.

  2. Selezionare il pannello Generale.
  3. Alla voce Download, fare clic su Salva file in.
  4. Per scegliere una cartella diversa, fare clic su Sfoglia...Scegli... e nella finestra successiva selezionare una cartella per il salvataggio dei file scaricati.
  5. Fare clic su OK per chiudere la finestra delle opzioniFare clic su Chiudi per chiudere la finestra delle preferenzeChiudere la finestra delle preferenze.

Verificare se ora è possibile scaricare file o salvare immagini. Se il problema è risolto, è possibile tornare alla propria configurazione di Firefox e, se si desidera, selezionare l'opzione Chiedi dove salvare ogni file.

Disattivare la scansione antivirus nelle preferenze di Firefox

Con alcuni antivirus si verifica il blocco di Firefox quando il programma esegue la scansione dei file appena scaricati. È possibile disattivare la scansione utilizzando la seguente procedura (che non inficerà il funzionamento del programma antivirus):

  1. Digitare about:config nella Barra degli indirizzi e premere Invio.

    • Se compare il messaggio "Questa operazione potrebbe invalidare la garanzia", fare clic sul pulsante Farò attenzione, prometto per visualizzare la pagina di about:config.
  2. Individuare la preferenza browser.download.manager.scanWhenDone e fare clic su di essa per modificare il valore in false.

Blocco di Firefox durante l'eliminazione di una cartella dei segnalibri

L'eliminazione di una cartella dei segnalibri che contiene molti elementi e più livelli di sottocartelle può provocare il blocco di Firefox. Per aggirare questo problema, eliminare le sottocartelle dei segnalibri non necessarie in più passaggi.

Blocco di Firefox all'uscita dal programma

Alcune volte, chiudendo Firefox, è possibile che il programma smetta di rispondere e resti in memoria pur non essendo aperta alcuna finestra di Firefox. Questo può far sì che al riavvio di Firefox si possano riscontrare problemi o che possa comparire una finestra di dialogo "Chiudi Firefox" con il messaggio Firefox è già avviato ma non risponde. Per aprire una finestra si deve prima chiudere il processo esistente di Firefox o riavviare il sistema. Chiudere tutti i processi di Firefox o riavviare il computer prima di riaprire Firefox. Per individuare altre cause e le soluzioni, leggere l'articolo Firefox è già avviato ma non risponde.

Chiudere completamente Firefox

  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  2. Chiudere tutte le finestre di dialogo o le finestre secondarie come la finestra dei download.


Se il problema dei processi di Firefox che restano in memoria è ricorrente, tentare le soluzioni riportate di seguito:

Risolvere i problemi causati dalle estensioni

Il problema potrebbe essere causato da un'estensione problematica e può essere risolto disattivando o disinstallando l'estensione. Per maggiori informazioni su come verificare e risolvere i problemi causati da estensioni difettose, leggere l'articolo Risoluzione dei problemi relativi a estensioni e temi.

Aggiornare o disattivare il plugin Java

In alcuni casi, le applicazioni Java possono causare il persistere del processo di Firefox anche dopo la sua chiusura. Cercare di aggiornare Java all'ultima versione visitando la pagina di controllo plugin di Mozilla o, se il plugin Java non è necessario, disattivarlo dal pannello Plugin della finestra Componenti aggiuntivi di Firefox. Per maggiori informazioni, leggere l'articolo Informazioni su Java.

Risolvere i problemi causati dai programmi di sicurezza per la navigazione in Internet

Le interazioni tra alcuni programmi di sicurezza per la navigazione in Internet (firewall, programmi antivirus, antispyware, ecc.) sono una delle più note cause di problemi per diversi sistemi operativi. Provare a configurare il firewall utilizzato per capire se il problema si risolve.




Questo articolo è basato sulle informazioni contenute in Firefox hangs (mozillaZine KB)



Condividi questo articolo: http://mzl.la/MP6ZBS

È stato utile questo articolo? Attendere...

Utenti che hanno contribuito a scrivere questo articolo: underpass, michro. Tutti possono contribuire.