Las preferencias no se guardan

This page does not exist in Euskara. You have been redirected to the Español version instead. If you would like to localize it into Euskara, click here. You can also see the English version of this page.

A veces, es posible que la configuración de Firefox no se guarde después de cambiarla. Por ejemplo, puedes cambiar una opción en la ventana de OpcionesPreferencias de Firefox y que la próxima vez que vuelvas a abrir el panel de OpcionesPreferencias, no se haya cambiado nada.

Las posibles causas y soluciones varían dependiendo de si no puedes guardar algunas preferencias o ninguna en absoluto. Este artículo también es válido si, tras actualizar Firefox, se abre la pestaña Se actualizó Firefox, que te redirige cada vez que inicias Firefox a la página Has actualizado Firefox a la última versión.


Reinicia Firefox para solucionar el problema

Lo más fácil en estos casos es restablecer Firefox a sus valores de fábrica (no olvides guardar toda la información importante antes de hacerlo). Además de restaurar todas las preferencias, también puedes reiniciar Firefox para solucionar muchos problemas, incluidos aquellos relacionados con extensiones o con información y opciones almacenadas en otros archivos de tu perfil de Firefox. Si prefieres probar con algo más específico, continúa leyendo la siguiente sección.

Nota: Al usar la característica "Restablecer", se guardarán tus marcadores, historial de navegación, pestañas y ventanas que tengas abiertas, contraseñas, cookies e información de autocompletado de formularios web. Sin embargo, se eliminarán tus extensiones y temas y se restablecerán tus preferencias. Al usar la característica "Restablecer", se guardarán tus marcadores, historial de navegación, pestañas y ventanas que tengas abiertas, contraseñas, cookies e información de autocompletado de formularios web. Sin embargo, se eliminarán tus extensiones y temas y se restablecerán tus preferencias. Al usar la característica restablecer, se guardarán tus marcadores, historial de navegación, contraseñas, cookies e información de autocompletado de formularios web. Sin embargo, se eliminarán tus extensiones y temas y tampoco se guardarán las pestañas, ventanas y grupos de pestañas abiertas. Se restablecerán tus preferencias. Más información aquí.

  1. Haz clic en el botón de menú New Fx Menu y, a continuación, en Ayuda Help-29 .
  2. En el menú Ayuda, elige Información para solucionar problemas.
    Si no puedes acceder al menú Ayuda, escribe about:support en la barra de direcciones para que te aparezca la página Información para solucionar problemas.
  3. En la esquina superior derecha de la página Información para solucionar problemas, haz clic en el botón Restablecer Firefox.
    Refresh 35 Win Refresh 35 Mac Refresh 35 Lin
  4. Para continuar, haz clic en Restablecer Firefox en la ventana de confirmación que se abre.
  5. Firefox se cerrará para poder restablecerse. Cuando acabe, te aparecerá una ventana con toda la información que se ha importado. Haz clic en Finalizar y Firefox se volverá a abrir.
Nota: El botón Reiniciar Firefox también se encuentra en la ventana del Modo seguro, en caso de que no puedas iniciar Firefox de forma normal. Si no encuentras el botón Reiniciar en tu versión de Firefox, también puedes hacerlo de forma manual creando un nuevo perfil. Consulta estas instrucciones para saber cómo crear un nuevo perfil.

Algunas preferencias específicas no se guardan

Si una opción específica se restablece continuamente o no puedes cambiar una opción específica pero otras opciones se guardan correctamente, puedes tener uno de los siguientes problemas:

Programas de terceros que cambian opciones de Firefox

Algunos programas fuerzan a Firefox a usar ciertas opciones. Debajo hay una lista de programas conocidos que hacen esto, junto a las acciones que puedes tomar para que dejen de forzar opciones de Firefox:

  • Creative ZenCast cambia el agente de usuario de Firefox, interfiriendo con Java.
    • Desinstala el programa
  • McAfee Privacy Service desactiva el bloqueo de ventanas emergentes de Firefox.
  • Norton 360 incluye una funcionalidad llamada "Limpieza de la privacidad de Firefox" que, si se activa, ignora tus opciones de privacidad de Firefox y evita que mantengas tu historial de navegación, las cookies o los datos privados de las sesiones.

Algunas barras de herramienta o complementos de terceros cambian la página de inicio de Firefox y las preferencias de búsqueda. Puedes restablecerlos de una forma muy sencilla con el complemento SearchReset.

El archivo user.js ignora la configuración de Firefox

Si no tienes instalado ninguno de los programas mencionados anteriormente o si has seguido las instrucciones y los cambios no permanecen, puede que tengas que editar directamente los archivos de configuración de Firefox. No te preocupes, es muy fácil. Así es como se hace:

  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.Haz clic en el botón de menú New Fx Menu , en Ayuda Help-29 y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaAbrir carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona SalirEn la barra de menú, haz clic en el menú Firefox y selecciona Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón de menú New Fx Menu y selecciona SalirQuit Close 29 .

  5. Abre el archivo user.js con un editor de texto (como el bloc de notasGedit, Lefpad o KateTextEdit).
    • Si no existe el archivo user.js, entonces estos pasos no te van a servir de ayuda.
  6. Elimina las líneas para las preferencias del usuario que quieres poder cambiar. Puedes borrar todas las líneas si quieres poder cambiar todo.
  7. Guarda el archivo y cierra el editor de texto.

Ahora deberías poder cambiar tus preferencias de Firefox.

El archivo de programas de Firefox bloquea o impide cambios de ciertos ajustes

Durante la instalación de Firefox puede que se haya añadido un archivo de configuración que bloquee ciertos ajustes o impida que se guarden algunos campios. Sigue los pasos para Reinstalar Firefox en el artículo Resolución y diagnóstico de problemas con Firefox para eliminar ese programa de Firefox de tu ordenador y volver a instalar una nueva copia de Firefox. (Reinstalar Firefox de esta forma no eliminará tus perfiles, contraseñas, marcadores y otros datos de usuario, ya que no están guardados en la carpeta de archivos de programas).

No puedo guardar ninguna preferencia

Si no se puede guardar ninguna de las preferencias, si ves una pestaña con el mensaje Firefox actualizado cada vez que inicias Firefox, o si has seguido los pasos indicados anteriormente pero no han funcionado, el archivo que usa Firefox para guardar tus preferencias puede haberse bloqueado o corrompido.

El archivo de preferencias está bloqueado

Puede ocurrir que Firefox no pueda guardar tus preferencias si el archivo prefs.js (o el archivo prefs.js.moztmp, si existe) esté protegido contra escritura o haya otros archivos de copia de seguridad de las preferencias.

  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.Haz clic en el botón de menú New Fx Menu , en Ayuda Help-29 y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaAbrir carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona SalirEn la barra de menú, haz clic en el menú Firefox y selecciona Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón de menú New Fx Menu y selecciona SalirQuit Close 29 .

  5. Localiza el archivo prefs.js (y, si existe, el archivo prefs.js.moztmp).
  6. Pulsa con el botón derecho en cada archivo y luego selecciona Propiedades en el menú contextual. Comprueba que en Atributos, no está marcada la casilla que hay junto a Sólo lectura en cada archivo.
    • Si tienes RealPlayer abierto, puede estar bloqueando el archivo prefs.js. Si cierras RealPlayer debería desbloquearse.
  7. Borra cualquier archivo con el nombre prefs-n.js, donde n es un número (p. ej. prefs-2.js).
  8. Si existe el archivo Invalidprefs.js, bórralo.
  9. Reinicia Firefox. Ahora deberías poder guardar tus preferencias.
  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.Haz clic en el botón de menú New Fx Menu , en Ayuda Help-29 y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaAbrir carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona SalirEn la barra de menú, haz clic en el menú Firefox y selecciona Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón de menú New Fx Menu y selecciona SalirQuit Close 29 .

  5. Localiza el archivo prefs.js (y, si existe, el archivo prefs.js.moztmp).
  6. Para cada archivo, asegúrate de que tu usuario tiene permiso de escritura.
  7. Borra cualquier archivo con el nombre prefs-n.js, donde n es un número (p. ej. prefs-2.js).
  8. Si existe el archivo Invalidprefs.js, bórralo.
  9. Reinicia Firefox. Ahora deberías poder guardar tus preferencias.
  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.Haz clic en el botón de menú New Fx Menu , en Ayuda Help-29 y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaAbrir carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona SalirEn la barra de menú, haz clic en el menú Firefox y selecciona Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón de menú New Fx Menu y selecciona SalirQuit Close 29 .

  5. Localiza el archivo prefs.js (y, si existe, el archivo prefs.js.moztmp).
  6. Para cada archivo, mantén pulsada la tecla Ctrl mientras pulsas en el archivo, y luego selecciona Obtener información.
  7. Asegúrate de que la opción Bloqueado está desmarcada.
  8. Borra cualquier archivo con el nombre prefs-n.js, donde n es un número (p. ej. prefs-2.js).
  9. Si existe el archivo Invalidprefs.js, bórralo.
  10. Reinicia Firefox. Ahora deberías poder guardar tus preferencias.

El archivo de preferencias se ha corrompido

El archivo de preferencias puede estar corrompido, lo que impedirá que Firefox escriba en él. Si eliminas este archivo, Firefox creará uno automáticamente cuando lo necesite. Para eliminar el archivo prefs.js, haz lo siguiente:

Esta acción eliminará todas tus preferencias de usuario y las de muchas de tus extensiones
  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.Haz clic en el botón de menú New Fx Menu , en Ayuda Help-29 y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaAbrir carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona SalirEn la barra de menú, haz clic en el menú Firefox y selecciona Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón de menú New Fx Menu y selecciona SalirQuit Close 29 .

  5. Localiza el archivo prefs.js (y, si existe, el archivo prefs.js.moztmp).
  6. Asegúrate de que la opción Bloqueado está desmarcada.
  7. Borra esos archivos y cualquier otro con el nombre prefs-n.js, donde n es un número (p. ej. prefs-2.js).
  8. Si existe el archivo Invalidprefs.js, bórralo.
  9. Reinicia Firefox. Ahora todas tus preferencias deben estar restablecidas a sus valores iniciales.

Otras soluciones

  • Puede que tu problema se deba a malware. Para más información, consulta el artículo Problemas en Firefox provocados por malware.
  • Algunos software, como Advanced SystemCare con protección de navegación pueden proteger y evitar cambios en los archivos de la carpeta de perfil de Firefox. Si tienes instalado ese tipo de software, comprueba la configuración o desinstálalo.



Basado en información de Preferences not saved (mozillaZine KB)

Artikulua lagungarria izan da? Itxaron mesedez...

These fine people helped write this article: willyaranda, omgs, avelper, zupe. You can help too - find out how.