Recuperar datos importantes desde un perfil anterior

En un perfil de Firefox se almacenan todos los datos importantes para el usuario, como marcadores, historial, cookies y contraseñas. En este artículo se explica cómo copiar los archivos a un nuevo perfil, se listan los archivos importantes dentro del perfil y se describe qué información se almacena en estos archivos.

Si tienes un problema con Firefox, en vez de intentar buscar y corregir el origen, a veces es más fácil hacer un nuevo perfil de Firefox y copiar los datos más importantes en ese perfil. La función de Restablecer Firefox lo hará automáticamente.

Nota: Debido a que tus preferencias y extensiones son a menudo la causa de la mayoría de los problemas, en este artículo no se explica cómo copiar tus preferencias y tus extensiones entre diferentes perfiles. Por lo tanto, si sigues los pasos de este artículo, tendrás que reinstalar las extensiones y volver a configurar tus preferencias de Firefox.

Haz una copia de tu perfil

Antes de empezar, te recomendamos que hagas una copia de seguridad completa de tu perfil de Firefox para que, en caso de que algo vaya mal, puedas restaurarlo sin problemas. Consulta el artículo Hacer una copia de seguridad y restaurar tu información en los perfiles de Firefox para obtener más instrucciones sobre cómo hacer una copia de seguridad de tu perfil.

Crea un nuevo perfil de Firefox

Para obtener información sobre cómo crear un nuevo perfil de Firefox, consulta el artículo Usar el Administrador de perfiles para crear y eliminar perfiles de Firefox, prestando especial atención a la sección Crear un nuevo perfil.

Copiar archivos entre las carpetas del perfil

Nota: Firefox debe estar cerrado mientras copias los archivos entre las carpetas de los perfiles.
  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.Haz clic en el botón de menú New Fx Menu , en Ayuda Help-29 y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona SalirEn la barra de menú, haz clic en el menú Firefox y selecciona Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón de menú New Fx Menu y selecciona SalirSalir Close 29 .

  5. Haz clic con el botón secundarioPresiona la tecla Ctrl mientras haces clic en el archivo que deseas copiar y selecciona Copiar.
  6. Abre la nueva carpeta del perfil de Firefox.
  7. Haz clic con el botón secundarioPresiona la tecla Ctrl mientras haces clic dentro de la carpeta del perfil y selecciona el elemento de menú Pegar elemento.

Repite los pasos 4-6 para cada archivo que deseas copiar a la nueva carpeta del perfil.

Durante el proceso de copia de tus datos personales de un antiguo perfil de Firefox a uno nuevo, es posible que puedas copiar el archivo que está causando el problema que intentas resolver. A mayor número de archivos a copiar, mayor será la probabilidad de que esto ocurra. Por ello te recomendamos que hagas lo siguiente:

  • Copia la cantidad mínima de archivos: solo los que contienen los datos más importantes, es decir, aquellos sin los que no puedes trabajar correctamente.
  • Copia solo algunos archivos y luego intenta comprobar si el problema que intentas resolver ha desaparecido o no.

Datos importantes y archivos

Marcadores, descargas e historial de navegación

  • {filepath places.sqlite}

Este archivo contiene todos los marcadores de Firefox y listas de archivos que has descargado y de sitios web que has visitado anteriormente. Para obtener más información, consulta Cómo usar los marcadores para guardar y organizar tus páginas favoritas.

Contraseñas

Las contraseñas se almacenan en dos archivos diferentes que son obligatorios:

  • key3.db - Este archivo almacena la clave de la base de datos de contraseñas. Para transferir las contraseñas guardadas, debes copiar este archivo junto con el siguiente archivo.
  • logins.json - Contraseñas guardadas.

Para obtener más información, puedes consultar el artículo Administrador de contraseñas: recordar, borrar y cambiar contraseñas guardadas en Firefox.

Preferencias específicas de los sitios web

  • permissions.sqlite

Este archivo almacena muchos de los permisos de Firefox que se deciden en función de cada sitio web. Por ejemplo, almacena los sitios a los que se permite o se bloquea las opciones de configurar cookies, instalar extensiones, mostrar imágenes, ventanas emergentes, etc.

Los motores de búsqueda

  • search.json

Este archivo almacena información sobre los motores de búsqueda disponibles en Firefox.

  • searchplugins

Esta carpeta incluye los archivos de los motores de búsqueda que instala el usuario. Para más información, consulta los artículos La barra de búsqueda: elige fácilmente tus buscadores favoritos y Agregar o quitar un buscador en Firefox.

  • search.json.mozlz4

Este archivo almacena los motores de búsqueda instalados por el usuario. Para obtener más información, consulta los artículos La barra de búsqueda: elige fácilmente tus buscadores favoritos y Agregar o quitar un buscador en Firefox.

Diccionario personal

  • persdict.dat

Este archivo almacena todas las palabras que has agregado al diccionario de Firefox. Si nunca lo has hecho, entonces no tendrás este archivo. Para obtener más información, consulta el artículo Usar el corrector ortográfico.

Historial de autocompletado

  • formhistory.sqlite

Este archivo recuerda lo que has buscado en la barra de búsqueda de Firefox y la información que has introducido en los formularios de los sitios web. Para obtener más información, consulta el siguiente artículo Función autocompletar para formularios.

Cookies

  • cookies.sqlite

Las páginas web utilizan las cookies para diversas funciones, como mantener la sesión iniciada en un sitio web una vez registrado en él, recordar las preferencias de un sitio web al que se le ha permitido establecerlas, para autenticarte como la persona que ha visitado un sitio web específico antes, etc.

Configuración de los certificados

  • cert8.db

Este archivo almacena la configuración de los certificados de seguridad y de todos los certificados SSL importados en Firefox.

Tipos de archivos y acciones para las descargas

  • mimeTypes.rdf

Este archivo almacena tus preferencias con respecto a lo que hace Firefox cuando se trata de tipos de archivo conocidos, como dónde quieres guardar un archivo o con qué aplicación quieres abrir un determinado tipo de archivo. Para obtener más información, consulta el artículo Administrar los diferentes tipos de archivo.



Basado en información extraída de Transferir los datos a un nuevo perfil - Firefox (mozillaZine KB)

¿Te resultó útil este artículo? Espera por favor...

Esta gente maravillosa ayudó a escribir este artículo: willyaranda, Breaking_Pitt, inma_610, avelper, xim88, Yllelder, zupe. Tú también puedes ayudar, descubre cómo hacerlo.