Lost all tabs from previous session and standard fixes don't work

My Firefox settings are configured to "Open previous windows and tabs" on Startup. This worked fine until this morning, when I lost all of the tabs in my session, includi… (read more)

My Firefox settings are configured to "Open previous windows and tabs" on Startup. This worked fine until this morning, when I lost all of the tabs in my session, including the pinned ones. The last time I closed Firefox, there was only one window open.

I have already tried these ideas to restore the tabs:

  • CTRL+SHIFT+T: Does nothing
  • CTRL+SHIFT+N: Does nothing
  • Three bar menu -> History -> Recently closed tabs: The list is empty
  • Three bar menu -> History -> Recently closed windows: The option is greyed out
  • Three bar menu -> History -> Restore previous session: The option does not exist in the menu
  • Open user profile folder and open sessionstore-backups folder: There are three files named "previous.jsonlz4", "recovery.baklz4" and "recovery.baklz4". They are each 2KB and contain only an empty tab with the URL "about:home". There are three additional files starting with "upgrade" but they are from too long ago, so they don't contain the tabs I require.

The contents of these tabs are vitally important for my work, so this is causing me significant stress. If anyone can suggest ways to recover my previous tab beyond the documented fixes, I would greatly appreciate it. Thank you so much to anyone who can help!

Asked by king__lego 1 week ago

Last reply by king__lego 19 hours ago

Commentary No Longer Visable On Multiple Websites

The last Firefox update, 126.0 (64bit), that was installed 2 days ago has caused various website's commentary or forums to not be displayed. For example, Yahoo finance pa… (read more)

The last Firefox update, 126.0 (64bit), that was installed 2 days ago has caused various website's commentary or forums to not be displayed. For example, Yahoo finance page, attempting to read the "community" section of a particular stock such as Walmart (WMT) nothing is displayed. This happens also on news websites that allow commentary. Google Chrome does display commentary but I don't like using Google.

This is not the first time commentary has not being displayed after an update. Happened a couple of times last year.

The desktop pc is running Windows 11, version 23H2.

Thanks, Frank

Asked by Clovis People 1 day ago

scheduled task running

ive built a new pc and have a flashing program popup every 10min. upon assistance from a really good pc guy, we've found its a firefox default browser agent with a long … (read more)

ive built a new pc and have a flashing program popup every 10min. upon assistance from a really good pc guy, we've found its a firefox default browser agent with a long code.

its not listed in my scheduled tasks, eyt runs every 10min. only thing close to firefox would be thrunderbird, but iirc, mozilla and thunderbird are not longer the same company. either way. i need this thing to stop running every 10min.

Asked by Brett Isaacs 3 days ago

Last reply by Brett Isaacs 2 days ago

Link Previews

When photos, videos, or websites are linked on a FB comment, it used to display a thumbnail preview below the comment. Now it just shows the link. On mobile, the previe… (read more)

When photos, videos, or websites are linked on a FB comment, it used to display a thumbnail preview below the comment. Now it just shows the link. On mobile, the preview appears. So I'm thinking a setting got changed on the desktop version.

Does anyone know what the issue is and how to correct?

Asked by m267 1 week ago

Last reply by m267 6 days ago

Problem with Mozilla Firefox webpage access

Greetings, Mozilla Community I'm contacting you to ask for help with a problem I'm having with Mozilla Firefox when attempting to visit the website https://proroofingcon… (read more)

Greetings, Mozilla Community

I'm contacting you to ask for help with a problem I'm having with Mozilla Firefox when attempting to visit the website https://proroofingcontractorgreenville.com/. The website won't load, and I'm not sure if that's because of a technical glitch, incompatibility with certain browsers, or anything the browser may be obstructing.

Has anyone else had this problem or has advice on how to fix it? I've tried removing extensions and cleaning the cache on my browser, but the issue still exists.

Any advice or tips on how to navigate the website more easily would be much valued. I'm grateful for your support in advance.

Asked by Alblim Ubtel 6 days ago

Remove time and date stamp from documents

I have scoured the web and read/tried everything. I cannot remove the time and date stamp from my documents. No matter what program/app they are printed from it shows up … (read more)

I have scoured the web and read/tried everything. I cannot remove the time and date stamp from my documents. No matter what program/app they are printed from it shows up ruining my printing. I've tried unchecking the header/footer box. There's nothing in my brother printer set up regarding the date/time stamp. It has to be firefox. How do I fix this? I'm not a computer guru so I need details. I'm at my whits end! Thanks!

Asked by penngrad74 6 days ago

Firefox deleting pdfs downloaded in private mode

I had downloaded a couple of pdfs from google drive via private browsing which were stored in my 'Downloads' folder. But as soon as I closed the window the pdfs were dele… (read more)

I had downloaded a couple of pdfs from google drive via private browsing which were stored in my 'Downloads' folder. But as soon as I closed the window the pdfs were deleted. I had also downloaded a zip file which wasn't deleted.

Asked by llxphltc 5 days ago

Last reply by llxphltc 5 days ago

Watching a series of tutorials from the Phlearn site. Does not auto advance to next video. Usually recommences the just watched video. Do not have this problem on other browsers

There seems to be something specific to the Phlearn site and Firefox which prevents videos from auto advancing. They either recommence the just completed video or revert … (read more)

There seems to be something specific to the Phlearn site and Firefox which prevents videos from auto advancing. They either recommence the just completed video or revert to an earlier one.

Asked by jpettett 5 days ago

[Firefox Memory Leak

Hi, I recently facing an issue that the Firefox browser randomly maxed out my RAM and went unresponsive. Like the screenshot below, I am only trying to open Facebook a… (read more)

Hi,

I recently facing an issue that the Firefox browser randomly maxed out my RAM and went unresponsive. Like the screenshot below, I am only trying to open Facebook and Instagram, 2 tabs.

I have tried to open about:memory and about:processes to monitor but it just went unresponsive and both the monitoring just hanged.

Have no idea why the Firefox process taking up so much RAM. Need help.

Asked by icefire94 1 week ago

Last reply by icefire94 5 days ago

Not able to load sites

I was able to open reddit.com without any problems earlier, but recentrly I'm not able to load it up anymore. The loading screen is eternal and it doesnt show any kind of… (read more)

I was able to open reddit.com without any problems earlier, but recentrly I'm not able to load it up anymore. The loading screen is eternal and it doesnt show any kind of error (unless it tries to connect for too long like a couple of minutes, then the error does shows up). The site still sends me notificarions through the browser though. Any other site loads up without a problem. I tried to use methods mentioned in the help article (turned off proxy, turned on network.dns.disableIPv6, deleted cookies and cache). In other browsers (Edge, for example) reddit.com loads just fine. Please help me if you can.

Asked by Anton 1 week ago

Last reply by Anton 5 days ago

Firefox e Amazon.com.br

Tenho o Win 11 23H2 com Firefox 124.0.1 instalado. Há meses , devo usar o Avast Browser para acessar o Amazon.com.br ou qualquer site do gov.br. Já desinstalei tudo e rei… (read more)

Tenho o Win 11 23H2 com Firefox 124.0.1 instalado. Há meses , devo usar o Avast Browser para acessar o Amazon.com.br ou qualquer site do gov.br. Já desinstalei tudo e reinstalei do zero , sem extensões , mas o problema continua. Alguém sabe me ajudar? Desde já agradeço.

Asked by Michael 1 month ago

Last reply by Michael 5 days ago

Multi IP'S conmect to my pc, a kernal level driver installed, bitwarden password valut uploaded to a ip and way more.

I used Firefox Developer Edition and yesterday saw that a new extension released for using Chrome web api to search and duckduckgo as one and had to test it "DuckDuck Chr… (read more)

I used Firefox Developer Edition and yesterday saw that a new extension released for using Chrome web api to search and duckduckgo as one and had to test it "DuckDuck Chrome"... I have since had keneral level drivers registered, IP addres ls directly connecting, every one of my files scanned and index and still I'm getting logs for connections from the same IP's that were using kernal calls to bypass me seeing whats going on... at one point they did a lernal call and changed the requested package power.

There were enough things ran from 5am pst today till 4pm pst today I have exporting the log file for multiple hours and it only has a tray icon telling me it's still creating it as the context was to large to be seen or queried in the Event Viewer itself (error 1734).

Asked by CodingCarson 4 days ago

DNS Over HTTPS - NS_ERROR_CONNECTION_REFUSED

Hi there! I'm trying to troubleshoot why firefox isn't connecting to my DNS over HTTPS instance running adguard home. Every other device (including another laptop) is ab… (read more)

Hi there!

I'm trying to troubleshoot why firefox isn't connecting to my DNS over HTTPS instance running adguard home. Every other device (including another laptop) is able to set the DNS over HTTPS and connect successfully - but my desktop PC instance gets NS_ERROR_CONNECTION_REFUSED. Despite multiple reboots, ipconfig /flushdns, release/renew, etc...

Even my android phone is able to connect to it using the "private dns" feature (uses port 853 instead of 443).

I've been able to verify https access to the DNS server and it's querying successfully. It's just this one instance it won't connect.

Asked by Josh Menzel 5 days ago

Offidocs

How do I get rid of this on my Firefox browser it keeps coming up all the time??? https://www.offidocs.com/media/system/app/view_edit_pdfeditor_nav.php?myServerhost=tut&… (read more)

Asked by thinkingofhow 4 days ago

updatew extension

you dont need a screenshot. its reral simple i am tired of nothing working right. i have added multiple wallets on my phantom app but it doesnt show up on my phantom wall… (read more)

you dont need a screenshot. its reral simple i am tired of nothing working right. i have added multiple wallets on my phantom app but it doesnt show up on my phantom wallet on my laptop. i have been hitting check for updates for 2 hours. why wont it update. and if i have to put in a 24 word secret phrase evertime i want to update my extension. then good bye firefox. then why have a check fofr updates button.

Asked by rmckinley2000 4 days ago

firefox didnt like the drobox directory I chose for downloads and now it wont ask anymore where to put downloads

I've always had my firefox checkmark the "Always ask you where to save files" box. I started to download a file from Envato elements, and firefox asked me where I wanted … (read more)

I've always had my firefox checkmark the "Always ask you where to save files" box. I started to download a file from Envato elements, and firefox asked me where I wanted to put it, so I pointed it to a dropbox folder on my finder level (I'm on a Mac computer). Some pop up showed up that said it didnt like the directory so I hit ok. Then I tried to download again to another location but now firefox won't ask me where i want to download the file to. And instead it just populates a file in the downloads folder called "7gp69ST8.mp4.part" or something similar. If I uncheck "Always ask you where to save files", the whole file downloads just fine to the downloads folder but I dont want that setting, I want the check mark ON so that it asks me each time where to save the file to. But its not asking me any more. So I hit quit on firefox and came back in and the issue persisted. I cleared the cookies and the issue persisted. Please help me fix this.

Asked by rachelcenter 4 days ago