• Solved
  • Locked

Firefox now saves files that I only wanted to open

After today's update to version 98 Firefox keeps saving files to the Downloads folder when I don't want it to, I just want to open them, but not keep them, with this new … (read more)

After today's update to version 98 Firefox keeps saving files to the Downloads folder when I don't want it to, I just want to open them, but not keep them, with this new behaviour the Downloads folder keeps filing up with useless clutter.

For example, before the update, when I downloaded a .zip file, a pop-up would show up asking if I wanted to save the file or open it with an application. If I chose to save it it would be saved to the Downloads folder, and if I chose to open it nothing would be saved to the Downloads folder.

After the update, when I download a .zip file, Firefox always saves the file to the Downloads folder, even if I choose to open it.

Can you please tell me if there is a way to make Firefox behave like in the previous version?

Asked by bayus.firestorm 3 months ago

Answered by bayus.firestorm 3 months ago

  • Solved
  • Archived

stop saving image files as webp

Firefox has been saving images from some sites as webp instead of JPG for a long time. There have been repeated threads on this subject which get locked and then pushed i… (read more)

Firefox has been saving images from some sites as webp instead of JPG for a long time. There have been repeated threads on this subject which get locked and then pushed into the long grass.

Sure, I could botch a solution by installing an add-on to convert them, or I could use something like XnView (which I do, periodically, and in bulk) after the save event has happened, or I can edit about:info to tell Firefox not to accept webp - but this breaks functionality for some sites (like eBay), but I have found that in the end I have had to start switching to Microsoft Edge to do my browsing for a number of sites because Mozilla Firefox are ignoring repeated user requests to provide a simple option to STOP doing this.

I don't want to save any files as webp - save them as PNG if you like, or jpg, but I use an ancient copy (v3.24) of ACDsee (from the days of Windows 98) for my image browsing, sorting, viewing etc because it is perfect, blisteringly quick, has no extra editing or other functionality which I don't need or want, and it doesn't bloat up anywhere with thumbnail files... but sadly webp didn't exist back then so it doesn't support it. I have used a number of much more up to date browser-viewers, but there is nothing can touch this OLD version of ACDsee for basically brilliant design.

I'm not changing my image viewer. It's non-negotiable.

I WILL however change my web browser if I have to, if the developers of the browser continually kick into the long grass to lock, hide away and pretend there's isn't an issue which has been repeatedly flagged as an annoyance for so many users.

I have been using one form or other of 'Mozilla' family of browsers since the days of Quarterdeck Mosaic. I don't particularly want to switch my loyalty, especially to Microsoft, but if they are listening to what customers want and providing it, and Mozilla are not, what else is there to do ?

I am a retired systems developer. I cannot envisage this being SUCH a big ask.

Modern software treats its users like idiots and takes away control, doing everything it's assumes on their behalf that they will want.

It is not difficult to provide an option within settings for when saving webp files to save as webp, png or jpg with conversion if necessary. All you need to do is hear the screams and respond. :)

Asked by Ethan 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

How to hide the address/URL bar again ?

Hello all, I run a bunch of web applets locally on my computer for personal use only (http://localhost/...), and until recently I could successfully launch FF using windo… (read more)

Hello all,

I run a bunch of web applets locally on my computer for personal use only (http://localhost/...), and until recently I could successfully launch FF using window.open(...) with the new window NOT showing the address bar (because it takes space and looks ugly within the applet, so I want to avoid it at all cost).

I believe this changed with FF 76 (I now run v. 76.0.1 64-bit on a Windows10 based computer), anyway at this point it seems impossible to NOT have the address bar show up in a FF window. :-/

To be clear : I have searched for a solution in this forum and elsewhere, found the solution to another new problem with FF ("megabar"), also seen the trick to hide the url in the address bar - but this is not what I'm looking for : I just want to *get rid of the address bar*, period.

Thanxx in advance for any help with this issue (surprised noone else seems to complain about this). :)

Asked by cfdhacker 2 years ago

Answered by jscher2000 - Support Volunteer 2 years ago

  • Solved
  • Archived

How can I customise/remove a default keyboard shortcut?

It's good to have those built-in shortcuts, but it's stupid you can't modify them. When I use this website I can't input the division sign by pressing / on the keypad bec… (read more)

It's good to have those built-in shortcuts, but it's stupid you can't modify them. When I use this website I can't input the division sign by pressing / on the keypad because it's the shortcut for Quick Find. I guess this is because the place to input is not a normal text box like in WolframAlpha , but part of the whole webpage(?). Add the function to customise shortcuts is much easier than let Firefox recognise and deal with this situation, I think. In fact, most software supports customising shortcuts, so I'm surprised to find there's no way for Firefox to do that.

Asked by WANGtheneighbor 2 years ago

Answered by McCoy 2 years ago

  • Solved
  • Archived

Can't get Thunderbird to work with Office 365 emails

I tried using Thunderbird to check my Office 365 email, with the following settings IMAP: outlook.office365.com Port: 143 SSL: STARTTLS SMTP: smtp.office365.com Port: 587… (read more)

I tried using Thunderbird to check my Office 365 email, with the following settings

IMAP: outlook.office365.com Port: 143 SSL: STARTTLS

SMTP: smtp.office365.com Port: 587 SSL: STARTTLS

Normal Password

All the settings are retried by Thunderbird once I enter the IMAP and SMTP details.

However upon clicking done, there will be a message saying "Unable to log in at server. Probably wrong configuration, username or password"

I have verified the username and password is correct, and also IMAP enabled for this account, but keep getting password wrong message.

Asked by siewkit84 1 year ago

Answered by siewkit84 1 year ago

  • Solved
  • Archived

watch video "in" firefox browser

I'm trying to watch videos in Firefox. Youtube works but Xvideos does not. Firefox pops up a window asking me: >> "Opening xvideos"."com ###.mp4". >> whi… (read more)

I'm trying to watch videos in Firefox. Youtube works but Xvideos does not. Firefox pops up a window asking me:

>> "Opening xvideos"."com ###.mp4". >> which is: MP4 Video (16.4MB) >> from https://cdn77-vid.xvideos-cdn"."com >> >> What should Firefox do with this file?

My only choice is: Open with Windows Media Player x86 (default)

suggestions?

I'm running Windows 7 Firefox 76.0.1

Thanks!!!!

Asked by G_Eak 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

set "print with system dialog" as default

dear ladies and gentlemen, Firefox has been delivered with the new print dialog since version 82. I have to print around a hundred PDF files at work (usually only the fir… (read more)

dear ladies and gentlemen,

Firefox has been delivered with the new print dialog since version 82.

I have to print around a hundred PDF files at work (usually only the first page of the document). The new print dialog means that there is a lot more work for me here.

Is it possible to set the "old" system print dialog by default or to instruct firefox to always print only the first page of the document by default?

Asked by Bruce Wayne 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Locked
  • Archived

HERE is the answer to put "TABS BELOW" which will work with Firefox V90 using the - userChrome.css - file

HERE IS THE ANSWER Here is the answer to get TABS BELOW with Firefox V90 . . copy all of this code below the broken line into your - userChrome.css - file and save it. Yo… (read more)

HERE IS THE ANSWER Here is the answer to get TABS BELOW with Firefox V90 . . copy all of this code below the broken line into your - userChrome.css - file and save it. You can modify the 45px in this line if you wish to get an appropriate height . . just experiment with different numbers till you get it right --menubar-height: 45px; /*30px|41px=11px; caption buttons on menubar*/

Also to make the tabs wider or narrower, modify the line which is coded width: 50vw !important;

Finally you must enable - css - in Firefox, by typing about:config into your address bar, and search for toolkit. When all the toolkit options appear change the one which says toolkit.legacyUserProfileCustomizations.stylesheets to TRUE by click the icon in the right hand column. Than close Firefox and reopen, and check how it looks This will enable your - css - file to be read, and interpreted and accepted by the Firefox browser.

-------------------------------------------------------------------
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* TABS: bottom - Firefox 65 and later - updated for 89+ */
/* https://searchfox.org/mozilla-release/source/browser/themes/shared/tabs.inc.css */
/* https://raw.githubusercontent.com/Aris-t2/CustomCSSforFx/master/classic/css/tabs/tabs_below_navigation_toolbar_fx89.css */
/* https://developer.mozilla.org/en-US/docs/Tools/Browser_Toolbox */

/* ROOT - VARS */
/* you can adjust the CSS variables until it looks correct */
/* you can use the Browser Toolbox to get the toolbar heights */

*|*:root {
  --tab-toolbar-navbar-overlap: 0px !important;

  --tab-min-height: 40px !important;
  --tab-min-width:  60px !important;

  --tab-adjust:  0px; /* adjust tab bar - only for 68-73 */
  --tab-caption: 5px; /* caption buttons on tab bar */
}

/* TAB BAR - below nav-bar */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10 !important;}
#TabsToolbar {-moz-box-ordinal-group:1000 !important;}

#TabsToolbar {
  display: block !important;
  position: absolute !important;
  bottom: 0 !important;
  width: 50vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}

/* navigator-toolbox - PADDING */
*|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  position: relative !important; /*89+*/
  padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*ADJUST*/
  background-color: var(--toolbar-bgcolor) !important;
}

/* TabsToolbar with menubar and titlebar hidden - rules for Firefox 65-73 */
*|*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"]) #toolbar-menubar[autohide="true"] ~
 #TabsToolbar{
  bottom: var(--tab-adjust); /*ADJUST*/
}

/* TABS: height */
#tabbrowser-tabs,
#tabbrowser-tabs > .tabbrowser-arrowscrollbox,
.tabbrowser-tabs[positionpinnedtabs] > .tabbrowser-tab[pinned] {
  min-height: var(--tab-min-height) !important;
  max-height: var(--tab-min-height) !important;
}

#TabsToolbar {
  height: var(--tab-min-height) !important;
  margin-bottom: 1px !important;
  box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important; /*OPTIONAL*/
  background-color: var(--toolbar-bgcolor) !important;
  color:            var(--toolbar-color) !important;
/*  z-index: 1 !important; */
}

/* indicators *//*
*|*:root[privatebrowsingmode=temporary] .private-browsing-indicator {
  position: absolute !important;
  display: block !important;
  right: 0px !important;
  bottom: 0px !important;
  width: 14px !important;
  pointer-events: none !important;
}
*/
.private-browsing-indicator {display: none !important;}
.accessibility-indicator    {display: none !important;}

/* Indicators - HIDE *//*
*|*:root:not([accessibilitymode])             .accessibility-indicator    {display: none !important}
*|*:root:not([privatebrowsingmode=temporary]) .private-browsing-indicator {display: none !important}
*/

/* Drag Space */
.titlebar-spacer[type="pre-tabs"],
.titlebar-spacer[type="post-tabs"] {
  width: 20px !important;
}

/* Override vertical shifts when moving a tab */
#navigator-toolbox[movingtab] > #titlebar > #TabsToolbar {
  padding-bottom: unset !important;
}

#navigator-toolbox[movingtab] #tabbrowser-tabs {
  padding-bottom: unset !important;
  margin-bottom: unset !important;
}

#navigator-toolbox[movingtab] > #nav-bar {
  margin-top: unset !important;
}

/* Hide window-controls and caption buttons on Tab Bar */
#TabsToolbar #window-controls {display: none !important;}
#TabsToolbar .titlebar-buttonbox-container {display: none !important;}

Asked by Trevor George, Bristol, UK 1 year ago

Answered by Trevor George, Bristol, UK 1 year ago

  • Solved
  • Archived

Cannot send email with smtp.office365.com

I was connected to O365 with my work email but cannot send any message. IMAP works just fine, all folders synced regularly, but sending not work for some unknown reason.… (read more)

I was connected to O365 with my work email but cannot send any message. IMAP works just fine, all folders synced regularly, but sending not work for some unknown reason.

SMTP setting is as follow: smtp.office365.com port 587 STARTTLS OAuth (this is correct setting, all others shows errors, including outlook.partner.cn & smtp.office365.cn, which is completely normal since I'm not in China).

The first thing that jump out is that my password is not OK, which is not correct. Password is OK. Click on "Retry" or "Enter new password" do nothing, just return the same pop up. If "Cancel", then receiving message with "unknown error 80004005" and all other blablabla about unknown reasons, with instruction to check my SMTP settings.

I've tried all variations available, but nothing works. Sometimes, at some moment after click on Cancel, it said "Message sent" and I can see it in my Sent Items folder, but it's fake because I never receive that test message to my personal Gmail address.

I have already tried all suggestions I could find (deleting passwords, resetting all, restarting, deleting and adding account again, changes in Config editor related to security.tls), but nothing worked for me.

My OS: Win 10 Pro, build 2004, TB version 78.3.2

Any advise is very welcome. Thank you all in advance.

Asked by denexi 1 year ago

Answered by Norbert 1 year ago

  • Solved
  • Archived

Backspace keyboard button not working in Firefox 87

Hello, I just upgraded to Firefox 87 and noticed that I wasn't able to go back to the previous webpage by clicking on the backspace button like what I have done in the pa… (read more)

Hello,

I just upgraded to Firefox 87 and noticed that I wasn't able to go back to the previous webpage by clicking on the backspace button like what I have done in the past if I'm not using a mouse on my laptop and had to click on the back button in the toolbar with the trackpad. I'm not too sure of why that happened with the upgrade and was a little surprised about that. Hope I can be able to get around this in some way if one of you know anything about this. Thanks.

Asked by Anduma22 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

you must log in to this network before you can access the internet

Hi everyone, I have this message that appears on every web page but my connection is fine: "you must log in to this network before you can access the internet". It appear… (read more)

Hi everyone,

I have this message that appears on every web page but my connection is fine: "you must log in to this network before you can access the internet". It appeared I don't know how (maybe after using my VPN?) and I can't get rid of it. Any idea?

In advance, thanks a lot.

Asked by jean.souviron 1 year ago

Answered by Scribe 1 year ago

  • Solved
  • Archived

Touchpad gestures doesn't work in Firefox. Please add this very useful feature.

Windows 10 gesture two finger swipe left and two finger swipe right doesn't work in Firefox. Two finger swipe left allows user to go history backward and two finger swipe… (read more)

Windows 10 gesture two finger swipe left and two finger swipe right doesn't work in Firefox. Two finger swipe left allows user to go history backward and two finger swipe right allows user to go history forward. These gestures work in Firefox if the user hold Alt key and preform the gestures. But most of the users don't like to hold Alt key and preform the gestures. Please fix that issue.

Asked by Rifat Mahmud 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Locked
  • Archived

Gmail won't load

Gmail will not load in Firefox, but will in Chrome. I've cleared my history, cookies, and cache. I made sure I had the latest Firefox update, restarted my computer, check… (read more)

Gmail will not load in Firefox, but will in Chrome. I've cleared my history, cookies, and cache. I made sure I had the latest Firefox update, restarted my computer, checked in internet connection, everything I could think of. There is no error message; it just stops loading and the page is totally blank, as you can see on the attached image. I've run out of ideas and know-how. Anyone else had this issue and resolved it?

Asked by jvelmore 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Hmm. We’re having trouble finding that site.

I am facing the problem to open the sites. When I used the network, it show the following error: Hmm. We’re having trouble finding that site. We can’t connect to the serv… (read more)

I am facing the problem to open the sites. When I used the network, it show the following error:

Hmm. We’re having trouble finding that site.

We can’t connect to the server at www.google.com.

If that address is correct, here are three other things you can try:

   Try again later.
   Check your network connection.
   If you are connected but behind a firewall, check that Firefox has permission to access the Web.

Please let me know your suggestion and comments.

Asked by mchahalrock 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Archived

download keep failing

i am trying to download a file (about 50gb) and the download keeps failing. When i click reply the download continuous. It downloads fine for a little bit then it fails a… (read more)

i am trying to download a file (about 50gb) and the download keeps failing. When i click reply the download continuous. It downloads fine for a little bit then it fails again. Keep in mind when i click the trry agin button the download does not restart, it just continuous to download where it left off. (sort of like just pause and unpause) what should i do?

Asked by johnkarpontin 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Archived

How to disable: "Your internet connection was restored" notifications?

How to disable: "Your internet connection was restored" notifications? – Terribly annoying and only started in the last version 77.0.1 very recently. I rather switch to a… (read more)

How to disable: "Your internet connection was restored" notifications? – Terribly annoying and only started in the last version 77.0.1 very recently. I rather switch to another browser if I cannot get rid of this. Checked my 3 plug-ins, but cannot find anything there, nor if it is something on Facebook I cannot find it. Any idea?

Asked by eyeless 2 years ago

Answered by McCoy 2 years ago

  • Solved
  • Archived

How do I save a pdf file shown in FF?

Firefox displays pdf files very nicely, but how do I save the file to my download folder? FF help says this is done by “clicking the download link” but I cant find any do… (read more)

Firefox displays pdf files very nicely, but how do I save the file to my download folder?

FF help says this is done by “clicking the download link” but I cant find any download links anywhere in the FF GUI, when the pdf is displayed.

I'm sure its there somewhere, but I just cant find it..

Help appreciated,

Cheers, Lars Bo

Asked by Lars Bo Larsen 1 year ago

Answered by WoodForGood 1 year ago

  • Solved
  • Archived

Copy/Paste not working

As the title indicates, copy/pasting does not work. I'm on Windows 10, have installed Firefox about two days ago (I've recently switched to it) so the version of FF is up… (read more)

As the title indicates, copy/pasting does not work.

I'm on Windows 10, have installed Firefox about two days ago (I've recently switched to it) so the version of FF is up to date. I've looked up a few fixes before posting and they didn't work:

- Tried booting FF on safe mode and it didn't fix the issue - it clearly isn't caused by an add-on (and I've never had this issue in my previous browser with nearly the same add-ons installed). - other people seem to have had the exact same issue multiple times and it's lasted for years, so it's clearly a problem on FF's end.

Here is the issue described more specifically: Copying things from a tab from FF and into the online version of Word does not work - when I try to, the intended selection: - disappears a few seconds after I've pasted - or it does not appear at all - or when it does, it erases the entire sentence it was pasted next to it, which you can imagine is absolutely bothersome.

I've also tried to copy/paste statistics from a site called archiveofourown.org onto another FF tab. - What ended up being copied is only the last character of the entire content I was trying to paste, which I think suggests there's some issue with what's contained in the clipboard.

I'm mentioning these two websites because I'm guessing that something about them is probably conflicting with the copy/paste feature, however I'm hoping no one will have the gall to tell me it's those websites' faults and that I should just stop using them.

When pasting (while having hopefully copied the former selected content- and no, it wasn't the case), it always pastes the content which was last copied into the clipboard prior to that very attempt, which shows that the clipboard's content was not refreshed with the last selected copied one.

I'm surprised to see that FF has had such a glaring issue for years and for many other users, and updates have never given a fix for it. I'd like this issue to be fixed properly, because I'd hate to have to switch back to my previous browser. FF sports so many nice features that other browsers don't have, and it'd be a shame to ruin the experience with a bug so basic as the copy/paste feature being broken.

Asked by yumiifmb 2 years ago

Answered by user1321319 2 years ago

  • Solved
  • Archived

Why does Firefox take up so much RAM?

I have been using Firefox for the past 2 years, but only recently have I noticed that Firefox is using 1 GB of RAM! It never increases or decreases and its getting very a… (read more)

I have been using Firefox for the past 2 years, but only recently have I noticed that Firefox is using 1 GB of RAM! It never increases or decreases and its getting very annoying now since I have barely any RAM to run zoom with (which for some reason takes up the rest of my RAM). I can't even run anything else, and thats annoying me a lot since my fan has to keep running. I can't upgrade my RAM because I use a laptop, and my laptop is under warranty and I can't afford to lose the warranty by upgrading the RAM. Is there any other way to decrease memory usage beside using about:memory and pressing the "minimize memory usage" button? Nothing happens when I press the button.

Asked by unknownturtle64 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Archived

How do I stop Firefox from opening links in a new window?

Currently, I'm using Firefox 82.0.2 on Fedora 31. Recently, it's started opening most, but not all links in a new window instead of the current one. Not on all sites, b… (read more)

Currently, I'm using Firefox 82.0.2 on Fedora 31. Recently, it's started opening most, but not all links in a new window instead of the current one. Not on all sites, but most. As a pair of examples, it opens links to articles on gasbuddy.com in a new window but not on Slashdot, and until a few months ago, it only opened a new window if I right-clicked and selected New Window from the context menu. I'd like to get the old behavior back, as this is quite inconvenient.

Asked by sideburns 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago