X
Tap here to go to the mobile version of the site.

Support Forum

How do I set the default font size to a lower value?

Posted

I recently got the Firefox 22.0 build 20130514181517 update (at the same time as a Windows 7 update, I might add) and since then the default font sizes on all websites have been enlarged. I have a 17" monitor, but due to the grossly overscaled fonts it seems more like an old 14", and it's quite irritating. To view the websites in approximately the old way they used to look, I have to zoom out twice, but it also means I have to do it on all sites. I also have the habit of accidentally zooming in or out while using my laptop's touchpad, so whenever I ctrl-0 to reset the font, it goes back to the large font, and I need to rezoom it again.

I am primarily trying to figure out if there is a way to reset the font size without using any add-ons.

Thanks

I recently got the Firefox 22.0 build 20130514181517 update (at the same time as a Windows 7 update, I might add) and since then the default font sizes on all websites have been enlarged. I have a 17" monitor, but due to the grossly overscaled fonts it seems more like an old 14", and it's quite irritating. To view the websites in approximately the old way they used to look, I have to zoom out twice, but it also means I have to do it on all sites. I also have the habit of accidentally zooming in or out while using my laptop's touchpad, so whenever I ctrl-0 to reset the font, it goes back to the large font, and I need to rezoom it again. I am primarily trying to figure out if there is a way to reset the font size without using any add-ons. Thanks

Chosen solution

Code changes regarding HiDPI support for high resolution displays have landed in Firefox 22 and later (bug #844604).

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)

Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments.

  • Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!)
  • Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Read this answer in context 10

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Google Update
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • 5.1.20125.0
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • VLC media player Web Plugin 2.0.0
  • NPWLPG
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Mahdi Dibaiee 7 solutions 44 answers

Edit -> Prefrences -> Content

Under Fonts & Colors play with your font's size and change it to whatever you want.

Also take a look at this:

https://support.mozilla.org/en-US/kb/settings-fonts-languages-pop-ups-javascript

Edit -> Prefrences -> Content Under Fonts & Colors play with your font's size and change it to whatever you want. Also take a look at this: https://support.mozilla.org/en-US/kb/settings-fonts-languages-pop-ups-javascript
cor-el
  • Top 10 Contributor
  • Moderator
16651 solutions 150515 answers

You can try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

You can try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences ---- Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

If I try to change the font size in Content Preferences it also overrides website based fonts which is unfortunate.

I tried creating a new profile and I noticed that it also has a large scale. I cannot figure out where the problem might be. I might have to resort to addons after all.

If I try to change the font size in Content Preferences it also overrides website based fonts which is unfortunate. I tried creating a new profile and I noticed that it also has a large scale. I cannot figure out where the problem might be. I might have to resort to addons after all.
cor-el
  • Top 10 Contributor
  • Moderator
16651 solutions 150515 answers

Chosen Solution

Code changes regarding HiDPI support for high resolution displays have landed in Firefox 22 and later (bug #844604).

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)

Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments.

  • Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!)
  • Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Code changes regarding HiDPI support for high resolution displays have landed in Firefox 22 and later (bug #844604). You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox. *The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05). *Change the default value -1 to 1 to make it work like in previous Firefox versions (100%) Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments. *Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!) *Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI). *http://kb.mozillazine.org/about:config If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/ Use this extension to adjust the font size for the user interface: *Theme Font & Size Changer: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/

Modified by cor-el

Question owner

Excellent! That did the trick! Changed it to 1.2 and it looks so much better now. Thanks for the great info :)

Excellent! That did the trick! Changed it to 1.2 and it looks so much better now. Thanks for the great info :)
544380 0 solutions 15 answers

It doesn't work for me. Toolbar text is tiny, web site text/graphics too HUGE.

It doesn't work for me. Toolbar text is tiny, web site text/graphics too HUGE.
cor-el
  • Top 10 Contributor
  • Moderator
16651 solutions 150515 answers

You will have to adjust the layout.css.devPixelsPerPx pref (e.g. 0.8) to increase the element size (icons and text) for the user interface and use an extension to change the default zoom for the web pages.

Use this extension to adjust the font size for the user interface:

You can use an extension to set a default font size and page zoom on web pages.

You will have to adjust the layout.css.devPixelsPerPx pref (e.g. 0.8) to increase the element size (icons and text) for the user interface and use an extension to change the default zoom for the web pages. Use this extension to adjust the font size for the user interface: *Theme Font & Size Changer: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ *Big Buttons: https://addons.mozilla.org/firefox/addon/big-buttons/ You can use an extension to set a default font size and page zoom on web pages. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/
544380 0 solutions 15 answers

Helpful Reply

This still does not work.

I tried all of them. Theme Font & Size Changer Big Buttons Default FullZoom Level NoSquint.

It only works for that page of that web site, as soon as you leave you start all over again.

Can't we just say Firefox messed up and needs to revert to the way it used to work without have to do ANYTHING to adjust any sizing. This is utterly ridiculous.

It's a web browser for GOD sakes...not the OS. It shouldn't be doing anything but displaying web sites with NO INTERVENTION by the user for each and every page.

Why are programers always looking for ways to take a working product and make it useless???

This still does not work. I tried all of them. Theme Font & Size Changer Big Buttons Default FullZoom Level NoSquint. It only works for that page of that web site, as soon as you leave you start all over again. Can't we just say Firefox messed up and needs to revert to the way it used to work without have to do ANYTHING to adjust any sizing. This is utterly ridiculous. It's a web browser for GOD sakes...not the OS. It shouldn't be doing anything but displaying web sites with NO INTERVENTION by the user for each and every page. Why are programers always looking for ways to take a working product and make it useless???
cor-el
  • Top 10 Contributor
  • Moderator
16651 solutions 150515 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

You can rename the content-prefs.sqlite file to content-prefs.sqlite.old (or delete the file) in the Firefox profile folder to reset the page zoom for all websites.

In case you are using "Clear history when Firefox closes":

  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History). *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode" You can rename the content-prefs.sqlite file to content-prefs.sqlite.old (or delete the file) in the Firefox profile folder to reset the page zoom for all websites. *http://kb.mozillazine.org/Profile_folder_-_Firefox In case you are using "Clear history when Firefox closes": *do not clear the Site Preferences *Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings *https://support.mozilla.org/kb/Clear+Recent+History Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.
jjan23 0 solutions 9 answers

Helpful Reply

I agree, Firefox definitely messed up this time. You guys need to revert it back to how it was....I'm sure this caused more problems for people than it solved, and it was totally unnecessary. Just a way to tweak something, well you messed it up this time, sorry to say.

I agree, Firefox definitely messed up this time. You guys need to revert it back to how it was....I'm sure this caused more problems for people than it solved, and it was totally unnecessary. Just a way to tweak something, well you messed it up this time, sorry to say.

Modified by jjan23

kobe 441 solutions 5048 answers
see * https://support.mozilla.org/en-US/questions/959696 * https://support.mozilla.org/en-US/questions/963035 * https://support.mozilla.org/en-US/questions/963027 * https://support.mozilla.org/en-US/questions/963010 * https://support.mozilla.org/en-US/questions/962979 * https://support.mozilla.org/en-US/questions/962990 * https://support.mozilla.org/en-US/questions/963001
Pat 3 solutions 26 answers

I changed the setting in about:config to 1.0 and it now matches Internet Explorer for the first time. That's good (if a little late in the game).

But I am astonished that Firefox's new adoption of Windows display text-size setting is not followed in the menubar, tab bar, or menus -- which are now tiny compared to page text. I should not have to use an addon "NoSquint" to now control the size of my web page. Just saying...

I changed the setting in about:config to 1.0 and it now matches Internet Explorer for the first time. That's good (if a little late in the game). But I am astonished that Firefox's new adoption of Windows display text-size setting is not followed in the menubar, tab bar, or menus -- which are now tiny compared to page text. I should not have to use an addon "NoSquint" to now control the size of my web page. Just saying...

Modified by Pat

Pat 3 solutions 26 answers

Waka_Flocka_Flame posted 7 related subjects. Here's another:

https://support.mozilla.org/en-US/que.../962945#answer-450204


moderator fixed the broken hyperlink

Waka_Flocka_Flame posted 7 related subjects. Here's another: [https://support.mozilla.org/en-US/questions/962945#answer-450204] ''moderator fixed the broken hyperlink''

Modified by the-edmeister

ilikefree 0 solutions 23 answers

Try this in about:config

layout.css.devPixelsPerPx;1.2

Try this in about:config layout.css.devPixelsPerPx;1.2
pkenny 0 solutions 4 answers

I have followed the instruction to rename the file content-prefs.sqlite . This changes the font size for some web sites, but not all (particularly not this page). However, it has no effect on the rest of the display; the tabs across the top of the page are still oversized, and so is the sidebar with my bookmarks. I have a lengthy list of bookmarks (which I do not wish to modify, so please don't suggest that as a way of covering up your mess); before I was updated to version 22 today, the list fitted comfortably on my screen, now the bottom quarter is off the bottom of the screen. The sidebar is also 25% wider than it was, and takes up too much screen space.

I agree with a previous poster; you need to revert to the previous defaults, for everything (headers, sidebar and web page content), or at least provide a sensible way for users to revert. I do not find it funny to have to search for some internal Firefox file and rename it; will the next step be asking us to edit registry entries? The least you can do is provide an easy-to-understand option under Tools>Options or some such location. Failing that, can I just undo the whole of the update to 22? You have taken an excellent product and ruined it; please at least acknowledge that there is a problem.

I have followed the instruction to rename the file content-prefs.sqlite . This changes the font size for some web sites, but not all (particularly not this page). However, it has no effect on the rest of the display; the tabs across the top of the page are still oversized, and so is the sidebar with my bookmarks. I have a lengthy list of bookmarks (which I do not wish to modify, so please don't suggest that as a way of covering up your mess); before I was updated to version 22 today, the list fitted comfortably on my screen, now the bottom quarter is off the bottom of the screen. The sidebar is also 25% wider than it was, and takes up too much screen space. I agree with a previous poster; you need to revert to the previous defaults, for everything (headers, sidebar and web page content), or at least provide a sensible way for users to revert. I do not find it funny to have to search for some internal Firefox file and rename it; will the next step be asking us to edit registry entries? The least you can do is provide an easy-to-understand option under Tools>Options or some such location. Failing that, can I just undo the whole of the update to 22? You have taken an excellent product and ruined it; please at least acknowledge that there is a problem.
pkenny 0 solutions 4 answers

I have now followed the suggestion by cor-el at the top of this column to modify the layout.css.devPixelsPerPx pref, changing the value from -1.0 to 1.0. This has put my display back near enough to what it was before the update to 22, so I am happy. Sorry for my intemperate language, but it really was unnecessarily complicated to get here.

I have now followed the suggestion by cor-el at the top of this column to modify the layout.css.devPixelsPerPx pref, changing the value from -1.0 to 1.0. This has put my display back near enough to what it was before the update to 22, so I am happy. Sorry for my intemperate language, but it really was unnecessarily complicated to get here.
dianam59 0 solutions 1 answers

Sorry, I really like Firefox, but what is going on here? I'm having the same problem. The font size is way to large. Also some of us need directions to be in English, not computer tech talk. :) Please fix it? I don't feel we should have to mess with our computers to adjust what Firefox has changed. I'm not meaning to be rude, but I'm old and computer illiterate. :)

Sorry, I really like Firefox, but what is going on here? I'm having the same problem. The font size is way to large. Also some of us need directions to be in English, not computer tech talk. :) Please fix it? I don't feel we should have to mess with our computers to adjust what Firefox has changed. I'm not meaning to be rude, but I'm old and computer illiterate. :)
John99 971 solutions 13138 answers

Hi dianam59,
I think Firefox may have been able to handle this better.

Complain using

Similar instructions but with a bit less computer talk:


You can adjust your screen resolution. To modify it do the following:

  • Type about:config into the Firefox address bar and tap on the Enter key.
  • If the warning This might void your warranty appears, click I'll be careful, I promise.
  • Search for layout.css.devPixelsPerPx

Fx22layout.css.devPixelsPerPx

  • Double-click on layout.css.devPixelsPerPx to modify its value. The default is -1.0 in Firefox 22 and above. Change it to 1.0 to make it work like in previous Firefox versions.

If necessary, further adjust the value in 0.1 or 0.05 steps. Use values between 1.0 and about 0.5 to reduce elements in size. Use values greater than 1.0 to increase size. For example, a value of 1.25 will increase font size to 125% to accommodate the default DPI setting in Windows 8. Double check the value that you enter. Setting a too small value will make everything disappear and a too large value will blow things up.

If web pages still need to be adjusted then you can look at the Default FullZoom Level or NoSquint extension.

To adjust the font size for the user interface, you can use the Theme Font & Size Changer extension.

Hi dianam59, <br />I think Firefox may have been able to handle this better. Complain using * https://input.mozilla.org/en-US/feedback Similar instructions but with a bit less computer talk: You can adjust your screen resolution. To modify it do the following: * Type '''about:config''' into the Firefox address bar and tap on the Enter key. * If the warning '''This might void your warranty''' appears, click '''I'll be careful, I promise'''. * Search for '''layout.css.devPixelsPerPx''' [[Image:Fx22layout.css.devPixelsPerPx]] * Double-click on layout.css.devPixelsPerPx to modify its value. The default is -1.0 in Firefox 22 and above. Change it to '''1.0''' to make it work like in previous Firefox versions. If necessary, further adjust the value in 0.1 or 0.05 steps. Use values between 1.0 and about 0.5 to reduce elements in size. Use values greater than 1.0 to increase size. For example, a value of 1.25 will increase font size to 125% to accommodate the default DPI setting in Windows 8. '''Double check the value that you enter.''' Setting a too small value will make everything disappear and a too large value will blow things up. If web pages still need to be adjusted then you can look at the [https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ Default FullZoom Level] or [https://addons.mozilla.org/firefox/addon/nosquint/ NoSquint] extension. To adjust the font size for the user interface, you can use the [https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ Theme Font & Size Changer] extension.
ilikefree 0 solutions 23 answers

pkenny you could try going to view, zoom and uncheck zoom text only

pkenny you could try going to view, zoom and uncheck zoom text only
kobe 441 solutions 5048 answers

Or try Ctrl + 0

Or try '''Ctrl''' + '''0'''