Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox not displaying Cascading Style Sheet borders

  • 2 trả lời
  • 15 gặp vấn đề này
  • 23 lượt xem
  • Trả lời mới nhất được viết bởi rabubi8

more options

I have pages that sit inside Drupal with its own style sheet that overrides the styles of the themes. The problem occurs where I have tables. Most often the right border of the table or some TDs are sometimes missing. I don't style each table cell separately, but some columns (not all) are just missing borders, whether top, right or bottom. I use firebug and when I inspect a specific cell I can see that the border is supposed to show (as it does in Chrome and IE). If the table width or height is changed in DOM, the borders sometimes appear.

I have pages that sit inside Drupal with its own style sheet that overrides the styles of the themes. The problem occurs where I have tables. Most often the right border of the table or some TDs are sometimes missing. I don't style each table cell separately, but some columns (not all) are just missing borders, whether top, right or bottom. I use firebug and when I inspect a specific cell I can see that the border is supposed to show (as it does in Chrome and IE). If the table width or height is changed in DOM, the borders sometimes appear.

Tất cả các câu trả lời (2)

more options

Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Hi, thank you for the response. I often refresh a page with "Ctrl + F5" but I tried the Safe Mode option and clearing the cache this morning but the behavior is still the same. When I clear the cache for Chrome and IE, the borders are still displaying correctly. I have attached a screen shot of one of the tables. In "A)" I have the normal table and the right border is missing on the 1st column (next to the folder icon) and the very last column. In "B)" I have displayed a hidden table row with JavaScript in the DOM and the borders are then showing. Here is the CSS for the 1st table cell with a folder icon (copied from Firebug):

table#AttrForm thead, table#AttrForm thead th, table#AttrForm tbody, table#AttrForm tbody td {
    -moz-border-bottom-colors: none;
    -moz-border-image: none;
    -moz-border-left-colors: none;
    -moz-border-right-colors: none;
    -moz-border-top-colors: none;
    border-bottom-color: #999999;
    border-bottom-style: solid;
    border-bottom-width: 1px;
    border-left-color-ltr-source: physical;
    border-left-color-rtl-source: physical;
    border-left-color-value: #999999;
    border-left-style-ltr-source: physical;
    border-left-style-rtl-source: physical;
    border-left-style-value: solid;
    border-left-width-ltr-source: physical;
    border-left-width-rtl-source: physical;
    border-left-width-value: 1px;
    border-right-color-ltr-source: physical;
    border-right-color-rtl-source: physical;
    border-right-color-value: #999999;
    border-right-style-ltr-source: physical;
    border-right-style-rtl-source: physical;
    border-right-style-value: solid;
    border-right-width-ltr-source: physical;
    border-right-width-rtl-source: physical;
    border-right-width-value: 1px;
    border-top-color: #999999;
    border-top-style: solid;
    border-top-width: 1px;
}

Được chỉnh sửa bởi cor-el vào