X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox Address Bar Goes to Bing

Được đăng

When typing into the address bar everything goes to bing search now. I have done everything from changing keyword.url to starting in safe mode to completely uninstalling and reinstalling Firefox. Nothing works and it always goes back to a bing search whenever I type anything in.

When typing into the address bar everything goes to bing search now. I have done everything from changing keyword.url to starting in safe mode to completely uninstalling and reinstalling Firefox. Nothing works and it always goes back to a bing search whenever I type anything in.

Giải pháp được chọn

hijack firefox


solved by uninstalling this update. kb982381

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • -NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Google Update
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • 4.0.50524.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Thông tin chi tiết

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.18
true
Xmarks
3.6.14
true
foxmarks@kei.com
Adblock Plus
1.2
true
Screengrab
0.96.3
true
{02450954-cdd9-410f-b1da-db804e18c671}
Modified Preferences
Name
Value
browser.history_expire_days
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.mstone
rv:1.9.2.3
extensions.lastAppVersion
3.6.3
network.cookie.prefsMigrated
true
privacy.sanitize.migrateFx3Prefs
true

Người tạo câu hỏi

I have the exact same problem. It's driving me crazy.

I have the exact same problem. It's driving me crazy.

Người tạo câu hỏi

Same here

Same here

Người tạo câu hỏi

yea same. this is really annoying me.

yea same. this is really annoying me.
cor-el
  • Top 10 Contributor
  • Moderator
17585 giải pháp 159079 câu trả lời
Được đăng
See http://kb.mozillazine.org/Location_Bar_search and http://kb.mozillazine.org/Keyword.URL See also [[Searches are redirected to another site]]

Được chỉnh sửa bởi cor-el vào

Người tạo câu hỏi

I have the same problem. I have checked the keyword.url, and it is set to google. My address bar searches still have Bing results. Even in safe mode Bing is taking over my searches. This is incredibly frustrating.

I have the same problem. I have checked the keyword.url, and it is set to google. My address bar searches still have Bing results. Even in safe mode Bing is taking over my searches. This is incredibly frustrating.

Người tạo câu hỏi

Same. Bing is absolute crap. I will switch to Chrome within the week if this shit doesn't get cleared up PRONTO.

Same. Bing is absolute crap. I will switch to Chrome within the week if this shit doesn't get cleared up PRONTO.

Câu trả lời hữu ích

Change Firefox’s address bar search from bing to the default settings in order to bring you to the page you ask if there is domain registered for that keyword, even if you don't write http://, www. or .com.

Type “about:config” in firefox address bar and type “keyword.url”. Right click and choose modify and type "http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q="

Without ""

Thanks God I fixed it. It was really annoying, frustrating! Hope it will work for you too guys or other people that will have this stupid issue, hijacking from bing.

Credits goes to:

Ref: http://pcproblems.wordpress.com/2009/06/11/firefox-addressbar-search-hijacked-by-microsoft-bing/

Thanks also to PakNik, Ravikumar Vasudevan, peter (Y)!

Cheers ;) eWin

Change Firefox’s address bar search from bing to the default settings in order to bring you to the page you ask if there is domain registered for that keyword, even if you don't write http://, www. or .com. Type “about:config” in firefox address bar and type “keyword.url”. Right click and choose modify and type "http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=" Without "" Thanks God I fixed it. It was really annoying, frustrating! Hope it will work for you too guys or other people that will have this stupid issue, hijacking from bing. Credits goes to: Ref: http://pcproblems.wordpress.com/2009/06/11/firefox-addressbar-search-hijacked-by-microsoft-bing/ Thanks also to PakNik, Ravikumar Vasudevan, peter (Y)! Cheers ;) eWin

Người tạo câu hỏi

Same prbl

Same prbl

Người tạo câu hỏi

I have the exact same problem even after setting the keyword.URL back to default. I am confident its not my ISP as others on the network dont have the same problem. My anti virus and malware check are all clean.

HELP!!

I have the exact same problem even after setting the keyword.URL back to default. I am confident its not my ISP as others on the network dont have the same problem. My anti virus and malware check are all clean. HELP!!

Người tạo câu hỏi

Same thing happening for me. Changing keyword.URL line to anything, not just Google searches, still defaults to Bing.

This behavior only started after I installed the latest group of updates from Windows update for Win7 64-bit that went out on the 8th.

Same thing happening for me. Changing keyword.URL line to anything, not just Google searches, still defaults to Bing. This behavior only started after I installed the latest group of updates from Windows update for Win7 64-bit that went out on the 8th.

Người tạo câu hỏi

Same theory as Mark. I'm sure it's not keyword.url nor my ISP's DNS.

Same theory as Mark. I'm sure it's not keyword.url nor my ISP's DNS.
TXGuy 87 giải pháp 861 câu trả lời
Được đăng

Do you have a Microsoft offered toolbar installed (i.e., Windows Live Toolbar, Bing Toolbar, etc.)? Do you have one of those installed in IE but not in Firefox?

~~blue:Microsoft pulled another sneaky, un-annouced addition to Firefox~~ similar to the .NET Framework added to Firefox some time ago. If you have a Microsoft offered toolbar in IE ~~red:but not previously installed~~ in Firefox, an update in the June 2010 Windows/Microsoft Updates ~~blue:added it to Firefox!!!~~ Read the following ~~red:very~~ carefully, ~~red:all the way to the end of the article~~:

http://arstechnica.com/microsoft/news/2010/06/microsoft-slips-ie-firefox-add-on-into-toolbar-update.ars

Also see: http://forums.mozillazine.org/viewtopic.php?f=38&t=1918559

Do you have a Microsoft offered toolbar installed (i.e., Windows Live Toolbar, Bing Toolbar, etc.)? Do you have one of those installed in IE but not in Firefox? ~~blue:'''Microsoft pulled another sneaky, un-annouced addition to Firefox'''~~ similar to the .NET Framework added to Firefox some time ago. If you have a Microsoft offered <u>'''toolbar in IE'''</u> ~~red:<u>'''but not previously installed'''</u>~~ <u>'''in Firefox'''</u>, an update in the June 2010 Windows/Microsoft Updates ~~blue:<u>'''added it to Firefox!!!'''</u>~~ Read the following ~~red:<u>'''very'''</u>~~ carefully, ~~red:<u>'''all the way to the end of the article'''</u>~~: http://arstechnica.com/microsoft/news/2010/06/microsoft-slips-ie-firefox-add-on-into-toolbar-update.ars Also see: http://forums.mozillazine.org/viewtopic.php?f=38&t=1918559

Người tạo câu hỏi

same problem here.

same problem here.

Người tạo câu hỏi

Same problem, changed keyword.url and still goes to bing, even when I use safe mode. I don't see the "Search Helper" mentioned in TXGuy's links anywhere in my addons either.

Please fix this quickly. Bing doesn't understand foreign encodings like Google does.

Same problem, changed keyword.url and still goes to bing, even when I use safe mode. I don't see the "Search Helper" mentioned in TXGuy's links anywhere in my addons either. Please fix this quickly. Bing doesn't understand foreign encodings like Google does.
TXGuy 87 giải pháp 861 câu trả lời
Được đăng

Nick said: I don't see the "Search Helper" mentioned in TXGuy's links anywhere in my addons either.

In the Ars Technia article, FIFTH PARAGRAPH, THIRD SENTENCE:

Both seem to be installed in ~~red:"C:\Program Files\Microsoft\Search Enhancement Pack\Search Helper\~~." Inside, there is a file called "SEPsearchhelperie.dll" that is responsible for the IE add-on ~~red:and a "firefoxextension" folder responsible for Firefox~~. The update can't be uninstalled, but ~~red:deleting these files works just fine~~.

Did you look there?

Nick said: '''''I don't see the "Search Helper" mentioned in TXGuy's links anywhere in my addons either.''''' In the Ars Technia article, FIFTH PARAGRAPH, THIRD SENTENCE: '''''Both seem to be installed in ~~red:"C:\Program Files\Microsoft\Search Enhancement Pack\Search Helper\~~." Inside, there is a file called "SEPsearchhelperie.dll" that is responsible for the IE add-on ~~red:and a "firefoxextension" folder responsible for Firefox~~. The update can't be uninstalled, but ~~red:deleting these files works just fine~~. ''''' Did you look there?

Người tạo câu hỏi

There isn't a "Microsoft" folder in my Program files. There's things like "Microsoft Office" and "Microsoft Visual Studio", but no straight up "Microsoft". I also searched for things like "Enhancement" and "Search" in my program files, and am currently searching my entire C: drive, but nothing like "Enhancement Pack" or anything is showing up.

Maybe I have something different?

There isn't a "Microsoft" folder in my Program files. There's things like "Microsoft Office" and "Microsoft Visual Studio", but no straight up "Microsoft". I also searched for things like "Enhancement" and "Search" in my program files, and am currently searching my entire C: drive, but nothing like "Enhancement Pack" or anything is showing up. Maybe I have something different?

Người tạo câu hỏi

Same problem here but it started 2 days ago? I also don't have that folder in my Program files? Is it something else that's doing this?

Same problem here but it started 2 days ago? I also don't have that folder in my Program files? Is it something else that's doing this?

Người tạo câu hỏi

Keyword searches are being redirected to bing, but

Keyword.url is set to a google search url

The Microsoft toolbar hasn't! been installed on my machine (ie no directory in program files as mentioned above. No entry in the program updates history either

Also couldn't find any instances of the string "bing" in the registry.

Keyword searches are being redirected to bing, but Keyword.url is set to a google search url The Microsoft toolbar hasn't! been installed on my machine (ie no directory in program files as mentioned above. No entry in the program updates history either Also couldn't find any instances of the string "bing" in the registry.

Người tạo câu hỏi

Yup, running into the same problem here with keyword searches being redirected to bing.

I've played around with changing Keyword.url to no effect and can't find the search helper toolbar in add-ons or in program files.

On a stranger note, simple, one word queries are sent to bing while multi-worded entries are handled properly. Also, the problem seemed to be resolved for me a little while ago, with all address bar searches being directed to google. However, upon restarting firefox, it was bing.com again.

Yup, running into the same problem here with keyword searches being redirected to bing. I've played around with changing Keyword.url to no effect and can't find the search helper toolbar in add-ons or in program files. On a stranger note, simple, one word queries are sent to bing while multi-worded entries are handled properly. Also, the problem seemed to be resolved for me a little while ago, with all address bar searches being directed to google. However, upon restarting firefox, it was bing.com again.

Người tạo câu hỏi

Uninstalling KB982381 solved it for me. I have no idea what it does except hijacking the search: http://www.microsoft.com/technet/security/bulletin/ms10-035.mspx

Let's hope MS will release a proper update next time

Uninstalling KB982381 solved it for me. I have no idea what it does except hijacking the search: http://www.microsoft.com/technet/security/bulletin/ms10-035.mspx Let's hope MS will release a proper update next time