Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Disable search in adressbar

  • 6 trả lời
  • 0 gặp vấn đề này
  • 8 lượt xem
  • Trả lời mới nhất được viết bởi zeroknight

more options

I want to use the search field for search and the adressbar to enter adresses. Unfortunately it doesn't let me enter adresses, they all get routed to a search provide (google) and I can't acees my router

How can I dsable the search in the adressbar?

Setting browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar (are you kidding me?) to flase does not help

I want to use the search field for search and the adressbar to enter adresses. Unfortunately it doesn't let me enter adresses, they all get routed to a search provide (google) and I can't acees my router How can I dsable the search in the adressbar? Setting browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar (are you kidding me?) to flase does not help

Tất cả các câu trả lời (6)

more options

You can exclude your router from search by going to about:config and creating browser.fixup.domainsuffixwhitelist.<routername> (Boolean) with value true.

Disable all searching in the address bar by changing keyword.enabled to false.

Hữu ích?

more options

This is not my problem, just an example.

I never want to search anything theat begins with protocol:// in the adressbar. I never want to search anything in the adressbar, because I have a search field.

Được chỉnh sửa bởi joe80 vào

Hữu ích?

more options

Go to about:config and change keyword.enabled to false.

Hữu ích?

more options

I did that before. It still wants to use search in most cases instead of following the URL.

I want the adressbar to not search. Never. It's an adress bar, not a search bar

Hữu ích?

more options

I have never had any such problem. Have you switched off all search suggestions in Settings on the Search and Privacy & Security pages? If so, I suggest restarting in troubleshoot mode to see whether the problem still occurs.

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Hữu ích?

more options

joe80 said

in most cases

Does this only happen with single words? Try changing browser.fixup.dns_first_for_single_words to true in about:config.

It will still do a search if the query starts with "?", "@" or a search keyword.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.