Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Spotify webplayer on Firefox is unuseable after updating to latest version

  • 13 trả lời
  • 9 gặp vấn đề này
  • 948 lượt xem
  • Trả lời mới nhất được viết bởi Howlzr

more options

Majority of the songs do not play and I'm given with a pop-up, "Spotify can't play this right now. If you have the file on your computer you can import it."

I will play a song from a playlist and is given that pop-up, it will continue skipping to the next song until it plays, but only for 9-10 seconds until the song mutes, to specify, the dot (when hovered on the progress bar) will still move, indicating that "it's playing".

Some clarifications: 1. I use Spotify Desktop app (windows), Spotify App (android), and Spotify Webplayer on Chrome and Firefox. Everything works just as fine on all of these, except for Spotify Webplayer on Firefox. 2. Skipping to a later timestamp does not unmute the song. 2. I have Spotify Premium 3. I have no VPN 4. I am running Firefox with an ad blocker 5. I am running Chrome with an ad blocker (same ad blocker in Fifefox) 6. I am running Firefox to the latest version (Firefox 119.0.1 (20231106151204))

What I've done so far: 1. Cleared caches and data. 2. Updated my Windows to the latest update available - Win10 v.22H2 3. Signed-out of Spotify for all my devices, then logging-in first on Spotify Desktop (this automatically redirects to Firefox webplayer) 4. Ran Firefox on "Troubleshoot Mode" 5. Un-checked and re-checked "Play DRM content" setting. 6. Disabled and re-enabled the plug-in "Widevine Content Decryption Module by Google Inc". (this plug-in is last udpated on November 17, 4.10.2710.0

I'm including this link from Spotify's Community page.. where two other users, who commented it is only with Firefox (webplayer), are experiencing the same problem as I am. https://community.spotify.com/t5/Desktop-Windows/Spotify-can-t-play-this-right-now-If-you-have-the-file-on-your/m-p/5679914#M123192

Majority of the songs do not play and I'm given with a pop-up, "Spotify can't play this right now. If you have the file on your computer you can import it." I will play a song from a playlist and is given that pop-up, it will continue skipping to the next song until it plays, but only for 9-10 seconds until the song mutes, to specify, the dot (when hovered on the progress bar) will still move, indicating that "it's playing". Some clarifications: 1. I use Spotify Desktop app (windows), Spotify App (android), and Spotify Webplayer on Chrome and Firefox. Everything works just as fine on all of these, except for Spotify Webplayer on Firefox. 2. Skipping to a later timestamp does not unmute the song. 2. I have Spotify Premium 3. I have no VPN 4. I am running Firefox with an ad blocker 5. I am running Chrome with an ad blocker (same ad blocker in Fifefox) 6. I am running Firefox to the latest version (Firefox 119.0.1 (20231106151204)) What I've done so far: 1. Cleared caches and data. 2. Updated my Windows to the latest update available - Win10 v.22H2 3. Signed-out of Spotify for all my devices, then logging-in first on Spotify Desktop (this automatically redirects to Firefox webplayer) 4. Ran Firefox on "Troubleshoot Mode" 5. Un-checked and re-checked "Play DRM content" setting. 6. Disabled and re-enabled the plug-in "Widevine Content Decryption Module by Google Inc". (this plug-in is last udpated on November 17, 4.10.2710.0 I'm including this link from Spotify's Community page.. where two other users, who commented it is only with Firefox (webplayer), are experiencing the same problem as I am. https://community.spotify.com/t5/Desktop-Windows/Spotify-can-t-play-this-right-now-If-you-have-the-file-on-your/m-p/5679914#M123192

Giải pháp được chọn

Are you still on version 119? You can update to 120 now by downloading the latest installer.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (13)

more options

What Ad blocker(s) do you have ? Did you try to disable all ad blockwers? Do you allow both Audio and Video on the Spotify website ?

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Hữu ích?

more options

1. I only have uBlock Origin. 2. Yes, I have tried disabling it. Still nothing / no changes. 3. I have now allowed both Audio and Video for Spotify website. Still nothing / no changes.

4.After accessing the Web Console, I could only filter out one (1) and two (2) console messages containing the words "block" and "content", respectively.

Filter results for block A. Request to access cookie or storage on “<URL>” was blocked because it came from a tracker and content blocking is enabled. 5

Filter results for "content" A. Content-Security-Policy warnings 4 B. Request to access cookie or storage on “<URL>” was blocked because it came from a tracker and content blocking is enabled. 5

Could you take a look at the attached images of the following below, and see if there are indicators/messages I may be missing? > Full text of the filtered console messages. > All Warnings > All Errors

5. Checking the Network Monitor leads to all requests with 200 (okay) status. 6. Done reloading the page. Still nothing/no changes.

Hữu ích?

more options

Try disabling Tracking Protection for the site.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Hữu ích?

more options

You can check for issues with Total Cookie Protection.

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

Hữu ích?

more options

By the time that I am writing this reply, I've done only two things after following zeroknight's reply:

1. Disable tracking protection - Still nothing / no changes

   > I proceeded to check the Console after disabling, please see results in attached images.

2. Installed the Developer Edition

   !! The site is working as normal. Song plays, no skipping, no muting.
   >  I proceeded to check the Console, please see results in attached images.

Following cor-el's latest reply, the only additional info I could share is that I checked the following below, under "How do I know if the site breakage is caused by Total Cookie Protection?" > network.cookie.cookieBehavior is set to 5 > I haven't changed this yet because of the warning about doing it only for advance users.

I haven't read the articles under Enhanced Tracking Protection because of the results following #1. If relevant, I have screenshots of the sites that are blocked when Enchanced Tracking Protection is on - currently two are blocked: Social Media Trackers and Cross-Site Tracking Cookies.

Please advice what to do next following #2.

Được chỉnh sửa bởi kit vào

Hữu ích?

more options

You can change the cookie settings via "Settings -> Privacy & Security" via the custom settings.

Selecting "Cross-site tracking cookies" sets network.cookie.cookieBehavior to '4' and does not partition/isolate cross-site cookies, but still keeps Enhanced Tracking Protection enabled. Selecting "Cross-site tracking cookies, and isolate other cross-site cookies" sets network.cookie.cookieBehavior to '5' and enables Total Cookie Protection.

Hữu ích?

more options

I've changed it now, it's still the same, it didn't fix the site.

Hữu ích?

more options

If it works in Developer Edition and you can't figure out what setting is responsible, the next thing would be to test a new profile with normal Firefox and possibly refresh your existing profile.

Hữu ích?

more options

I've made two attempts at creating a new profile under the normal Firefox. 1. First profile

   > upon start-up, I've imported bookmarks from HTML, then synced my mozilla account.
   > Logged-in to Spotify . The issue still persist.

2. Second profile

   > upon start-up, I clicked "Skip for now" 
   > Logged-in to Spotify. The issue still persist.

I've now finished refreshing my existing profile. The issue still persist.

Hữu ích?

more options

Giải pháp được chọn

Are you still on version 119? You can update to 120 now by downloading the latest installer.

Hữu ích?

more options

Thank you for informing! Just updated to 120 now, and it sure did fix the website, finally.

Thank you both for the help.

Hữu ích?

more options

zeroknight said

Are you still on version 119? You can update to 120 now by downloading the latest installer.

I've been having the same issue. I just updated to 120 and it hasn't fixed the problem.

Hữu ích?

more options

There seems to have been a similar issue a few years ago (It's on the spotify forums), but I'm not exactly sure if there is a Firefox equivalent to the 'Clear Active Connections' setting that was mentioned, or where to find it if so.

At the same time that I started having this issue (a few days ago), Disney+ also started consistently giving me an 'Error 83' and not playing videos. Wondering if it might be linked?

[Link To The Spotify Forum Post]

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.