Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

No longer have the option to save default behaviour of a download file

  • 5 trả lời
  • 0 gặp vấn đề này
  • 1 lượt xem
  • Trả lời mới nhất được viết bởi brian

more options

for new file types the option to save the default behaviour for future downloads is no longer avaliable for me. Also, the option to set in "Settings -> General -> Files and Applications" does not show any of the new file types.

I've tried re-installing firefox, as well as refreshing but still the same results.

for new file types the option to save the default behaviour for future downloads is no longer avaliable for me. Also, the option to set in "Settings -> General -> Files and Applications" does not show any of the new file types. I've tried re-installing firefox, as well as refreshing but still the same results.
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

The "Do this automatically for files like this from now on" checkbox is missing because the site in your screenshot has a response header with a generic content type ("application/octet-stream"). You can override this with Content-Type Fixer.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (5)

more options
more options

Hi Paul,

Unfortunately no that article didn’t provide the solution as the file type is not being added to the list of known file types

more options

Giải pháp được chọn

The "Do this automatically for files like this from now on" checkbox is missing because the site in your screenshot has a response header with a generic content type ("application/octet-stream"). You can override this with Content-Type Fixer.

more options

You can't add entries directly to the download application actions panel, this can only be done via the checkbox on the "Save as" download prompt.

If you do not see this panel then this might be a problem with the dark theme you use and you may have to get an update in case you use CSS code in userContent.css.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Thanks, I was able to solve this with the https://addons.mozilla.org/en-US/firefox/addon/content-type-fixer/ extension