Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Cannot manually visit HTTP websites - complete automatic redirect to HTTPS

  • 12 trả lời
  • 1 gặp vấn đề này
  • 42 lượt xem
  • Trả lời mới nhất được viết bởi ajfigurelli

more options

For a few days now, Firefox (Dev. Edition, version 90) has not allowed me to manually visit http:// websites, and automatically and silently redirects to their https:// version. This is on every single website I have tried.

Things that I have tried:

Disable/remove HTTPS Everywhere Enable then re-disable built-in Firefox HTTPS Only Mode

Restart Firefox 'Forget about this site' Clear cache Clear site preferences A bunch of stuff in about:config (fallback-to-https, stricttransportpreloadlist etc)

Giải pháp được chọn

Firefox can be stubborn if the server has a certificate installed, but isn't working with a secure connection and automatically try to upgrade to https://.

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (12)

more options

I refreshed Firefox and it worked for a bit but now it's doing it again after I hit 'reload' on a page that "wasn't redirecting properly".

Hữu ích?

more options

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Hữu ích?

more options

Yes, the problem occurs in safe mode as well.

Hữu ích?

more options

Remove History For One Site {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings

Hữu ích?

more options

I've already tried that, and it didn't work.

Hữu ích?

more options

Did you try to delete SiteSecurityServiceState.txt in the profile folder ?

Did you try to disable HTTPS-Only for this website via the padlock icon drop-down list ?


Boot the computer in Windows Safe Mode with network support to see if that has effect.

Hữu ích?

more options

I closed Firefox and deleted the file, but it unfortunately didn't fix my issue. It created the file again exactly as it was before I deleted it.

HTTPS-Only is off, and I don't have this problem on any other browser I've tried (IE, Edge)

Hữu ích?

more options

Giải pháp được chọn

Firefox can be stubborn if the server has a certificate installed, but isn't working with a secure connection and automatically try to upgrade to https://.

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Hữu ích?

more options

I refreshed Firefox last night and it fixed the problem temporarily. I tried with a new profile just now and it seems to be working, as well. I'll post again if it stops working again. Thanks for the assistance.

Hữu ích?

more options

It's doing it again. I can't refresh firefox or make a new profile every single time this happens. Why is there a setting for always using HTTPS if it's going to do it anyway? It's not just a problem with the one website I need HTTP for, after it triggers I can't visit ANY website in non-HTTPS mode until I refresh or make a new profile, and then I have to set up all of my extensions and the UI like I've had it for years.

Hữu ích?

more options

Did you install any extension that could be causing this because with HTTPS-Only disabled this should never happen ?

Enabling DNS over HTTPS also might be causing this.

You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Hữu ích?

more options

I switched from developer edition back to the main-line Firefox a few days ago and it hasn't broken yet, so it may be a problem with the Beta or Developer branches.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.