Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Some Excel files download but do not show associated with Excel or appear to have no file name extension.

  • 14 trả lời
  • 10 gặp vấn đề này
  • 23041 lượt xem
  • Trả lời mới nhất được viết bởi RangeRyder

more options

Some Excel files download but do not show associated with Excel or appear to have no file name extension. If I download these files using Internet Explorer they open properly. I can add xls or xlsx to the file name and it will open properly with Excel. If I select the file the 'open file with' dialog box opens and I if select Excel, the file will not open at all.....nothing happens and Excel does not open. The excel file in the attached image are those where I added the excel file name extension.

Giải pháp được chọn

Unfortunately, the way that Firefox assigns the file name is more literal and less improvisational than Internet Explorer, so you may need to add that .xls or .xlsx extension yourself from time to time.

If you want to do it at the earliest possible time, you can change from immediate downloading to asking you where the save the file, which also provides the opportunity to edit the file name. If you want to try that, the setting is described here: Startup, home page, tabs, and download settings.

Đọc câu trả lời này trong ngữ cảnh 👍 4

Tất cả các câu trả lời (14)

more options

Giải pháp được chọn

Unfortunately, the way that Firefox assigns the file name is more literal and less improvisational than Internet Explorer, so you may need to add that .xls or .xlsx extension yourself from time to time.

If you want to do it at the earliest possible time, you can change from immediate downloading to asking you where the save the file, which also provides the opportunity to edit the file name. If you want to try that, the setting is described here: Startup, home page, tabs, and download settings.

more options

ldhoward said

Some Excel files download but do not show associated with Excel or appear to have no file name extension. If I download these files using Internet Explorer they open properly. I can add xls or xlsx to the file name and it will open properly with Excel. If I select the file the 'open file with' dialog box opens and I if select Excel, the file will not open at all.....nothing happens and Excel does not open. The excel file in the attached image are those where I added the excel file name extension.

Thanks!!

more options

'''About two weeks ago, was the last time I downloaded the file and it opened correctly. Pictures attached.

Problem "Just Started." I log in to my Bill Pay program and selected to down load a payment history. Previously; the file' history.csv' would be downloaded or opened in Excel 2010 as a spreadsheet file.

Current Firefox version 39.0

Now when I elect to open with Excel 2010, the file appears as a text delimited file.

Before the file is opened, I get an "error message" in Excel: I am told the file "type" has been changed to history.csv.htm

I contacted the Bill Pay Provider and they said they assign the history.csv name and file type to the file.

I logged in to IE 11 and latest version of Google Chrome, when I downloaded the file it opened properly in Excel as a spread sheet format.

more options

Hi Range_Rider, as an immediate workaround, you can edit the file name to remove the extra .htm extension.

If the server is sending the correct content type, then the second dialog should not say Firefox HTML document and no .htm extension should be added.

Sometimes the file that stores the associations between content types and applications becomes corrupted. Since the file's XML format is difficult to edit, the usual suggestion is to rename the file and have Firefox rebuilt it from scratch. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old (in case you need to recover it later).

Start Firefox back up again. You will need to restore some settings such as your preferred PDF viewer and client for email links.

Any improvement with CSV files?

more options

Tried it, renamed file to .old . Restarted Firefox, logged into Bill Pay. Set it up to download the data.

The dialog box did not suggest open in Excel, used other and selected Excel.

Same problem, opened in a CSV text layout like before.

I am going to try this on another computer, same OP system and same version of Firefox.

My Bill Pay service did up date there software, I'm not ruling out they caused the problem.

more options

Hi Range_Rider, what Firefox looks for is the Content-type header sent by the server ahead of the file. For CSV, and good content-type to send is "text/csv" and it seems based on the behavior that Firefox is getting "text/html" instead. This can occur when configuration of a new webserver is incomplete, but I have no idea whether that is the case with this vendor.

One way to inspect that header is before clicking the download link, open the Web Console in the lower part of the tab using either:

  • Ctrl+Shift+k
  • Developer menu

When you then click the link for the download, and cancel it, the URL should be listed in the console. If you click that, Firefox should display the request and response headers, and among the response headers you should be able to find the Content-Type sent by the server. Or perhaps one isn't being sent at all?

Google Chrome as a similar kind of console, there you would check the Network section, but I don't know the most convenient way to open it.

more options

[Haven't tried last post yet.]

UPDATE:

I have tried the download on two other computers; Win 7 Home Premium and Firefox V39.0

The downloads opened Excel (was same version) as expected...an Excel spreadsheet file. Did noticed in the download Dialog box when the file was downloaded... there was comment saying the csv file will open as an Excel Spreadsheet.

I do not see this Dialog comment on my computer when I down load the file.

I now must believe my down load process for what I am doing is either broken or corrupted.

For those who are thinking, yes I can down load the FILE and import the CSV file in to Excel, data is not corrupted.

Will try last suggestion and post status.
more options

For scher2000: performed your request, screen print below.

Question:

How do I tell Firefox that a .csv file is for (or to open) in Excell; or what changed that is confusing Firefox?

more options

Hi Range_Rider, somewhere in the console you should see the URL to the download. I don't see a scroll bar to look for it, so you might not have had the console opened before trying the link. Or maybe the link generates a new tab, which Firefox closes when it recognizes when it is a download. In that case, you can access the information using the Browser Console. Either:

  • Ctrl+Shift+j
  • Developer Tools > Browser Console

Click the Clear button at the top to remove unnecessary noise, then switch over to the page and try the download link again, then check the Browser Console for the URL. Then you could click the URL to call up a dialog showing the request and response headers, and there look for Content-Type. I have attached an example.

That said, I think the server must be set up correctly because it works on Firefox on other systems. Do you have any content filtering add-ons or external software that might be altering how files are received from the server??

Được chỉnh sửa bởi jscher2000 vào

more options

I provided the images I believe you want to see.

I performed another test, saved an Excel spreadsheet in .csv format and sent it to my self. It open in Excel as a spread sheet. I verified and look for clues on my computer using Chrome and IE, could not get them to "fail"

Doing some research, it appears I am not reading the file correctly from Bill Pay due to "character interpretation?" Can I force Firefox to see ISO characters instead of plain text?

more options

Hi Range_Rider, I think most of the error messages are related to other content in the page. Your third screen shot shows that for some strange reason, your Firefox is receiving a content-type of text/html for the .csv file, which is not normal.

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

There is no change same dialog box message running in Firefox Safe mode.

As strange as this is, I have experienced one other problem in Bill Pay Service web site. Making a change to a scheduled payment entry, always comes back with an error, however the actual change went through.

"A system error has occurred. Your request may not have been completed successfully. Please verify, and if necessary, try again."

This error is duplicated in Chrome and IE. This may be an actual bug for them to address.

Is there any item in about:config that could cause it not to read the "characters" correctly?

more options

Hi Range_Rider, there probably are some about:config settings for how to handle characters in web pages, but since the site is indicating disposition:attachment, Firefox is supposed to simply pop up the Open/Save dialog and not try to read the contents of the file itself.

If this same download works in other installations of Firefox, I suspect something is modifying the header between the server and your Firefox on this system. Could you check whether you have any unusual connection setting:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default of "Use system proxy settings" should piggyback on the Windows/IE "LAN" setting, but you also could try "No proxy" to see whether that makes any difference.

If this remains unsolved, I think you would have to continue renaming the file back to its intended name by removing the .htm extension.

more options

There has been a change. I checked "use system Proxy settings" tried it - would not open in Excel. I check no proxy, tried it - it still failed. I selected save file and it (the download) saved it as a .csv in my downloads.

I opened it and it opened Excel and displayed  - correctly? 

While opening in Excel is still not happening, another "smaller" problem has arisen. The cvs data is not "coming down" sorted as displayed on the screen.

I am going to call the BILL PAY service and ask what is happening there.

Also please note, some time when I save the file, it fails to save, however the 2nd time it saves the file as a csv.