Como ajustar preferências que não são salvas

Em algumas situações, as opçõespreferências do Firefox não são salvas após efetuar alterações. Por exemplo, você pode alterar as configuração nas OpçõesPreferências mas o valor original volta quando abrir as OpçõesPreferências novamente. Este artigo também pode ser aplicado se após a atualização do Firefox você notar que a aba Firefox Atualizado é carregada sempre que o Firefox é iniciado.

As possíveis causas e soluções variam, dependendo se você tem a possibilidade de salvar algumas preferências específicas ou se não há preferências para ser salvas. Seu problema também pode ser devido a algum vírus ou software malicioso. Veja Solucione problemas causados por Malware no Firefox para mais detalhes.

Nota: Alguns programas como o Advanced SystemCare com Surfing Protection podem impedir que arquivos do seu perfil do Firefox sejam modificados. Se você tem instalados em seu computador programas desse tipo verifique suas configurações ou os desinstale.

Restaure o seu Firefox para corrigir o problema

A maneira mais fácil de resolver este problema é restaurar o Firefox para o seu estado original, preservando suas informações essenciais. Além de redefinir todas as preferências, irá corrigir uma ampla gama de outros problemas, incluindo os causados por complementos ou com dados e configurações que são armazenadas em outros arquivos do seu perfil. Se você preferir tentar correções mais precisas, pule esta seção e tente as soluções abaixo.

Nota: Ao usar o recurso de restauração, seus favoritos, histórico, abas abertas, janelas, senhas, cookies e informações de preenchimento automático de formulários serão salvos. No entanto, seus complementos e temas serão removidos e suas preferências serão reiniciadasAo usar o recurso de restauração, seus favoritos, histórico, abas abertas, janelas, senhas, cookies e informações de preenchimento automático de formulários serão salvos. No entanto, seus complementos e temas serão removidos e suas preferências serão reiniciadas Ao usar o recurso de restauração, seus favoritos, histórico, senhas, cookies e informações de preenchimento automático de formulários serão salvos. Porém, seus complementos e temas serão removidos. Abas abertas, janelas e grupos de abas não serão salvos e suas preferências serão reiniciadas. Veja mais.
  1. Clique no menu Ajuda e selecione Dados para suporte., clique no botão Firefox, vá para o dub-menu Ajuda e selecione Dados para suporte.Na barra de menu, clique em Ajuda e selecione Dados para suporte.
    Reset Firefox 1 - WinXP Troubleshooting info - win Troubleshooting info - mac Troubleshooting info - lin
    Se não for possível acessar o menu Ajuda menu, digite about:support na barra de endereços para abrir a página Dados para suporte.
  2. Clique em Restaurar o Firefox no canto superior direito da página de Informação de Resolução de Problemas.
    Reset Firefox 2 - WinXP Reset Firefox - Win - 1 Reset Firefox - Mac - 1 Reset Firefox - Lin - 1
  3. Para continuar, clique em Restaurar o Firefox na janela de confirmação que se abriu.Para continuar, clique em Restaurar Firefox na janela de confirmação que se abriu.
  4. Firefox irá fechar e ser restaurado. Quando estiver feito, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox irá abrir.Firefox irá fechar e ser restaurado. Quando estiver feito, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox irá abrir.
  1. Clique no botão de menu New Fx Menu e a seguir clique em ajuda Help-29 .
  2. No menu Ajuda selecione Dados para suporte.
    Se não for possível acessar o menu Ajuda menu, digite about:support na barra de endereços para abrir a página Dados para suporte.
  3. Clique no botão Restaurar o Firefox... no canto superior direito da página de Dados para Suporte.
    Reset 29 Win Reset 29 Mac Reset 29 Lin
  4. Para continuar, clique em Restaurar o Firefox na janela de confirmação que será aberta.
  5. O Firefox será fechado e reiniciado. Quando terminar, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox abrirá.
  1. Clique no botão Restaurar o Firefox... no canto superior direito da página de Dados para Suporte.
  2. Para continuar, clique em Restaurar o Firefox na janela de confirmação que será aberta.
  3. O Firefox será fechado e reiniciado. Quando terminar, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox abrirá.

Nota: O botão Refresh FirefoxReset Firefox também está disponível no Modo Seguro do Firefox se você não consegue iniciar o Firefox normalmente.

Preferências específicas não estão sendo salvas

Se uma configuração específica no Firefox é restaurada ou não é possível que você altere uma única configuração, mas outras configurações estão salvas corretamente, provavelmente você deve ter uma das seguintes questões.

Programas de terceiros estão alterando as configurações do Firefox

Alguns programas forçam o Firefox a usar certas configurações. Abaixo está uma lista de programas conhecidos que fazem isso e as ações que você pode tomar para fazê-los parar de forçar as configurações do Firefox:

  • Creative ZenCast altera o agente usuário do Firefox, interferindo com o Java.
    • Desinstalar o programa
  • McAfee Privacy Service desliga o bloqueador de pop-up do Firefox.
  • Norton 360 inclui uma "Limpeza de privacidade do Firefox" característica essa que, se ativado, substitui as configurações de privacidade do seu Firefox e evita de você manter seu Histórico de Navegação, cookies ou outros dados privados entre as sessões.

Algumas barras de ferramentas de terceiros e extensões alteram a página inicial do Firefox e configurações de pesquisa. Você pode restabelecer rapidamente estes com o SearchReset add-on. • See Remova barra de ferramentas que alteram a pesquisa ou a página inicial para mais informações.

User.js arquivo de substituição de preferências

Se você não tiver qualquer um dos programas acima instalados, ou se você seguiu as sugestões e preferências individuais que ainda não estão salvas, você Você pode ter que editar os arquivos de configuração do seu Firefox. Não entre em pânico, pois é muito fácil. Aqui está como fazê-lo.

  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no botão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba com os dados para suporte será aberta.Clique no botão New Fx Menu , depois em ajuda Help-29 e então em Dados para suporte. A aba com os dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se não conseguir abrir ou usar o Firefox, siga as instruções para encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Abra o arquivo user.js com um editor de texto (como Bloco de NotasGedit ou KateTextEdit).
  6. Se não houver nenhum arquivo user.js, estes passos não irão ajudá-lo.
  7. Remova as linhas de opçõespreferências que você deseja autorizar a mudança. Você pode excluir todas as linhas, caso deseja ser autorizado a fazer todas as alterações.
  8. Salve o arquivo e feche o editor de texto.

Agora você já deve ser capaz de alterar as configurações do Firefox.

O arquivo de programa do Firefox bloqueia ou evita alterações para determinadas preferências

A instalação do Firefox pode ter sido personalizada para adicionar um arquivo de configuração do programa que bloqueia ou impede que determinadas alterações sejam salvas. Siga os passos no artigo Diagnosticar e resolver problemas do Firefox para remover o Firefox do seu computador e instalar uma nova cópia. Reinstalar o Firefox desta forma não irá remover seus dados e configurações do usuário, desde que estejam salvos em um local separado dos arquivos de programa.

Não é possível salvar qualquer preferência ou configuração

Se nenhuma das suas configurações forem salvas, e se você notar que a aba Firefox Atualizado é carregada sempre que o Firefox é iniciado, ou se já tentou os passos acima sem sucesso, pode ser que o arquivo que o Firefox utiliza para salvar suas preferências esteja bloqueado ou corrompido.

Arquivo de preferências protegido contra gravação

O Firefox pode ser impossibilitado de salvar suas configurações, se o arquivo prefs.js (ou o prefs.js.moztmp) existirem e estiverem protegidos contra gravação ou existem outros arquivos de backup de suas preferências.

  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no botão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba com os dados para suporte será aberta.Clique no botão New Fx Menu , depois em ajuda Help-29 e então em Dados para suporte. A aba com os dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se não conseguir abrir ou usar o Firefox, siga as instruções para encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Localize o arquivo prefs.js (e o arquivo atual prefs.js.moztmp ).
  6. Clique com o botão direito em um arquivo de cada vez, selecione e selecione Properties no menu de contexto. Verifique se em Atributos, não há nenhuma marcação na caixa ao lado de Somente Leitura para qualquer arquivo.
    • Se o RealPlayer estiver aberto, ele pode estar bloqueando o arquivo prefs.js. Fechar o RealPlayer deve desbloqueá-lo.
  7. Exclua qualquer arquivo prefs-n.js onde n é um número (por exemplo prefs-2.js).
  8. Exclua Invalidprefs.js se o arquivo existir.
  9. Reinicie o Firefox. Agora você deve estar habilitado a salvar preferências.
  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no botão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba com os dados para suporte será aberta.Clique no botão New Fx Menu , depois em ajuda Help-29 e então em Dados para suporte. A aba com os dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se não conseguir abrir ou usar o Firefox, siga as instruções para encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Localize o arquivo prefs.js (o arquivo atual prefs.js.moztmp).
  6. Para cada arquivo, certifique-se que seu usuário tenha permissões de gravação para o arquivo.
  7. Exclua qualquer arquivo prefs-n.js, onde n é um número, (por exemplo, prefs-2.js).
  8. Exclua o arquivo Invalidprefs.js se este existir.
  9. Reinicie o Firefox. Agora você deve conseguir salvar preferências.
  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no botão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba com os dados para suporte será aberta.Clique no botão New Fx Menu , depois em ajuda Help-29 e então em Dados para suporte. A aba com os dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se não conseguir abrir ou usar o Firefox, siga as instruções para encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Localize o arquivo prefs.js (e se estiver presente, o arquivo prefs.js.moztmp).
  6. Para cada arquivo, mantenha pressionado a tecla Ctrl e selecione Get Info.
  7. Certifique-se de que a opção Bloqueado esteja desmarcada.
  8. Exclua quaisquer arquivos prefs-n.js, onde n é um número, (por exemplo, prefs-2.js).
  9. Excluir Invalidprefs.js se este existir.
  10. Reiniciar o Firefox. Agora você deve conseguir salvar preferências.

Arquivo de preferências corrompido

O arquivo de preferências pode estar corrompido, impedindo o Firefox de alterá-lo. Se você excluir este arquivo, o Firefox irá criá-lo novamente de forma automática, quando ele necessitar.

Veja como excluir o arquivo prefs.js.

Isto irá remover todas as suas configurações e ajustes personalizados, para várias extensões.
  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no botão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba com os dados para suporte será aberta.Clique no botão New Fx Menu , depois em ajuda Help-29 e então em Dados para suporte. A aba com os dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se não conseguir abrir ou usar o Firefox, siga as instruções para encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Localize o arquivo prefs.js (e se presente, o arquivo prefs.js.moztmp).
  6. Exclua estes e quaisquer arquivos prefs-n.js onde n um número, (por exemplo, prefs-2.js).
  7. Exclua Invalidprefs.js se este existir.
  8. Reinicie o Firefox. Agora você deve ter todas as suas preferências restabelecidas.




Baseado em informações da Preferencias não salvas (mozillaZine KB)


Compartilhe este artigo: http://mzl.la/1BAQrbZ

Este artigo foi útil? Por favor, aguarde...

Contribuidores que ajudaram a escrever esse artigo: ouesten, JeffGuimaraes, brwolfgang, reginaduarte. Você também pode ajudar - descubra como.