Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

permanently lock window position - xulstore.json

  • 2 balasan
  • 0 ada masalah ini
  • 2 paparan
  • Balasan terakhir oleh Ondrej

more options

Hi,

how to lock window position permanently in Firefox? After the last update (v.119) some pages change randomly - they break the window size - it stays maximized (but not fully), my "favorite size" breaks = the browser starts in "broken size" on new start.

With versions 118.X, it was enough to set the file "xulstore.json" to "read only" in my profile directory, and whenever I made any changes, after restarting the browser, everything turned on according to my settings and everything was fine.

Now it reads this data from some other source - just from where and how to change it???

PS: when I lock the "xulstore.json" file in v.119 and accidentally resize the window right after a new start, the window size is loaded from "xulstore.json" for a few moments, but then it changes to the size I exited Firefox with - and I do not want that.

It's getting on my nerves :/ Well thank you.

Hi, how to lock window position permanently in Firefox? After the last update (v.119) some pages change randomly - they break the window size - it stays maximized (but not fully), my "favorite size" breaks = the browser starts in "broken size" on new start. '''With versions 118.X, it was enough to set the file "xulstore.json" to "read only" in my profile directory, and whenever I made any changes, after restarting the browser, everything turned on according to my settings and everything was fine.''' '''Now it reads this data from some other source - just from where and how to change it???''' PS: when I lock the "xulstore.json" file in v.119 and accidentally resize the window right after a new start, the window size is loaded from "xulstore.json" for a few moments, but then it changes to the size I exited Firefox with - and I do not want that. It's getting on my nerves :/ ''' Well thank you.'''

All Replies (2)

more options

Does it still happen with all your extensions disabled?

Go to about:config and make sure privacy.resistFingerprinting.enabled is set to false.

Helpful?

more options

Hi zeroknight,

yes i tried with extensions disabled... no change

I also tried with a new profile... no change

I don't even have the "privacy.resistFingerprinting.enabled" value in about:config. And even if I add it manually and change it to "false" it is still unchanged. I only need to move or change the size of the window and it will start in the same size the next time Firefox is started.

thank you

Helpful?

Tanya soalan

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.