Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Window is too "big," obscures toolbar

  • 6 replies
  • 3 have this problem
  • 1 view
  • Last reply by cor-el

more options

I can only see the top edge of my Googlebar Lite toolbar. The problem is not limited to that one. Whatever toolbar should be immediately above the window is obscured BY the window, and unusable.

All Replies (6)

more options

If you mean the Firefox window is too large, mouse to the edge of the window. When the pointer becomes an arrow, move it slowly into the window to make it smaller. If you can't reach the window edge;

==============================

Occasionally the Firefox window will get off screen. Here are three different approaches to getting that window into view. One of them should work!

Firefox Window "off screen" — Arrow Key Method

If you know that Firefox is off to a particular side, you can use the arrow keys to move it back on screen. You only need to move it far enough to be able to click the title bar and then you can drag it the rest of the way.

Make the Firefox tile active on the task bar and press this key combination to start moving the window:

Alt+Spacebar > m

(To clarify, that's Alt+Spacebar to open the window control menu, then the letter m to start moving the window.)

Press the arrow key for the direction you want to move the window, e.g., press the left arrow key to move the window left. Press the Enter key to complete the move.

Firefox Window "off screen" — Maximize + New Window Script Method

If Firefox is nowhere to be found but you know it's out there, try this method. Make the Firefox tile active on the task bar and press this key combination to maximize the window:

Alt+Spacebar > x

(To clarify, that's Alt+Spacebar to open the window control menu, then the letter x to maximize the window.)

If that works, try this:

(1) Copy the following line of code to the clipboard (it's all one line...):

newwin=window.open(window.location.href, "_blank",
"width=640,height=480,menubar,toolbar,personalbar");
newwin.moveTo(0,0);

(2) In the maximized window, press Ctrl+Shift+k to open the web console.

(3) Press Ctrl+v to paste the line of code next to the caret (») then press Enter to run it. A new copy of that page should open in a window positioned at the top left of the screen.

(4) Switch back to the maximized window and close it first, before doing anything in the new window.

Firefox Window "off screen" — Remove Settings File

If you can't move or maximize Firefox, you can rename or delete the settings file that stores the last window position.

(1) Open your currently active Firefox settings folder (AKA Firefox profile folder). From the Start menu (Run box or search box), paste this into the search box and press Enter:

%APPDATA%\Mozilla\Firefox\Profiles

This should open a window showing one or more Firefox profile folders. If you have multiple folders, look for the most recent. Click into your profile folder.

(2) If Firefox is still running, right-click it on the Task Bar and Close all Windows.

(3) Wait a few moments for Firefox to finish updating files in your profile folder, then rename localstore.rdf to something else, like localstore-bad.rdf or localstore.old. Alternately, you can delete the file.

(4) You're done with your profile folder and you can restart Firefox now.

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

Here is a screenshot showing the problem. It seems to come and go randomly. Note that the Googlebar Lite toolbar is barely visible above the portion of FF29 displaying the Web page. The Firefox window is "maximized."

more options

I found that after Firefox v29, a LOT of my settings and
add-ons were changed / reset. Try this; Start Firefox in Safe Mode
While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration.
Then check ALL of your settings. Browser and add-ons. Then restart.

more options

Thanks, but that really didn't help. My toolbars don't appear when FF is in Safe Mode, and the whole problem is that one of my toolbars is being obscured. Obviously anything that disables the toolbars totally isn't going to reveal whether the problem is fixed.

more options

You have a lot of extensions installed, so it is quite possible that some are interfering and causing this issue.

Try to create a new profile to see if you can find the problem in the current profile.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem