Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to turn off the "untrusted connection" thing?

  • 49 replies
  • 204 have this problem
  • Last reply by John99

more options

This "Untrusted Connection" thing is god-damned annoying. Websites that I've been using for YEARS... all of a sudden are "untrusted." I don't ***-**** care. How do I turn this feature off?

moderator edited out offensive language

Modified by the-edmeister

All Replies (20)

more options

Well the most important thing to do is to first update to Firefox 19. Update Firefox to the latest release

Then, check the date/ time of your computer, Reset Firefox Refresh Firefox - reset add-ons and settings and let us know what happens!

more options

Thanks for your input Tyler. But, I don't want additional FireFox "changes" or "updates." I want to know how to turn this CRAP "off."

more options

Well, then unfortunately I can't help you. You need to update to Firefox 19 as it has dozens of security fixes and bug fixes, and we can only really help you when you use a version of Firefox we support. Staying with an old version of Firefox is quite unwise.

more options

The fact that you REFUSE to support previous versions... tells me volumes about the Mozilla "project"... and NOT in a "good" way.

Your v19 -does- seem to 'remember' what I have added as 'exceptions'. However, I will withhold my 'approval' until I have used the v19 for several days.

This statement does NOT IN ANY WAY condone YOUR arrogant attitude expressed previously... "that you don't support previous releases of FireFox."

(Language removed by mod)

Modified by user633449

more options

First, please refrain from using language or being abusive in the forums or you will be banned.

Firefox 10 is not supported, because it was replaced by Firefox 11, which was replaced by Firefox 12, and so on. The only supported version is the most recent version of Firefox, which right now is Firefox 19. Old versions of Firefox are insecure, and out of date, using them is not recommended and we don't support them anymore.

more options

Which security software (firewall, anti-virus) do you have?

Some security software intercept secure connections and send their own certificate.

Some examples are ESET and Bitdefender.

  • ESET setup -> advanced setup -> extend web and email tree -> SSL
  • SSL protocol: Do not scan SSL protocol
  • BitDefender -> Privacy settings -> disable Scan SSL
more options

First, I don't appreciate Tyler's condescending attitude. If he doesn't like my frustration vented, then FIX THE PROBLEM.

Second, I have "updated" to v19, which -seems- to have alleviated some of the problems to a degree. But, when I "add exception" for a website that I've been using for... oh... 10 years or more... I expect that site to be added... NOT... have to "add exception" a second... or third... or fourth time... OR FIFTH TIME... ad nauseum... I expect it to be added... the FIRST TIME... that I indicate for that site to be added to the exception list.

Tyler doesn't "like" my "abusive language"... pffffff... answer my questions with something functional, then we'll get somewhere.

I have no idea what "ESET" and "bitdefender" are.

I understand that MOZILLA is "freeware." Please understand, I -GREATLY- appreciate your (and the community-at-large's) efforts. I truly HATE the Microsoft stranglehold on the computing industry. However in the last FOUR or FIVE months, I have been sorely disappointed with FireFox.

In my mind, "user-friendly" means "user-tweakable"... as in... "I-can-tell-the-software-to-do-what-I-want-it-to-do." Maybe I just need to learn to write my own software... COBOL-85 is a bit out-of-date.

more options

You can also check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

"ESET" and "Bitdefender" are examples of security software (firewall) that can be configured to monitor secure connections.

more options

Funny how you say that if we give you a "functional" answer you'll be nice, when updating to 19 at least put you in the right track. Regardless, the language you used (which I've since removed) does not belong on this forum. Working together and not being abusive is the best way to solve issues.

more options

v19 STILL... hasn't FIXED the issue. I shouldn't have to "Confirm Security Exception" 2, 3, 4, or 10 times. Pull your head out of that very-dark-place, Tyler... and give me a FUNCTIONAL FIX.

more options

That link didn't provide any insights related to the problems I am experiencing.

more options

Some security software intercept secure connections and send their own certificate.

Check out why the site is untrusted (see the Technical details) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

more options

Ok... I've read over this arguing back and forth (didn't get anything out of that but whatever) I too can not get my firefox to stop this connection issue! I have checked the time/date, that is not at all the issue. I don't know how to access this eset or bitdefender thing, can someone please try to help me before I go crazy. I need firefox for college, but EVERY SINGLE time I try to get on any website AT ALL it says this no matter if i've accepted the connection 5-10 times, and I am currently using version 19, and I have not had this problem until I started using this version which I just updated last weekend.

more options

Did you try to retrieve the certificate like I posted above?

If security software is involved then the issuer of the certificate will be that security software.

What do the Technical Details on that SSL error page say?

more options

I didn't have the problem until I upgraded to FF v14 or v15 a few months ago, when I was FORCED to "upgrade." I had been using, I think, v4.(something,) because several 'games' on Facebook worked better with the older version. (I can hear the groans.) Here's a portion of the pop-up-window message I get:

!! You are about to override how Firefox identifies this site. !! Legitimate banks, stores, and other public sites will not ask you to do this.


Certificate Status This site attempts to identify itself with invalid information.

Unknown identity Certificate is not trusted, because it hasn't been verified by a recognized authority using a secure signature.

Certificate / General Could not very this certificate for unknown reasons.

Here's the certificate (partial) ---------------------------------

-Issued to- Common name: Organization: (blank) Organizational unit: go to Serial Number 6A:62:F2:CF:4C:5E:52:E1:74:F6:A5:EC:0D:99:20:35

-Issue by- Name Thawte DV SSL CA organization Thawte, Inc Org Unit Domain Validated SSL

-Validity- Issued on 10/22/2012 Expires on 10/23/2013 (I left off the "Fingerprints" data strings)

END -----------------------------------------------

-- ?? Any ideas ?? --

more options

Trying to 'troubleshoot' in days past, I had turned ThreatFire 'off'. Went further tonight and "uninstalled" ThreatFire. Restarted. And get the same "OMG ! Don't use this site ! It's BAD !" message.

I have re-installed ThreatFire.

more options

Reading back through this string...

I don't receive a "Secure Connection Failed" message.

My Zitomedia email log-in page is the only time I get "Untrusted Connection."

more options

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

more options

1) Closed FF, Deleted "Cert8", no fix. 2) Closed FF, Renamed to "Secmod.old", no fix. 3) Closed FF, Deleted "Secmod" and "Secmod.old", no fix. 3) The Clock is set to "sync with Internet Time Server"

Poked around on the 'link' for "Secure Connection Failed", it does not address either of these conditions: 1) Certificate Status This site attempts to identify itself with invalid information. 2)Unknown identity Certificate is not trusted, because it hasn't been verified by a recognized authority using a secure signature.

I called the ISP. No, they haven't received complaints of this issue. The tech I spoke with uses FF v19. He gets into his Zito mail with no error/ warning messages.

Since this problem seems to be specific to me: ...traceroute <enter> ...yielded an unknown IP:, then hit the Zito server(s.) I'm not finding who "owns" that IP, yet.

more options

(correction to my last) My queries haven't found who "owns" that IP, yet.

  1. 1
  2. 2
  3. 3