Fehlerbehebung bei Plugins wie Flash oder Java, um verbreitete Probleme mit Firefox zu lösen

(Weitergeleitet von Fehlerbehebung bei Plugins)

Wenn Sie Probleme mit dem Anzeigen von Inhalten auf Seiten haben, die Plugins wie Flash, Java oder andere verwenden, sollten Sie überprüfen, ob eines davon dieses Problem verursacht.

Häufige Probleme, die von Plugins verursacht werden:

Dieser Artikel beschreibt, wie Sie fehlerhafte Plugins finden können. Falls Sie Probleme mit Erweiterungen oder "Themes" haben, lesen Sie den Artikel Fehlerbehebung bei Erweiterungen, Themes und Hardware-Beschleunigung. Allgemeine Informationen zu Plugins finden Sie im Artikel Plugins mit Firefox verwenden.

Überprüfen, ob ein Plugin das Problem verursacht

Sie können gezielt einzelne Plugins deaktivieren, während Firefox läuft. Wenn Sie ein Plugin verdächtigen, das Problem hervorzurufen, deaktivieren Sie es zuerst und testen die Seite dann erneut. Wenn Sie nicht sicher sind, welches Plugin Sie deaktivieren sollen, gehen Sie folgendermaßen vor:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Die Add-ons-Verwaltung wird sich öffnen.

    Windows: Australis - Add-ons öffnen Add-ons-Manager öffnen - fx29 - Win8 Linux: Australis - Add-ons öffnen

  2. Gehen Sie im Tab mit der Add-ons-Verwaltung zum Abschnitt Plugins.
  3. Wählen Sie ein Plugin in der Liste aus und klicken Sie dann auf die Schaltfläche Deaktivieren. Wiederholen Sie diesen Schritt für jedes Plugin in der Liste. Sie müssen Firefox nicht neu starten, damit Ihre Änderungen wirksam werden.
  4. Prüfen Sie, ob Ihr Problem weiterhin besteht. Wenn es nicht mehr vorhanden ist, gehen Sie zum Add-ons-Manager zurück und aktivieren Sie ein Plugin nach dem anderen mit der Schaltfläche Aktivieren und überprüfen Sie nach jedem einzelnen, ob das Problem wieder auftritt. Tun Sie das, bis Sie das Plugin gefunden (aktiviert) haben, bei dem das Problem wieder auftritt.
  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Die Add-ons-Verwaltung wird sich öffnen.

    Windows: Australis - Add-ons öffnen Add-ons-Manager öffnen - fx29 - Win8 Linux: Australis - Add-ons öffnen

  2. Gehen Sie im Tab mit der Add-ons-Verwaltung zum Abschnitt Plugins.
  3. Wählen Sie bei allen Plugins in der Liste aus dem Auswahlmenü Niemals aktivieren. Sie müssen Firefox nicht neu starten, damit Ihre Änderungen wirksam werden.
  4. Prüfen Sie, ob Ihr Problem weiterhin besteht. Wenn nicht, gehen Sie zum Add-ons-Manager zurück und aktivieren Sie ein Plugin nach dem anderen wieder über die Auswahl Immer aktivieren und überprüfen nach jedem einzelnen, ob das Problem wieder auftritt. Tun Sie das, bis Sie das Plugin gefunden (aktiviert) haben, bei dem das Problem wieder auftritt.

Wenn Sie feststellen, dass das Deaktivieren eines Plugins Ihr Problem löst, fahren Sie mit den weiteren Schritten in diesem Artikel fort.

Plugins aktualisieren oder neu installieren

Viele Probleme mit Plugins können behoben werden, indem Sie auf die letzte Version des Plugins wechseln. Um zu überprüfen, ob irgendeines Ihrer installierten Plugins veraltet ist, besuchen Sie bitte Mozillas Plugin-Testseite.

Wenn die Aktualisierung auf die neueste Version des Plugins oder dessen Neuinstallation nicht hilft, lassen Sie das Plugin deaktiviert oder deinstallieren Sie es.

Plugin händisch deinstallieren

Wenn Sie kein Deinstallationsprogramm verwenden können, um ein Plugin zu entfernen, tun Sie es händisch:

  1. Tippen Sie in die Adressleiste about:config und drücken Sie die EingabetasteReturn.

    • Die Warnung „Hier endet möglicherweise die Gewährleistung!“ erscheint beim Aufruf von about:config. Klicken Sie auf Ich werde vorsichtig sein, versprochen!, um fortzufahren.

      about_config_win_fx4 about:config - Linux - Fx18 about_config_mac_fx4

      about:config - Fx29 - Linux about:config - Fx29 - Mac about:config - Fx29 - Win8
  2. Suchen Sie im Feld Filter nach der Einstellung plugin.expose_full_path.
  3. Klicken Sie mit der Maus doppelt auf die Einstellung plugin.expose_full_path in der Liste, um den Wert auf true zu ändern. (Damit wird der volle Dateipfad zum Plugin auf der Seite about:plugins angezeigt anstatt nur dessen Dateiname.)
  4. Geben Sie about:plugins in die Intelligente Addressleiste ein und drücken Sie die EingabetasteReturn um die Seite Installierte Plugins anzuzeigen.
  5. Jeder Eintrag auf der Seite "Installierte Plugins" beinhaltet die Zeile "Dateiname:" gefolgt von einem Dateipfad. Gehen Sie mit dem Windows Explorermit Ihrem Dateimanager zu dem Verzeichnis, das diese Datei beinhaltet.
  6. Ändern Sie den Namen der Datei, damit sie nicht mehr gefunden werden kann – z.B. npswf32 ändern zu Xnpswf32
  7. Klicken Sie in der Liste auf der Seite about:config doppelt mit der Maustaste auf die Einstellung plugin.expose_full_path, um den Wert auf false zu ändern und den vollen Plugin-Pfad zu Webseiten abzuschalten.

Das Plugin wird nach der Namensänderung von Firefox nicht mehr verwendet.

Wenn Sie kein Deinstallationsprogramm verwenden können, um ein Plugin zu entfernen, tun Sie es händisch:

  1. Geben Sie about:plugins in die Intelligente Addressleiste und drücken Sie die EingabetasteReturn um die Seite Installierte Plugins anzuzeigen.
  2. Jeder Eintrag auf der Seite "Installierte Plugins" beinhaltet die Zeile "Dateiname:" gefolgt von einem Dateipfad. Gehen Sie mit dem Windows Explorermit Ihrem Dateimanager zu dem Verzeichnis, das diese Datei beinhaltet.
  3. Ändern Sie den Namen der Datei, damit sie nicht mehr gefunden werden kann – z.B. npswf32 ändern zu Xnpswf32

Das Plugin wird nach der Namensänderung von Firefox nicht mehr verwendet.

Wenn Sie kein Deinstallationsprogramm verwenden können, um ein Plugin zu entfernen, tun Sie es händisch:

  1. Geben Sie about:plugins in die Intelligente Addressleiste und drücken Sie die EingabetasteReturn um die Seite Installierte Plugins anzuzeigen.
  2. Jeder Eintrag auf der Seite "Installierte Plugins" beinhaltet die Zeilen "Datei:" und "Pfad:" und dahinter jeweils den Namen und den Pfad zu dem Speicherort des Plugins, das Sie entfernen möchten. Gehen Sie mit dem Windows Explorermit Ihrem Dateimanager zu dem Verzeichnis, das diese Datei beinhaltet.
  3. Ändern Sie den Namen der Datei, damit sie nicht mehr gefunden werden kann – z.B. npswf32 ändern zu Xnpswf32

Das Plugin wird nach der Namensänderung von Firefox nicht mehr verwendet.

Die Plugin-Datenbank reinitialisieren

In manchen Fällen können Sie ein Plugin nicht deinstallieren oder wieder installieren. Die Reinitialisierung der Plugin-Datenbank behebt möglicherweise dieses Problem:

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8

    Profilordner öffnen - Fx29 - Linux

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Löschen Sie die Datei pluginreg.dat.
  5. Öffnen Sie Firefox.
  6. Tippen Sie in die Adressleiste about:plugins und drücken Sie die EingabetasteReturn, um die Liste der installierten Plugins in Firefox anzuzeigen.



Teile diesen Artikel: http://mzl.la/NYtGci

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel, gk0moz. Auch Sie können helfen – erfahren Sie, wie.