Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

video in firefox

  • 13 svar
  • 1 har dette problem
  • 35 visninger
  • Seneste svar af jim

more options

I go to yahoo.com and look at articles on that web site. When I click on the article I see a grey box with no content. I have turned off hardware acceleration. I have no add ons except roboform which I use for storing passwords. I have removed all cookies and temp files using CCleaner. Yahoo.com works with no alterations in Chrome and Edge. I like Firefox but do not understand why default settings do not work with Yahoo.com. I am using version 95.0 64bit on a Win 11 machine.

I go to yahoo.com and look at articles on that web site. When I click on the article I see a grey box with no content. I have turned off hardware acceleration. I have no add ons except roboform which I use for storing passwords. I have removed all cookies and temp files using CCleaner. Yahoo.com works with no alterations in Chrome and Edge. I like Firefox but do not understand why default settings do not work with Yahoo.com. I am using version 95.0 64bit on a Win 11 machine.

Valgt løsning

I analyzed the Yahoo news situation in another thread three weeks ago:

(A) Diagnosis

Yahoo uses "lazy loading" for some images where an image is loaded completely transparent (opacity: 0) and then a script reveals the image. It isn't working correctly in Firefox, so you just see the placeholder meant to display temporarily while the image is loading.

You can't reproduce the problem using a direct link like this:

https://news.yahoo.com/children-vaccination-christmas-124521435.html

The problem only occurs when you are loading new stories from another Yahoo News! page in the same tab. For example, you can start on the following page and click a link to a Yahoo News! story and after one or two you should find the problem:

https://news.yahoo.com/originals/

You can see the leftover rule to hide the image in the attached screenshot (from Firefox's Page Inspector panel).

Reloading the story (clicking the Reload button on the toolbar or Ctrl+r) triggers the script to work correctly so after reload, you can see the image. Another workaround is to open all the story links in a new tab instead of staying in the same tab.

Whatever the root cause, it will need to be fixed by Yahoo or reported as a bug related to Yahoo's script by someone who can tease out why the script fails to run (correctly) in Firefox .

(B) Workaround

You can override the inappropriate transparency by applying a custom style rule to Yahoo News pages. The simplest way to set that up is using the Stylus extension. However, if you already have a userContent.css file, see #5 below for the code.

(1) Install the Stylus extension from https://addons.mozilla.org/firefox/addon/styl-us/ (when the installation confirmation appears, check the box to allow it to run in private windows if you read Yahoo News in private windows)

(2) While viewing a news story with this problem, click the extension's "S" button on the toolbar, and then hover your mouse over "news". Once the confirmation tooltip appears that this will apply to all pages on news.yahoo.com, click. (Second attached screenshot.)

(3) If you like, edit the name of the style (by default, news.yahoo.com)

(4) Click in the editor box and paste this code (Third attached screenshot):

/*** Force visibility of hidden "lazy load" image on Yahoo News ***/
     /* Override opacity: 0 */
.caas-img-container.caas-img-loader .caas-img {
  opacity: 1 !important;
}
     /* Suppress gradient haze */
.caas-img-container.caas-img-loader::after {
  display: none !important;
}


(5) Click the Save button, then switch back to your problem tab to see whether it worked. Assuming it worked, this is now going to be done automatically and you can close the Stylus tab. (Fourth attached screenshot.)

Success?

Note: This kind of site modification is subject to future failure when Yahoo changes how it does things...

Læs dette svar i sammenhæng 👍 2

Alle svar (13)

more options

Can post a full browser screenshot like mine showing the issue. Have you tried the same steps in Safe Mode? What security software are you running?

more options

jim said

I have removed all cookies and temp files using CCleaner.

We do not recommend using other programs to clean Firefox because they could corrupt the files. Also, the browser can clean itself.


Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

This is what I see.

more options

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Did you ever try Safe Mode like the guys mentioned before?

more options

I am now on a different computer using Win 11 Pro. I started firefox in troubleshoot mode and had the same results. I am getting a gray embedded picture or video and cannot see the content. I start chrome and have no problems seeing all the content. Just to be clear, I have two web pages on startup for firefox. One is google and the other is yahoo Seems strange that on two computers I experience the same situation. When I click on an article in yahoo, the first picture shows up fine but when I scroll down the same article is when I see the grey box instead of a picture or video.

more options

I do not understand why three other browsers (Opera, Chrome, Edge) do not have problems viewing content on the Yahoo.com web site and Firefox does, at least for me. I install and use the other three browsers with no settings except the default settings. I appreciate the replies to my question. Is it possible there is a bug in Firefox? How do I convey that information to the development team?

more options

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

more options

Firefox is more secure than other browsers meaning it is less forgiving. One example is with website certificates.

more options

Valgt løsning

I analyzed the Yahoo news situation in another thread three weeks ago:

(A) Diagnosis

Yahoo uses "lazy loading" for some images where an image is loaded completely transparent (opacity: 0) and then a script reveals the image. It isn't working correctly in Firefox, so you just see the placeholder meant to display temporarily while the image is loading.

You can't reproduce the problem using a direct link like this:

https://news.yahoo.com/children-vaccination-christmas-124521435.html

The problem only occurs when you are loading new stories from another Yahoo News! page in the same tab. For example, you can start on the following page and click a link to a Yahoo News! story and after one or two you should find the problem:

https://news.yahoo.com/originals/

You can see the leftover rule to hide the image in the attached screenshot (from Firefox's Page Inspector panel).

Reloading the story (clicking the Reload button on the toolbar or Ctrl+r) triggers the script to work correctly so after reload, you can see the image. Another workaround is to open all the story links in a new tab instead of staying in the same tab.

Whatever the root cause, it will need to be fixed by Yahoo or reported as a bug related to Yahoo's script by someone who can tease out why the script fails to run (correctly) in Firefox .

(B) Workaround

You can override the inappropriate transparency by applying a custom style rule to Yahoo News pages. The simplest way to set that up is using the Stylus extension. However, if you already have a userContent.css file, see #5 below for the code.

(1) Install the Stylus extension from https://addons.mozilla.org/firefox/addon/styl-us/ (when the installation confirmation appears, check the box to allow it to run in private windows if you read Yahoo News in private windows)

(2) While viewing a news story with this problem, click the extension's "S" button on the toolbar, and then hover your mouse over "news". Once the confirmation tooltip appears that this will apply to all pages on news.yahoo.com, click. (Second attached screenshot.)

(3) If you like, edit the name of the style (by default, news.yahoo.com)

(4) Click in the editor box and paste this code (Third attached screenshot):

/*** Force visibility of hidden "lazy load" image on Yahoo News ***/
     /* Override opacity: 0 */
.caas-img-container.caas-img-loader .caas-img {
  opacity: 1 !important;
}
     /* Suppress gradient haze */
.caas-img-container.caas-img-loader::after {
  display: none !important;
}


(5) Click the Save button, then switch back to your problem tab to see whether it worked. Assuming it worked, this is now going to be done automatically and you can close the Stylus tab. (Fourth attached screenshot.)

Success?

Note: This kind of site modification is subject to future failure when Yahoo changes how it does things...

more options

jscher2000, You are the first person that at least said there was a problem on that web site (Yahoo.com) Whether it is Yahoo that needs to provide the solution seems to not be the main concern. People who are not programmers and want to see content on yahoo should not have to write scripts to see that content in Firefox. Why can't the Firefox development team bring this issue to Yahoo? Until it is resolved, why can't the development team create the script and put it in Firefox? Why can't there be an add on that specifically corrects the problem and people who want to use it can put it in the proper folder so we don't suffer or use other browsers. By the way, there should be a specific CSS add on script to see color in the bookmark folder that were removed many Firefox versions ago.

more options

Hi jim, I gave you a click click copy paste workaround. I'm not going to create an add-on for this.

As for possible changes to Firefox, those take a long time and there are many high priorities. Someone can file a bug for this, but I wouldn't expect a fix in 2021.

more options

jscher2000, Thank you for all your help. The stylus worked I also found your notes on creating a CSS file for bookmark colors.

You have been very helpful. Merry Christmas and Happy new year.