Java, Silverlight, Adobe Acrobat og andre plugins virker ikke mere

Fra og med Firefox version 52, udgivet 7. marts 2017, understøttes installerede NPAPI-plugins ikke længere i Firefox, undtagen Adobe Flash. Plugins som fx Java, Microsoft Silverlight og Adobe Acrobat vil ikke længere blive indlæst i Firefox, selvom de er installeret på din computer. Læs mere i denne artikel.

I løbet af de senere år har Firefox indført forskellige web-API'er, som websteder kan bruge i stedet for at skulle bruge plugins, så du vil muligvis slet ikke bemærke ændringen.

Hvorfor stopper understøttelsen af NPAPI-plugins?

Internettet er fyldt med websteder med aktivt indhold, fx video, lyd og spil. I starten understøttede browsere som Firefox ikke den slags indhold, så for at kunne se eller høre det, skulle man installere et plugin. Men plugins gør browseren langsommere, mindre sikker og mindre stabil. Google Chrome og Microsoft Edge gik for nogen tid siden væk fra brugen af plugins, og nu følger Firefox efter.

I løbet af de seneste år, har vi arbejdet hårdt på at udskifte plugins med web-API'er. De giver mulighed for de samme funktioner som plugins, men uden at underminere browserens ydelse, sikkerhed og stabilitet.

I en periode, hvor vi finpudsede de nye web-API'er, ændrede vi, så du skulle klikke for at aktivere et plugin.

I dag er web-API'erne klar, og vi stopper understøttelsen af plugins, undtagen Adobe Flash.

// Disse udmærkede personer hjalp med at skrive denne artikel:Joergen, Kim Ludvigsen. Du kan også hjælpe - find ud af hvordan.

Hjalp denne artikel? Vent venligst...

Bliv frivillig hos Mozilla Support