Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I disable auto resizing tabs?

  • 4 replies
  • 1 has this problem
  • 231 views
  • Last reply by marjar

more options

Hi,

I love Firefox, but the one behavior that drives me crazy is auto resizing tabs. I would like to pick one size for tabs, and have the browser stick to that size for all tabs.

Ideally, I would like to accomplish this without installing any extensions to the browser. Can anybody assist?

FYI, I'm using the latest version of Firefox (27.0.1) on a Mac, running the latest Mavericks (10.9.2). I tend to keep everything up to date.

Chosen solution

Never mind, I figured it out. If anybody else is wondering:

  • In your URL bar, type "about:config" without the quotes.
  • In the "search" bar field up top, type "tabs".
  • Look for "browser.tabs.animate". By default, the value is set to "true". Double click on it, which should set the value to "false".

The "false" value should fix the (insanely annoying) tab auto resizing. You can now continue to use Firefox and enjoy tabs without continued frustration.

[relevant image attached]

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Never mind, I figured it out. If anybody else is wondering:

  • In your URL bar, type "about:config" without the quotes.
  • In the "search" bar field up top, type "tabs".
  • Look for "browser.tabs.animate". By default, the value is set to "true". Double click on it, which should set the value to "false".

The "false" value should fix the (insanely annoying) tab auto resizing. You can now continue to use Firefox and enjoy tabs without continued frustration.

[relevant image attached]

more options

Hi thebonafortuna,

understand the frustration but currently can not think of an easy non-addon based idea how to resolve this: custom-tab-width

more options

Thanks. I was less concerned with setting my own custom width, and more concerned with disabling the dynamic resizing of tabs.

Fortunately, I was able to successfully solve that frustration with the above solution. It's like night and day: a far more enjoyable browsing experience.

Also, oddly enough, the browser seems to be running perceptibly snappier since disabling animating tabs. I encourage others to try and see if they notice the same.

more options

ok, I was reading it wrong... I have tried to turn off the tab animations in profile as well and tend to like it :D

Thanks for sharing