Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable New Translation tool

more options

I updated to the latest version of firefox and am not pleased with the translation tool automatically detecting the wrong language on sites. Is there any way to fully disable it? I currently have no languages installed yet it pops up offering to "translate".

I updated to the latest version of firefox and am not pleased with the translation tool automatically detecting the wrong language on sites. Is there any way to fully disable it? I currently have no languages installed yet it pops up offering to "translate".

Isisombululo esikhethiwe

There are a couple of hidden settings you could look at:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.translations and pause while the list is filtered

To allow Firefox to display the Translation button in the address bar, but turn off the drop-down panel:

(3) Double-click the browser.translations.automaticallyPopup preference to switch the value from true to false -- this will allow you to experiment with the feature when it could be useful, and watch its evolution

To completely disable the translation feature (for example, if you have an add-on you prefer):

(4) Double-click the browser.translations.enabled preference to switch the value from true to false

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 4

All Replies (1)

more options

Isisombululo Esikhethiwe

There are a couple of hidden settings you could look at:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.translations and pause while the list is filtered

To allow Firefox to display the Translation button in the address bar, but turn off the drop-down panel:

(3) Double-click the browser.translations.automaticallyPopup preference to switch the value from true to false -- this will allow you to experiment with the feature when it could be useful, and watch its evolution

To completely disable the translation feature (for example, if you have an add-on you prefer):

(4) Double-click the browser.translations.enabled preference to switch the value from true to false

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.