X
Tap here to go to the mobile version of the site.

Support Forum

removed add-on and firefox is affected

Posted

I installed foxlingo as an add-on translation tool. I have removed it and some sites are still being translated into another language. I've uninstalled and reinstalled firefox and still having issues

I installed foxlingo as an add-on translation tool. I have removed it and some sites are still being translated into another language. I've uninstalled and reinstalled firefox and still having issues
jscher2000
  • Top 10 Contributor
8696 solutions 71081 answers

Could you check your add-ons here and see whether Foxlingo left anything behind?

orange Firefox button or classic Tools menu > Add-ons

Try both the plugins and the extensions. Try disabling anything that's not essential, restart Firefox, and test again.


Does Foxlingo change any proxy settings? You could check here:

orange Firefox button or classic Tools menu > Options > Advanced > Network

Click the Settings button and try "No proxy" or "Use system proxy settings"

Could you check your add-ons here and see whether Foxlingo left anything behind? orange Firefox button ''or'' classic Tools menu > Add-ons Try both the plugins and the extensions. Try disabling anything that's not essential, restart Firefox, and test again. ---- Does Foxlingo change any proxy settings? You could check here: orange Firefox button ''or'' classic Tools menu > Options > Advanced > Network Click the Settings button and try "No proxy" or "Use system proxy settings"

Question owner

I've disabled anything extra and I only have firebug and measureit as my old add ons. Some pages still come up in another language.

I've disabled anything extra and I only have firebug and measureit as my old add ons. Some pages still come up in another language.
jscher2000
  • Top 10 Contributor
8696 solutions 71081 answers

A standard approach to cleansing site-specific files and settings is clearing your Firefox cache and deleting your saved cookies for the site.

1. Clear Firefox's Cache

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Offline Storage : "Clear Now"

2. If needed, delete the problem site's cookies here (this will log you out)

While viewing a page on the site, right-click and choose View Page Info > Security > "View Cookies"

Then reload the page. Any change?


Also, when you encounter a problem page, could you check Firebug's Net tab, look at your request headers and see whether the Accept-Language header specifies anything other than your preferred language, which I assume is en or en-US. If it lists other languages, you could try to reset that preference using the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste lang and pause while the list is filtered

(3) Right-click intl.accept_languages and choose Reset.

I can't think of any other settings that could be causing this issue.

A standard approach to cleansing site-specific files and settings is clearing your Firefox cache and deleting your saved cookies for the site. 1. Clear Firefox's Cache orange Firefox button ''or'' Tools menu > Options > Advanced On the Network mini-tab > Offline Storage : "Clear Now" 2. If needed, delete the problem site's cookies here (this will log you out) While viewing a page on the site, right-click and choose View Page Info > Security > "View Cookies" Then reload the page. Any change? ---- Also, when you encounter a problem page, could you check Firebug's Net tab, look at your request headers and see whether the Accept-Language header specifies anything other than your preferred language, which I assume is en or en-US. If it lists other languages, you could try to reset that preference using the about:config preferences editor. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''lang''' and pause while the list is filtered (3) Right-click '''intl.accept_languages''' and choose Reset. I can't think of any other settings that could be causing this issue.

Question owner

I've cleared the cache, cookies, and history and still have the issue. When I enable firebug and check the net tab; everything is in another language still. I checked the about:config and intl.accept_languages didn't allow me to reset but there was a ton of foxlingo files in there.

I've cleared the cache, cookies, and history and still have the issue. When I enable firebug and check the net tab; everything is in another language still. I checked the about:config and intl.accept_languages didn't allow me to reset but there was a ton of foxlingo files in there.
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

Which languages are installed in Firefox and in what order?

  • Tools > Options > Content > Languages
Which languages are installed in Firefox and in what order? *Tools > Options > Content > Languages

Question owner

English/United States [en-us] - 1st English [en] - 2nd

Those are the only two installed.

English/United States [en-us] - 1st English [en] - 2nd Those are the only two installed.
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

I can't think of a reason why pages should get translated unless there is still some component active of a translation extension.

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

I can't think of a reason why pages should get translated unless there is still some component active of a translation extension. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Started in safe mode. Still in another language.

Started in safe mode. Still in another language.
Chris Ilias
  • Moderator
354 solutions 1944 answers

We'll need some more info about your Firefox setup. Go to Help > Troubleshooting Information then click Copy all to Clipboard. Open a reply to this post, and go to Edit > Paste to paste the info from your Troubleshooting Information page.

We'll need some more info about your Firefox setup. Go to '''Help > Troubleshooting Information''' then click '''Copy all to Clipboard'''. Open a reply to this post, and go to '''Edit > Paste''' to paste the info from your Troubleshooting Information page.

Question owner

Application Basics

       Name
       Firefox
       Version
       13.0.1
       User Agent
       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
       Profile Folder
         Show Folder
       Enabled Plugins
         about:plugins
       Build Configuration
         about:buildconfig
       Crash Reports
         about:crashes
       Memory Use
         about:memory
 Extensions
       Name
       Version
       Enabled
       ID
       Firebug
       1.9.2
       true
       firebug@software.joehewitt.com
       MeasureIt
       0.4.10
       true
       {75CEEE46-9B64-46f8-94BF-54012DE155F0}
 Important Modified Preferences
     Name
     Value
       accessibility.typeaheadfind.flashBar
       0
       browser.cache.disk.capacity
       1048576
       browser.cache.disk.smart_size.first_run
       false
       browser.cache.disk.smart_size_cached_value
       1048576
       browser.places.smartBookmarksVersion
       3
       browser.startup.homepage_override.buildID
       20120614114901
       browser.startup.homepage_override.mstone
       13.0.1
       extensions.lastAppVersion
       13.0.1
       network.cookie.prefsMigrated
       true
       places.database.lastMaintenance
       1340605296
       places.history.expiration.transient_current_max_pages
       100641
       privacy.sanitize.migrateFx3Prefs
       true
       privacy.sanitize.timeSpan
       0
       security.warn_viewing_mixed
       false
 Graphics
       Adapter Description
       ATI Radeon 3100 Graphics
       Vendor ID
       0x1002
       Device ID
       0x9611
       Adapter RAM
       256
       Adapter Drivers
       atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
       Driver Version
       8.632.0.0
       Driver Date
       7-2-2009
       Direct2D Enabled
       Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
       DirectWrite Enabled
       false (6.1.7601.17789)
       ClearType Parameters
       ClearType parameters not found
       WebGL Renderer
       Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
       GPU Accelerated Windows
       0. Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
 JavaScript
       Incremental GC
       1
 Library Versions
       Expected minimum version
       Version in use
       NSPR
       4.9
       4.9
       NSS
       3.13.4.0 Basic ECC
       3.13.4.0 Basic ECC
       NSS Util
       3.13.4.0
       3.13.4.0
       NSS SSL
       3.13.4.0 Basic ECC
       3.13.4.0 Basic ECC
       NSS S/MIME
       3.13.4.0 Basic ECC
       3.13.4.0 Basic ECC
Application Basics Name Firefox Version 13.0.1 User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1 Profile Folder Show Folder Enabled Plugins about:plugins Build Configuration about:buildconfig Crash Reports about:crashes Memory Use about:memory Extensions Name Version Enabled ID Firebug 1.9.2 true firebug@software.joehewitt.com MeasureIt 0.4.10 true {75CEEE46-9B64-46f8-94BF-54012DE155F0} Important Modified Preferences Name Value accessibility.typeaheadfind.flashBar 0 browser.cache.disk.capacity 1048576 browser.cache.disk.smart_size.first_run false browser.cache.disk.smart_size_cached_value 1048576 browser.places.smartBookmarksVersion 3 browser.startup.homepage_override.buildID 20120614114901 browser.startup.homepage_override.mstone 13.0.1 extensions.lastAppVersion 13.0.1 network.cookie.prefsMigrated true places.database.lastMaintenance 1340605296 places.history.expiration.transient_current_max_pages 100641 privacy.sanitize.migrateFx3Prefs true privacy.sanitize.timeSpan 0 security.warn_viewing_mixed false Graphics Adapter Description ATI Radeon 3100 Graphics Vendor ID 0x1002 Device ID 0x9611 Adapter RAM 256 Adapter Drivers atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64 Driver Version 8.632.0.0 Driver Date 7-2-2009 Direct2D Enabled Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer. DirectWrite Enabled false (6.1.7601.17789) ClearType Parameters ClearType parameters not found WebGL Renderer Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer. GPU Accelerated Windows 0. Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer. JavaScript Incremental GC 1 Library Versions Expected minimum version Version in use NSPR 4.9 4.9 NSS 3.13.4.0 Basic ECC 3.13.4.0 Basic ECC NSS Util 3.13.4.0 3.13.4.0 NSS SSL 3.13.4.0 Basic ECC 3.13.4.0 Basic ECC NSS S/MIME 3.13.4.0 Basic ECC 3.13.4.0 Basic ECC
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

There is nothing unusual in that troubleshooting list.

You can try to reset Firefox.

Reset creates a new profile and tries to import some settings from the old profile leaving the old profile intact.

There is nothing unusual in that troubleshooting list. You can try to reset Firefox. *https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems Reset creates a new profile and tries to import some settings from the old profile leaving the old profile intact. *https://support.mozilla.org/kb/Recovering+important+data+from+an+old+profile

Modified by cor-el

Question owner

Yeah resetting it didn't work. I've removed the add-on, uninstalled, reinstalled, and still nothing. It's amazing what the heck is going on.

Yeah resetting it didn't work. I've removed the add-on, uninstalled, reinstalled, and still nothing. It's amazing what the heck is going on.
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

Are you being redirected to a page in a different locale or is the English page just translated to the other language?

What are the current connection settings?

Does it help if you change them to "No proxy"?

Are you being redirected to a page in a different locale or is the English page just translated to the other language? What are the current connection settings? Does it help if you change them to "No proxy"? *Tools > Options > Advanced : Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel

Question owner

It doesn't redirect. It translates either all or some of the pages. Changing the connection settings does not help. I attached a picture of what I meant by it changes some things on a page.

It doesn't redirect. It translates either all or some of the pages. Changing the connection settings does not help. I attached a picture of what I meant by it changes some things on a page.
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

Are you sure that this is a translation and not a font issue?

You can use this extension to see which fonts are used for selected text.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and disable website fonts as a test.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
Are you sure that this is a translation and not a font issue? You can use this extension to see which fonts are used for selected text. *fontinfo: https://addons.mozilla.org/firefox/addon/fontinfo/ You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 You can try different default fonts and disable website fonts as a test. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"

Question owner

Ok so I removed the check to allow pages to choose their own fonts and low and behold it worked. Problem is though that I didn't have this issue until I installed that foxlingo. So it's definitely a font fix but the translator cause the issue I believe. Any thoughts now?

Ok so I removed the check to allow pages to choose their own fonts and low and behold it worked. Problem is though that I didn't have this issue until I installed that foxlingo. So it's definitely a font fix but the translator cause the issue I believe. Any thoughts now?
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

Which font is Firefox using to display the faulty text if you use the above mentioned fontinfo extension?

Which font is Firefox using to display the faulty text if you use the above mentioned fontinfo extension?