Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

No audio on Twitch Streams.

  • 11 uphendule
  • 1 inale nkinga
  • 40 views
  • Igcine ukuphendulwa ngu liamlol222

more options

Hi there. I appear to have some kind of issue/bug with Twitch. For some reason, some streams, seemingly at random, do not play audio. Closing firefox and reopening sometimes fixes this, other times it doesnt. For example, if I am watching a stream, I then close firefox, and use "restore last session", there is no audio coming from the site. Other sites such as youtube work fine 100% of the time. Doing the same on other browsers such as Chrome do not have this issue. I have tried reloading the page and it seemingly works at random, I have tried clearing the cache.

Hi there. I appear to have some kind of issue/bug with Twitch. For some reason, some streams, seemingly at random, do not play audio. Closing firefox and reopening sometimes fixes this, other times it doesnt. For example, if I am watching a stream, I then close firefox, and use "restore last session", there is no audio coming from the site. Other sites such as youtube work fine 100% of the time. Doing the same on other browsers such as Chrome do not have this issue. I have tried reloading the page and it seemingly works at random, I have tried clearing the cache.

All Replies (11)

more options

Ok some more info. Upon closing and reopening, where there is no audio, it does not say "playing" on the tab itself. Changing the video quality settings also fixes this issue. I have no idea what is causing this.

more options

Is this a new issue? Does it still happen if you disable low latency mode in Twitch (Settings > Advanced > Low Latency)?

more options

zeroknight said

Is this a new issue? Does it still happen if you disable low latency mode in Twitch (Settings > Advanced > Low Latency)?

This does indeed appear to a new issue. I dont believe this happened before in my many years of using Firefox. And this does sort of solve the issue. If I open a stream, then close the browser and reopen using restore last session, the audio does indeed stay muted, with and without low latency. However, turning low latency off and on does restore the audio, much like changing the video quality does. If I had to maybe guess what the issue is, when watching a video for example, it says "PLAYING" in the tab at the top of the browser. When restoring, it does not say that for the stream, until changing quality or latency. And Im not sure if this is related, but turning the audio on and off for youtube videos and twitch streams causing minor frame drops.

more options

Does it still happen in Troubleshoot Mode?

more options

zeroknight said

Does it still happen in Troubleshoot Mode?

Yes, the problem still occurs in Troubleshoot mode.

more options

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

more options

zeroknight said

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Mostly not, no. After downloading Developer edition, the issue is more infrequent, but does still occur. However, developer edition does provide the "click to unmute" option, which normal firefox does not. But, developer edition does also just have random mutes where I am forced to change the quality or etc to hear sound again.

more options

Did you check for issues caused by your Avast Antivirus security software ?

more options

cor-el said

Did you check for issues caused by your Avast Antivirus security software ?

I assume by this, you mean that I should disable my Avast and see if the problem persists? Edit: After turning off the core shields it provides, the issue remains. As the picture shows, no sound is coming from the twitch tab at the top.

Okulungisiwe ngu liamlol222

more options

Disabling anti-virus might not be enough to stop it from interfering. Some more things to try:

  • Go to about:third-party and disable third-party modules.
  • Start in Windows Safe Mode.
  • Uninstall Avast temporarily and reboot the system.
more options

After going on to third party and disabling all avast modules that connect to Firefox, the issue persists. As the picture shows, no sound is coming from the twitch tab. And yes, it was unmuted, but still no sound.