Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I remove alternative languages from Firefox Language Settings?

  • 4 uphendule
  • 3 zinale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu cor-el

more options

I set my browser to use English instead of my local language and I expect sites to use English by default. Now for some reason Gmail showed me a "do you want to leave this page" browser dialogue in language other than English.

Turns out, there's a new(?) option to set alternative interface languages, and I suppose websites can now choose which one to use?

Wow, just noticed, even tooltips on this website aren't in English anymore. This is extremely annoying.

I'd love to remove the alternate language from that list and leave Firefox interface exclusively in English. There is no option to remove the second language, only to move priority (see screenshot).

Searching through about:config with "language" didn't help. The closest relevant result was for the dictionaries. I do not have problems with dictionaries; "alternate" did not bring any relevant results either.

I set my browser to use English instead of my local language and I expect sites to use English by default. Now for some reason Gmail showed me a "do you want to leave this page" browser dialogue in language other than English. Turns out, there's a new(?) option to set alternative interface languages, and I suppose websites can now choose which one to use? Wow, just noticed, even tooltips on this website aren't in English anymore. This is extremely annoying. I'd love to remove the alternate language from that list and leave Firefox interface exclusively in English. There is no option to remove the second language, only to move priority (see screenshot). Searching through about:config with "language" didn't help. The closest relevant result was for the dictionaries. I do not have problems with dictionaries; "alternate" did not bring any relevant results either.
Ama-screenshot ananyekiwe

All Replies (4)

more options

intl.locale.requested

Found the line in about:config I needed to modify. After deleting the extra language and restarting the browser everything seems to work as intended. Seems that the "Firefox Language Settings" is unaffected by my edit though

more options

You can't remove the default language of the Firefox locale you have installed, only languages you add can be removed.

The first language setting in Settings is about the language for the user interface. The second language setting is about the preferred languages for webpages.

If the Firefox user interface (toolbars) is in the wrong language or if you want to change the current/default language, download Firefox in the language of your choice.

more options

cor-el said

If the Firefox user interface (toolbars) is in the wrong language or if you want to change the current/default language, download Firefox in the language of your choice.

That was not the case. Only _some_ UI elements of Firefox were in a wrong language. This is an old installations and I never had any problems with languages, nor have I changed anything recently. This problem occurred after updating to 114. I've already said that the issue is fixed by removing extra language from intl.locale.requested in about:config

Okulungisiwe ngu Fly McFlyson

more options

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.