Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to load Google apps in Firefox

  • 9 uphendule
  • 2 zinale nkinga
  • 39 views
  • Igcine ukuphendulwa ngu etdavidoff

more options

Yesterday I started having trouble logging into Gmail and associated apps (calendar, contacts, docs, sheets, shared folders, etc., as well as google.com) in Firefox. All other sites are loading with no problems. Google apps are working fine in Chrome. Still having problems today.

My office uses Google Workplace for everything so this is really messing me up, I've lost several hours of work trying to get things to load. The IT person told me that if Firefox is having problems I should use Chrome instead. I hate Chrome! I want to use Firefox, but I can't get my work done if it won't load Google apps.

Please note that I have tried the following solutions thus far: restarted Firefox (several times) restarted computer removed add-ons cleared cached web content cleared cookies and site data refreshed Firefox solution at https://support.mozilla.org/en-US/questions/1200943 solution at https://support.mozilla.org/en-US/questions/1132284 solution at https://knowtechie.com/is-mozilla-firefox-not-loading-pages-for-you-heres-the-fix/

After each fix things start working for a while but then everything Gmail-related freezes or crashes and I need to start all over again. Help!!!

Yesterday I started having trouble logging into Gmail and associated apps (calendar, contacts, docs, sheets, shared folders, etc., as well as google.com) in Firefox. All other sites are loading with no problems. Google apps are working fine in Chrome. Still having problems today. My office uses Google Workplace for everything so this is really messing me up, I've lost several hours of work trying to get things to load. The IT person told me that if Firefox is having problems I should use Chrome instead. I hate Chrome! I want to use Firefox, but I can't get my work done if it won't load Google apps. '''Please note that I have tried the following solutions thus far:''' restarted Firefox (several times) restarted computer removed add-ons cleared cached web content cleared cookies and site data refreshed Firefox solution at https://support.mozilla.org/en-US/questions/1200943 solution at https://support.mozilla.org/en-US/questions/1132284 solution at https://knowtechie.com/is-mozilla-firefox-not-loading-pages-for-you-heres-the-fix/ After each fix things start working for a while but then everything Gmail-related freezes or crashes and I need to start all over again. Help!!!

Isisombululo esikhethiwe

etdavidoff said

Thanks so much for your response! Really appreciate knowing that it's not just me. I was contemplating reinstalling Firefox since that's the only thing I haven't tried yet. Did you try that? Please let me know if you find a solution, I'm sure you have a much better chance of figuring this out than I do!

I haven't re-installed Firefox, but I did ask a similar question and got a response. Check out the fifth post down from "jscher2000". From my preliminary testing setting the "security.tls.enable_0rtt_data" in "about:config" seems to be working just fine for right now. I'm going to see how Google sites respond to this setting be disabled throughout the day before marking it as having solved my issue.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (9)

more options

etdavidoff said

My office uses Google Workplace for everything so this is really messing me up, I've lost several hours of work trying to get things to load. The IT person told me that if Firefox is having problems I should use Chrome instead.

You should understand why your IT is saying what they are saying.

Helpful?

more options

Saying "don't use Firefox" is not a helpful solution.

Helpful?

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click the shield icon for more detail and possibly disable the protection. You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Okulungisiwe ngu cor-el

Helpful?

more options

Thanks very much for your response! Unfortunately I had already tried most of those, and the one which I hadn't tried yet (troubleshoot mode) just confirmed that there is a problem. Would welcome any other suggestions!

Helpful?

more options

etdavidoff said

Thanks very much for your response! Unfortunately I had already tried most of those, and the one which I hadn't tried yet (troubleshoot mode) just confirmed that there is a problem. Would welcome any other suggestions!

Just to let you know, you're not the only one with this issue. I'm the System admin at my company and I've been experiencing this for the past two to three weeks as has a few of our other users who also prefer Firefox over Chrome, even though we are a Google Workspace shop. I've also tried everything mentioned above, including this solution: https://superuser.com/questions/1280239/firefox-secure-connection-failed-ssl-error-bad-mac-alert

Helpful?

more options

Thanks so much for your response! Really appreciate knowing that it's not just me. I was contemplating reinstalling Firefox since that's the only thing I haven't tried yet. Did you try that?

Please let me know if you find a solution, I'm sure you have a much better chance of figuring this out than I do!

Helpful?

more options

Isisombululo Esikhethiwe

etdavidoff said

Thanks so much for your response! Really appreciate knowing that it's not just me. I was contemplating reinstalling Firefox since that's the only thing I haven't tried yet. Did you try that? Please let me know if you find a solution, I'm sure you have a much better chance of figuring this out than I do!

I haven't re-installed Firefox, but I did ask a similar question and got a response. Check out the fifth post down from "jscher2000". From my preliminary testing setting the "security.tls.enable_0rtt_data" in "about:config" seems to be working just fine for right now. I'm going to see how Google sites respond to this setting be disabled throughout the day before marking it as having solved my issue.

Okulungisiwe ngu cor-el

Helpful?

more options

This could be a problem with the Zero Round Trip Time Resumption (0rtt) feature. You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:

Helpful?

more options

scriptguru1701 and cor-el - Thank you both so much! It's working now! Yay! (I was getting so tired of being stuck using Chrome...)

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.