搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Stop Firefox making tabs go to sleep?

  • 6 回覆
  • 0 有這個問題
  • 29 次檢視
  • 最近回覆由 Terry

more options

Had Firefox 9x or so installed on my mac and then updated to 101. Now tabs go to sleep, unloads. So videos paused and the timer reset, webmail have to login again and again. If saving websites temporary in tabs now can change after article/sites get updated.

Setting "browser.tabs.unloadOnLowMemory" to false do not work. Tabs still go to sleep with the "ZZZZ". Have tried to restart Firefox and reboot computer.

Tried to install older version of Firefox but then it complain about compatibility with the old "settings files", so have to make a clean install then... Possible to force this? Change what version the "settings files" are so older version of firefox dont complain?

Had Firefox 9x or so installed on my mac and then updated to 101. Now tabs go to sleep, unloads. So videos paused and the timer reset, webmail have to login again and again. If saving websites temporary in tabs now can change after article/sites get updated. Setting "browser.tabs.unloadOnLowMemory" to false do not work. Tabs still go to sleep with the "ZZZZ". Have tried to restart Firefox and reboot computer. Tried to install older version of Firefox but then it complain about compatibility with the old "settings files", so have to make a clean install then... Possible to force this? Change what version the "settings files" are so older version of firefox dont complain?

所有回覆 (6)

more options

I don't know whether installing an older version will help your issue but there is this article.

https://support.mozilla.org/en-US/kb/install-older-version-firefox

more options

I found how do run older version of Firefox and keeping old User Profile.

Start it with this command in Terminal. Had to jump in to the .app file and then MacOS directory. There was the -bin file i ran with this command after. --allow-downgrade

After downgrading the tabs still went to sleep and wondered why. Looked in Addons and there was one I havnt installed called Auto Tab Discard. Disabled it and now tabs dont go to sleep.

Thanks for the help.

由 Hepp 於 修改

more options

Hi Hepp, What you're experiencing is not normal behaviour. I'm using Firefox 102.0.1 on macOS Monterey, and if I have a video running in one tab, switching to another tab does not pause the video. The fact that videos keep playing is why there is a speaker icon on any tab that is playing audio (so you know which tab the sound is coming from).

Using old versions of Firefox also poses a significant security risk.

Let's try refreshing Firefox. This will purge a lot of your Firefox files, while retaining most of your personal data. For instructions, check out the following article: Refresh Firefox - reset add-ons and settings

more options
more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Hepp said

After downgrading the tabs still went to sleep and wondered why. Looked in Addons and there was one I havnt installed called Auto Tab Discard. Disabled it and now tabs dont go to sleep.