X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

firefox 26.0 returns to the top of the page when using back button at ebay.com

Được đăng

Hi all,

When at eBay.com using FireFox 26.0, looking at a specific list, hitting the back button returns you the top of the previous page rather than correctly returning you to where you had to scrolled section of the previous page.

In other words, if looking at an item 1/2 way down the list of items and clicking on a an item to view that specific listing, hitting the back button returns you back to the top of the listings vs. returning you to where you were prior to clicking on the specific item 1/2 down the list of items. You then have to scroll down the list or rather, start your search of the page of listings again from the top rather than continuing your search where you left off.

Is there a quick fix? I have experienced this before on new Firefox releases but not recently.

Thanks...

Neil

Hi all, When at eBay.com using FireFox 26.0, looking at a specific list, hitting the back button returns you the top of the previous page rather than correctly returning you to where you had to scrolled section of the previous page. In other words, if looking at an item 1/2 way down the list of items and clicking on a an item to view that specific listing, hitting the back button returns you back to the top of the listings vs. returning you to where you were prior to clicking on the specific item 1/2 down the list of items. You then have to scroll down the list or rather, start your search of the page of listings again from the top rather than continuing your search where you left off. Is there a quick fix? I have experienced this before on new Firefox releases but not recently. Thanks... Neil

Giải pháp được chọn

A way to avoid this is to middle-click a link to open the link in a new tab and close the tab to return to the eBay search page.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 12.0 r0
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20913.0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • iTunes Detector Plug-in
  • NPWLPG

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8787 giải pháp 71865 câu trả lời
Được đăng

If you open a new tab and work with eBay in the new tab, do you have the same problem?

The reason I ask is a problem related to tabs you restored from a previous session. I could dig up that thread, but I don't recall there being a solution for that last time I looked.


I tested with this page: iPad Air. When I go "Back" I am returned to the correct place.

In case it matters, I am not logged in to eBay and hardly ever visit... to simulate my situation, try right-clicking the link > Open in a New Private Window. Any difference?

If you open a new tab and work with eBay in the new tab, do you have the same problem? The reason I ask is a problem related to tabs you restored from a previous session. I could dig up that thread, but I don't recall there being a solution for that last time I looked. ---- I tested with this page: [http://www.ebay.com/sch/iPads-Tablets-eBook-Readers-/171485/i.html?_dcat=171485&rt=nc&_pppn=r1&Product%2520Line=iPad%2520Air iPad Air]. When I go "Back" I am returned to the correct place. In case it matters, I am not logged in to eBay and hardly ever visit... to simulate my situation, try right-clicking the link > Open in a New Private Window. Any difference?

Người tạo câu hỏi

Yes, I have the same problem in a new tab.

Yes, I have the same problem in a new tab.
cor-el
  • Top 10 Contributor
  • Moderator
17570 giải pháp 158915 câu trả lời
Được đăng

Giải pháp được chọn

A way to avoid this is to middle-click a link to open the link in a new tab and close the tab to return to the eBay search page.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
A way to avoid this is to middle-click a link to open the link in a new tab and close the tab to return to the eBay search page. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Người tạo câu hỏi

I restored the default theme, restarted FF and all is good. I then reapplied my add on theme, restarted FF and all is still good. Maybe the upgrade to 26.0 while the add on theme was active corrupted something.

Thanks for the help everyone.

I restored the default theme, restarted FF and all is good. I then reapplied my add on theme, restarted FF and all is still good. Maybe the upgrade to 26.0 while the add on theme was active corrupted something. Thanks for the help everyone.

Người tạo câu hỏi

The problem is back after several days. Switched back to the default them and it made no difference.

The problem is back after several days. Switched back to the default them and it made no difference.
jscher2000
  • Top 10 Contributor
8787 giải pháp 71865 câu trả lời
Được đăng

In case there is a problem with accumulated data for the page, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

In case there is a problem with accumulated data for the page, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: orange Firefox button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help?

Người tạo câu hỏi

I have done everything you recommended above. It is strange but I discovered only have this problem on one specific item search. All other eBay item searches are fine.

I have done everything you recommended above. It is strange but I discovered only have this problem on one specific item search. All other eBay item searches are fine.
jscher2000
  • Top 10 Contributor
8787 giải pháp 71865 câu trả lời
Được đăng

That's interesting. Does the search term have spaces or apostrophes or other special characters in it? Not that I would have a workaround for that....

That's interesting. Does the search term have spaces or apostrophes or other special characters in it? Not that I would have a workaround for that....

Người tạo câu hỏi

The below search and others with northface are giving me problems.

northface mens xxl

Weird isn't it?

The below search and others with northface are giving me problems. northface mens xxl Weird isn't it?
whitewolftexas 0 giải pháp 8 câu trả lời
Được đăng

"middle-click a link to open the link in a new tab and close the tab to return to the eBay search page." I don't even know what "middle-click" means and there is no way to close the link once you get there with out closing eBay altogether and that would sort of defeat the purpose, so this solution will not work.

"middle-click a link to open the link in a new tab and close the tab to return to the eBay search page." I don't even know what "middle-click" means and there is no way to close the link once you get there with out closing eBay altogether and that would sort of defeat the purpose, so this solution will not work.
jscher2000
  • Top 10 Contributor
8787 giải pháp 71865 câu trả lời
Được đăng

Hi whitewolftexas, middle-click means to click the link using the wheel on your mouse. Alternately, to open a link in a new tab, you also can Ctrl+click or right-click > Open Link in New Tab.

Hi whitewolftexas, middle-click means to click the link using the wheel on your mouse. Alternately, to open a link in a new tab, you also can Ctrl+click or right-click > Open Link in New Tab.
cor-el
  • Top 10 Contributor
  • Moderator
17570 giải pháp 158915 câu trả lời
Được đăng

A middle-click means that you click a link with the mouse scroll wheel.
This is equivalent with holding down the Ctrl key and left-clicking the link.
This way you open the link in a new tab, so you keep the eBay or other website in their own tab and won't lose the scroll position and you can close the tab when you are finished with it to return to the tab with the eBay page.

A middle-click means that you click a link with the mouse scroll wheel.<br /> This is equivalent with holding down the Ctrl key and left-clicking the link.<br /> This way you open the link in a new tab, so you keep the eBay or other website in their own tab and won't lose the scroll position and you can close the tab when you are finished with it to return to the tab with the eBay page.
whitewolftexas 0 giải pháp 8 câu trả lời
Được đăng

My wheel want let me click but right clicking seems to work but why am I having to go to such links to see what I want to now?

My wheel want let me click but right clicking seems to work but why am I having to go to such links to see what I want to now?
jscher2000
  • Top 10 Contributor
8787 giải pháp 71865 câu trả lời
Được đăng

Hi whitewolftexas, the original problem in this thread was that when you visit a link and then go back, Firefox re-requests an updated page from eBay. Opening the links in a new tab gets around that by keeping the original page open while you check the individual items in other tabs.

Hi whitewolftexas, the original problem in this thread was that when you visit a link and then go back, Firefox re-requests an updated page from eBay. Opening the links in a new tab gets around that by keeping the original page open while you check the individual items in other tabs.
cor-el
  • Top 10 Contributor
  • Moderator
17570 giải pháp 158915 câu trả lời
Được đăng

Maybe continue the discussion with whitewolftexas in this thread: /questions/988596

Maybe continue the discussion with ''whitewolftexas'' in this thread: [/questions/988596]
whitewolftexas 0 giải pháp 8 câu trả lời
Được đăng

I do not want to do it that way. I just want to use the back button. I'm not using ver. 26, I'm using 27.0.1.

I do not want to do it that way. I just want to use the back button. I'm not using ver. 26, I'm using 27.0.1.
rmwpg 1 giải pháp 18 câu trả lời
Được đăng

I am also having this problem. It is maddening! Click "Back" and I'm taken to the top of the previous page, rather than to the position on that page I was previously at.

I *think* it started after 'upgrading' to firefox 28---a move I was loathe to do, but finally gave in after being hounded about it for months. These stupid upgrades seldom seem to offer any benefit, and often screw up extensions, or do things like this---aarrgghhh.

It's like driving a new car in which the transmission doesn't work, when your old car ran fine.

To pre-answer anyone who asks, I have done EVERYTHING suggested above, and nothing helps. It also happens on every page on every website.

So, the firefox creators leave it up to volunteers on sites like this to solve some obviously hideous design fault? Unbelievable.

I am also having this problem. It is maddening! Click "Back" and I'm taken to the top of the previous page, rather than to the position on that page I was previously at. I *think* it started after 'upgrading' to firefox 28---a move I was loathe to do, but finally gave in after being hounded about it for months. These stupid upgrades seldom seem to offer any benefit, and often screw up extensions, or do things like this---aarrgghhh. It's like driving a new car in which the transmission doesn't work, when your old car ran fine. To pre-answer anyone who asks, I have done EVERYTHING suggested above, and nothing helps. It also happens on every page on every website. So, the firefox creators leave it up to volunteers on sites like this to solve some obviously hideous design fault? Unbelievable.
jscher2000
  • Top 10 Contributor
8787 giải pháp 71865 câu trả lời
Được đăng

Hi rmwpg, if this happens on every page on every website something may be wrong with Firefox's cache, or you might have disabled caching, requiring Firefox to reload every page every time. Firefox 28 does not work that way normally.

To confirm that Firefox 28 can work correctly on your system, could you do a two-minute experiment?

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

(Windows) Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Any time you want to switch profiles, exit Firefox and return to this dialog.

You'll click the Create Profile button. I recommend using the default location suggested (in other words, don't click the button to choose a different folder). Then start Firefox in the new profile you created.

Does the Back button work normally in the new profile?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

Hi rmwpg, if this happens ''on every page on every website'' something may be wrong with Firefox's cache, or you might have disabled caching, requiring Firefox to reload every page every time. Firefox 28 does not work that way normally. To confirm that Firefox 28 can work correctly on your system, could you do a two-minute experiment? '''Create a new Firefox profile''' A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder. (Windows) Exit Firefox and start up in the Profile Manager using Start > search box (or Run): firefox.exe -P Any time you want to switch profiles, exit Firefox and return to this dialog. You'll click the Create Profile button. I recommend using the default location suggested (in other words, don't click the button to choose a different folder). Then start Firefox in the new profile you created. Does the Back button work normally in the new profile? When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.