Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Some web fonts are not rendered

  • 6 trả lời
  • 42 gặp vấn đề này
  • 32 lượt xem
  • Trả lời mới nhất được viết bởi p_blomberg

more options

When I visit some sites that use web fonts, the web fonts are not rendered. It does not render with the wrong font - the text is completely invisible. On other sites, web fonts work just fine, and I cannot understand why some web fonts work and some don't.

Examples of non-working sites: http://blog.mailchimp.com/ (headers shown, article text missing) https://www.sbab.se/ (huge top header missing) http://onlinepizza.se/ (headers and button texts missing)

Examples of working sites: http://www.google.com/fonts http://www.typetester.org/

On the Network -> Fonts tab in the inspector, no downloads are shown on the broken sites. Is there a font cache that I can delete?

I have tried uninstalling firefox, deleting all profiles and installing it again. Nothing changes.

Tất cả các câu trả lời (6)

more options

This sounds a lot like a problem Firefox has some time ago. Here's a reference to that here: http://stackoverflow.com/questions/16584224/web-fonts-not-working-in-some-firefox-including-google-fonts-sample-page

I have the same issue as well right now, and in fact, if I replace http by https, the problem goes away.

more options

One of the example sites, sbab.se, forces https. Trying https on blog.mailchimp.com does not solve the problem.

more options

Works fine here on Linux. Right-click > "Inspect Element" > Font shows:


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)
more options

I have just tried Safe Mode and shift+reload. Makes no difference. :(

more options

You can try to rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

more options

As I stated in my first post, I have tried uninstalling firefox, deleting all profiles and installing it again. Nothing changes.