X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Can't get it to remember passwords

Được đăng

Firefox won't offer to remember passwords. When I go to security settings, the box for remember passwords for sites is grayed out.

Firefox won't offer to remember passwords. When I go to security settings, the box for remember passwords for sites is grayed out.

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Google Update
  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.10.2.10212
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Unity Player 3.5.3f3
  • Winamp Application Detector
  • NPWLPG

Ứng dụng

  • Firefox 20.0.1
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • URL hỗ trợ: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Tiện ích mở rộng

  • Java Console 6.0.33 ({CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA})
  • Java Console 6.0.35 ({CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA})
  • Java Console 6.0.37 ({CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: AMD Radeon(TM) HD 6520G
  • adapterDescription2:
  • adapterDeviceID: 0x9647
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 7-14-2011
  • driverDate2:
  • driverVersion: 8.836.1.3000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon(TM) HD 6520G )
  • windowLayerManagerType: Direct3D 10

Thay đổi cài đặt

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.startup.homepage: https://mail.google.com/mail/?shva=1#inbox
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.name.serif.x-western: Arial
  • font.size.fixed.x-western: 15
  • font.size.variable.x-western: 18
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1368149465
  • places.history.expiration.transient_current_max_pages: 93424
  • places.history.expiration.transient_optimal_database_size: 149476802
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
cor-el
  • Top 10 Contributor
  • Moderator
17670 giải pháp 159841 câu trả lời
Được đăng

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
Make sure that you do not run Firefox in (permanent) Private Browsing mode. *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode" ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Người tạo câu hỏi

Neither suggestion worked. I never browse in private mode and box still greyed out in safe mode.

Neither suggestion worked. I never browse in private mode and box still greyed out in safe mode.

Được chỉnh sửa bởi dj9281 vào

philipp
  • Top 25 Contributor
  • Moderator
5330 giải pháp 23532 câu trả lời
Được đăng

which security program do you use?

which security program do you use?

Người tạo câu hỏi

Microsoft security essentials and I've always had it. This password issue just started a few weeks ago and I've made no security changes (at least not intentionally)

Microsoft security essentials and I've always had it. This password issue just started a few weeks ago and I've made no security changes (at least not intentionally)
philipp
  • Top 25 Contributor
  • Moderator
5330 giải pháp 23532 câu trả lời
Được đăng

ok, i was just asking because some versions of norton are causing this. however i've just discovered in the settings you have provided, that firefox is set to "never remember a history" in the privacy options (which is essentially the same as running it in private mode permanently) which will also prohibit the storage of passwords - change that to custom history settings & it should be possible to remember passwords in firefox afterwards...

ok, i was just asking because some versions of norton are causing this. however i've just discovered in the settings you have provided, that firefox is set to "never remember a history" in the privacy options (which is essentially the same as running it in private mode permanently) which will also prohibit the storage of passwords - change that to custom history settings & it should be possible to remember passwords in firefox afterwards...

Người tạo câu hỏi

I've always had that setting checked and it's always had no problems saving passwords before a few weeks ago.

I've always had that setting checked and it's always had no problems saving passwords before a few weeks ago.
cor-el
  • Top 10 Contributor
  • Moderator
17670 giải pháp 159841 câu trả lời
Được đăng

Can you change the signon.rememberSignons pref directly to true on the about:config page?

It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.
Rename the key3.db and signons.sqlite files in the Firefox profile folder.
You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.
You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.
If that has worked then you can remove the renamed files that are no longer needed.

See:

Can you change the <b>signon.rememberSignons</b> pref directly to true on the <b>about:config</b> page? It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.<br /> Rename the key3.db and signons.sqlite files in the Firefox profile folder.<br /> You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.<br /> You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.<br /> If that has worked then you can remove the renamed files that are no longer needed. See: * "Troubleshooting" in http://kb.mozillazine.org/Password_Manager
snoo 0 giải pháp 1 câu trả lời
Được đăng

Oh thank you very much cor-el, it really helped! It has been bothering for a week that firefox just refuse to remember password even though the prompt box did pop up and all the setting seemed correct, now that I've changed the key3.db and signons.sqlite files everything is gone back to be normal, what a relief! Thanks!

Oh thank you very much cor-el, it really helped! It has been bothering for a week that firefox just refuse to remember password even though the prompt box did pop up and all the setting seemed correct, now that I've changed the key3.db and signons.sqlite files everything is gone back to be normal, what a relief! Thanks!
lsalrn 0 giải pháp 1 câu trả lời
Được đăng

Thank you, thank you, thank you. Your directions that I have copied and pasted below have finally restored the "remember password" to no longer being grayed out and is now usable again!

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

   https://support.mozilla.org/kb/Private+Browsing 
   Tools > Options > Privacy > Firefox will: "Use custom settings for history"
   Deselect: [ ] "Always use private browsing mode"
Thank you, thank you, thank you. Your directions that I have copied and pasted below have finally restored the "remember password" to no longer being grayed out and is now usable again! Make sure that you do not run Firefox in (permanent) Private Browsing mode. https://support.mozilla.org/kb/Private+Browsing Tools > Options > Privacy > Firefox will: "Use custom settings for history" Deselect: [ ] "Always use private browsing mode"