Search Support

Fire FTP does not appear in the Firefox 4 Tools Menu, where is it?

  • 10 trả lời
  • 400 gặp vấn đề này
  • 7306 lượt xem
  • Trả lời mới nhất được viết bởi Nancy

more options

I have just upgraded Firefox from 3.6.16 to Firefox 4 (OS Win XP) I had Fire FTP as an add on, but after upgrading it disappeared from the Tools Menu (along with all my accounts details) I then re installed the Fire FTP Add On but it does not appear in the Tools Menu, where has it gone? Firefox 4 appears to have reinstalled previously removed Extensions/Add ons The Tools Menu doesnt have anything in it. How can I roll back from Firefox 4

All Replies (10)

more options

Yeah I lost every button. Reinstalled, and still no luck. Went back to 3.6.16 but now no fireftp. I am disgusted. Upgrade? Not to my way of thinking.

more options

Sorry, I don't use FireFTP myself, but there is a "help" page at the authors MozDev website. You may need to use the FireFTP Toolbar button if the Tools Menu item is gone.

http://fireftp.mozdev.org/help.html
How do I start FireFTP?
Go to your menu bar and click Tools->FireFTP. Alternatively, you can use the toolbar button. To add the toolbar button, right click on the Firefox toolbar and select "Customize...". Then find the FireFTP button and drag it to the toolbar somewhere.

Make sure you have successfully restarted Firefox after installation; otherwise FireFTP will not be fully installed.

more options

I think the answer to "Where is it?" is that it is hidden under the "improved" interface screen. If you go to the move add ons (or whatever menu that is) and move something up near the top of the screen where Firefox used to keep the [File Edit History Bookmarks Tools Help menu], you will see that the main interface screen moves down and that those drop down choices are still there. Then, assuming that FireFTP is the only add on you have added, it's icon will be located immediately to the right of the "Help" drop down. The real problem is that there is no way that I have found to access anything on that menu, because the only time you can see it is when you are adding something to it. So, since you can't access the FireFTP icon to run it, Firefox 4 will not let you use it. After several hours messing with it I gave up and went back to the last version of Firefox 3. I can't believe they have left this go unfixed for this long.

more options

Hi,

just insert "chrome://fireftp/content/fireftp.xul" as url (without the inverted commas), after fireftp is installed. I got the idea after inspecting the second image from this link: http://www.simplehelp.net/2007/10/15/how-to-use-ftp-from-within-firefox/

more options

Fire FTP works as well as (or better than) ever.

Click on the FireFox menu In the drop-down menu, select Web Developer

If you have Fire FTP installed, you should see it listed there.

more options

Ok, I found it. But it was more convenient for me when it was on the Tools menu. And come to think of it, it is a "Tool". My question is: Was this Microsoft-type thinking to "decide" that FireFTP gets pushed down a menu-notch. That is to say, FireFTP was asked for a 'tip' and couldn't or didn't want to cough it up, and was demoted... Sorry to be cynical, but with the blur of upgrades at Firefox, a user might wonder what's up.... Oh well, I will hope for the best. (I miss the old layout, though)

more options

To clarify Afallach's reply, the FireFTP menu is now under Tools->Web Developer->FireFTP.

I don't know why the development team chose to move it there, but they've been making a lot of stupid design decisions recently.

more options

That makes it also accessible via "Firefox > Web Developer" if the menu bar is hidden and that wouldn't be the case if it is an extension that has an entry in Tools like "Live HTTP Headers".

more options

"I don't know why the development team chose to move it there, but ...."

The developer of each add-on makes that decision - where the extension's menu items are located.

more options

Try VIEW>TOOLBARS>ADD-ON BAR. You can enable FireFTP (along with any other add-ons that were disabled last time there was a Firefox upgrade).

It now appears as a tiny icon just to the left of the Home button

Được chỉnh sửa bởi Nancy vào