Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Multiple windows, check for closing multiple tabs is asked only on last window

  • 10 trả lời
  • 0 gặp vấn đề này
  • 1 lượt xem
  • Trả lời mới nhất được viết bởi Fred

more options

Hey there,

during work I often open two windows of Firefox to have more information visible on my two monitors. Unfortunately I sometimes forget that I have a second window open, so I close only my "main" window and loose all tabs.

Is there a way to force Firefox to ask to close a window and loosing multiple tabs for every window open?

Right now this only happens for the last open window.

PS: I just found out about the keyboard shortcut of restoring a window (CTRL+SHIFT+N) recently. I would prefer a setting in my case.

Thanks in advance Fred

Hey there, during work I often open two windows of Firefox to have more information visible on my two monitors. Unfortunately I sometimes forget that I have a second window open, so I close only my "main" window and loose all tabs. Is there a way to force Firefox to ask to close a window and loosing multiple tabs for every window open? Right now this only happens for the last open window. PS: I just found out about the keyboard shortcut of restoring a window (CTRL+SHIFT+N) recently. I would prefer a setting in my case. Thanks in advance Fred

Được chỉnh sửa bởi Fred vào

Giải pháp được chọn

I just found the settings to switch on my desired behaviour!

It is "browser.tabs.closeWindowWithLastTab = false".

Now I get the warning in the second open window with more than two open tabs, even when closing via X on Windows. Also when having two windows open, the "second" one with only one tab, the warning is shown in "main window".

So now it works like desired.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (10)

more options

What do you have set here? see screenshot This option is a must for me.  ;-)) see my open windows screenshot

Hữu ích?

more options

jonzn4SUSE said

What do you have set here? see screenshot This option is a must for me.  ;-)) see my open windows screenshot

"Confirm before closing multiple tabs" is checked. Nonetheless Firefox is just asking to close multiple tabs on the last open window with multiple tabs.

I do not see the other setting. Did you use some about:config settings to activate it?

Được chỉnh sửa bởi Fred vào

Hữu ích?

more options

You can also go here for history. see screenshot

Hữu ích?

more options

Looks like on Linux there is the ctrl + Q option. https://support.mozilla.org/en-US/kb/how-configure-close-tab-warnings-firefox

Hữu ích?

more options

Did you check "History -> Restore Previous Session and" "History -> Recently Closed Windows/Tabs"?

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox Title bar, especially if you have multiple windows or Private Browsing windows open to prevent losing tabs in unnoticed windows.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

Hữu ích?

more options

Thanks for your reponse, core-el!

cor-el said

Did you check "History -> Restore Previous Session and"

Unfortunately I'm not quite sure where to find these settings in History.

I do have checked "Settings > General > Startup > Open previous windows and tabs". Is that what you are asking for? That setting only saves the last opened windows and tabs. And if I have closed my "main window" already all tabs are lost. But ...

cor-el said

"History -> Recently Closed Windows/Tabs"?

I never used that function, so will try to remember the next time, thanks!

cor-el said

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox Title bar, especially if you have multiple windows or Private Browsing windows open to prevent losing tabs in unnoticed windows.
  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

A bit annoying to exit this way, to be honest, but if it helps, I'll try to close it this way in the future.

Hữu ích?

more options

Hi Fred, maybe this one:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.tabs.warnOnClose and pause while the list is filtered

(3) Double-click the preference (or click the toggle button at the right end of the row ) to switch the value from false to true

I suggest testing with a less important multi-tab window first.

Hữu ích?

more options

Hey jscher2000,

thanks for your detailed response!

But it is already activated. And it does work.

My point is that if I have a second Firefox window open, no warning is shown. Only the last window shows the warning. Because of that I did lost a few times some important tabs on my "main window".

So my question is: is this behaviour intentional or maybe a bug? It would be nice if the warning would be shown for every window separately.

Fred

Được chỉnh sửa bởi Fred vào

Hữu ích?

more options

Hi Fred, I get a warning for every* non-private window I close. Maybe I guessed wrong about which preference is responsible for that.

* if it has 2 or more tabs

Được chỉnh sửa bởi jscher2000 - Support Volunteer vào

Hữu ích?

more options

Giải pháp được chọn

I just found the settings to switch on my desired behaviour!

It is "browser.tabs.closeWindowWithLastTab = false".

Now I get the warning in the second open window with more than two open tabs, even when closing via X on Windows. Also when having two windows open, the "second" one with only one tab, the warning is shown in "main window".

So now it works like desired.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.