Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How to get rid of unrequested invasive rendered area debugging overlay?

  • 8 trả lời
  • 0 gặp vấn đề này
  • 3 lượt xem
  • Trả lời mới nhất được viết bởi F0X

more options

After updating my openSUSE Firefox package from version 122 to 123 every frame inside each window started to have weird grey overlay of scrollable area. I failed to find any description of such a thing happening, let alone how to get rid of it. I tried removing build-in distro-default preferences and had complete audit of all my custom preferences in about:config but none changed that behavior. I even updated to 124b4 but this also haven't changed anything. Naturally, nuking entire profile is not an option, I might as well replace the whole browser. So, how do I get rid of this thing?

After updating my openSUSE Firefox package from version 122 to 123 every frame inside each window started to have weird grey overlay of scrollable area. I failed to find any description of such a thing happening, let alone how to get rid of it. I tried removing build-in distro-default preferences and had complete audit of all my custom preferences in about:config but none changed that behavior. I even updated to 124b4 but this also haven't changed anything. Naturally, nuking entire profile is not an option, I might as well replace the whole browser. So, how do I get rid of this thing?
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Change apz.minimap.enabled to false in about:config. This setting had been broken for many years until it was fixed in version 123 (Bug 1604280).

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (8)

more options

You appear to be using userChrome.css and userContent.css. You can set toolkit.legacyUserProfileCustomizations.stylesheets => false in about:config to disable these files.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can set toolkit.legacyUserProfileCustomizations.stylesheets => false in about:config to disable these files.

Hữu ích?

more options

None of that got rid of the overlay. I also tried temporarily running new, empty profile and it did not have the overlay but this didn't clarify much.

Hữu ích?

more options

I'm running Leap and Tumbleweed and not able to replicate your issue on Distro, Mozilla, nor Waterfox. X11 or Wayland? Graphic driver info? lshw -numeric -C display You may have to install lshw or use infocenter to get the info.

Operating System: openSUSE Tumbleweed 20240226 KDE Plasma Version: 5.27.10 KDE Frameworks Version: 5.115.0 Qt Version: 5.15.12 Kernel Version: 6.7.6-1-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Xeon® CPU E3-1535M v6 @ 3.10GHz Memory: 62.2 GiB of RAM Graphics Processor: Quadro P4000/PCIe/SSE2 Manufacturer: HP Product Name: HP ZBook 17 G4

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

F0X said

None of that got rid of the overlay. I also tried temporarily running new, empty profile and it did not have the overlay but this didn't clarify much.

New profile is not showing the issue, sounds like an add-on issue.

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

jonzn4SUSE said

I'm running Leap and Tumbleweed and not able to replicate your issue on Distro, Mozilla, nor Waterfox. X11 or Wayland? Graphic driver info? lshw -numeric -C display You may have to install lshw.

Well, good for you then. And I'm here have to write even this text behind a grey bar because it generated another one over the input window too.

Full lshw -numeric -C display shows whole bunch irrelevant BIOS-level stuff and your example is not from lshw's output at all. But my setup is typical X11/KDE with AMD Radeon RX580 and latest Mesa.

jonzn4SUSE said

New profile is not showing the issue, sounds like an add-on issue.

Except that "Troubleshooting Mode" supposed to disable them all and it still didn't help. And what kind of addon would even be that? I'm 80% certain that some Firefox's (or some toolkit's used by it, like GTK) built-in rendering debug option got flipped somewhere. Maybe even one that is not triggered by prefs but by some hardcoded condition.

Được chỉnh sửa bởi F0X vào

Hữu ích?

more options

Okay.

Hữu ích?

more options

Giải pháp được chọn

Change apz.minimap.enabled to false in about:config. This setting had been broken for many years until it was fixed in version 123 (Bug 1604280).

Hữu ích?

more options

zeroknight said

Change apz.minimap.enabled to false in about:config. This setting had been broken for many years until it was fixed in version 123 (Bug 1604280).

Thanks! I have no idea how & when this got flipped and had no forethought to search for 'map' keyword too. It's been ages since I was so helpless with a technical issue.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.