Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Screwy fonts

  • 9 trả lời
  • 3 gặp vấn đề này
  • 8 lượt xem
  • Trả lời mới nhất được viết bởi Avigail Bahat

more options

Firefox displays websites with gibberish for headlines. I've monkeyed with the "Fonts" preferences in the Settings to no avail. Perhaps I'm not choosing correctly. They are currently set with Firefox's defaults and the box allowing websites to choose their own fonts is also selected. No matter what I've done, it looks like the attached image. Help!

Firefox displays websites with gibberish for headlines. I've monkeyed with the "Fonts" preferences in the Settings to no avail. Perhaps I'm not choosing correctly. They are currently set with Firefox's defaults and the box allowing websites to choose their own fonts is also selected. No matter what I've done, it looks like the attached image. Help!
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

I'm not sure about Troubleshoot Mode, but I went back into Settings>Fonts>Advanced and unchecked the box allowing websites to choose their own fonts, requiring the browser to use my settings. This worked.

Thanks for the help, everyone.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (9)

more options
  1. Numbered list item
more options

Does it still happen in Troubleshoot Mode?

more options

Giải pháp được chọn

I'm not sure about Troubleshoot Mode, but I went back into Settings>Fonts>Advanced and unchecked the box allowing websites to choose their own fonts, requiring the browser to use my settings. This worked.

Thanks for the help, everyone.

more options

Issues with a weird looking font or missing glyphs can be caused by a problem with a specific font and you need to identify this font and fix this. You may find that it can be resolved by finding and removing duplicate fonts installed in the local ~/Library/Fonts folder, that are conflicting with standard system fonts.

You can check in Font Book for font issues like corrupted and duplicate fonts.

Note that you should be careful about disabling "Allow pages to choose their own fonts, instead of your selections above" as this will cause issues with iconic fonts used by webpages to display small icons (you may see text labels instead of icons).

more options

so. . . . no real answers yet, eh? in my instance, this occurred the moment i (foolishly) installed sonoma beta. today (oct.26), firefox updated and all was good. then i quit firefox and when i returned, the same bunk with gibberish font renders all over, including the firefox home page (see attachment). i've gone through the fonts listed in the web dev (i'm no developer, though) and validated everything using mac's fontbook app. there was an issue with helvetica neue but that's been fixed now.

i've currently unchecked the setting to let sites display their own fonts, and this seemingly "fixes" the problem but, as you see attached, my home page is still gibberish. while i know what each item is (thanks, icons), it's simply a reminder that this is still broken and all i've done is apply a band aid to a serious infection.

what made it work momentarily today?

thanks in advance, folks.

more options

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. If the Fonts tab is hidden, click the down arrow at the right end.

more options

Go to about:config and try changing layout.css.font-visibility to 1 to limit fonts to a standard list.

more options

I have the same issue, and I've been trying to fix it for days. Troubleshoot mode works, and also uncheck the checkbox, but this is not a solution. I recently updated to Sonoma on my Mac, and then the font started being screwy :)

After inspecting, I saw I needed an "SF NS" system font, which I can't install.

HELP.

more options

Hi, so what worked for me is to remove all fonts from my library folder, and then restart.