Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Copy/pasting URLs sometimes forces my keyboard language from ENG CMS to ENG US

  • 4 trả lời
  • 0 gặp vấn đề này
  • 34 lượt xem
  • Trả lời mới nhất được viết bởi stranger

more options

Hello,

This is a weird issue that's been plaguing me for years. Only recently have I spotted the common factor.

On two Windows 10 computers, sometimes when I copy/paste a link in Firefox, my keyboard input language switches from Canadian Multilingual Standard to US English. On my desktop, I don't even have US English installed as an input method, yet it still switches to it. I've even made registry changes to specifically remove it, to no avail. Disabling the option to switch languages via keyboard shortcut also makes no difference.

This seems to happen completely randomly. I'll ctrl+c/ctrl+v a link and the language will change. Putting it back to CMD and ctrl+c/ctrl+v again and it won't change. The change only happens when I copy/paste a link from Firefox. Maybe one out of every 15-20 times on the large scale, but sometimes it will happen twice in a row, or not at all for a week.

Does anyone have any insight on this issue, or how I can fix it permanently? It's such a weird issue and it's infrequent enough, but every time it happens it feels like tripping in a full sprint. Very unpleasant.

Currently running 113.0.1 (64-bit), but again, this has been plaguing me for years. I first thought it was a Windows install issue, but it's happening on two different systems. Thanks in advance

Hello, This is a weird issue that's been plaguing me for years. Only recently have I spotted the common factor. On two Windows 10 computers, sometimes when I copy/paste a link in Firefox, my keyboard input language switches from Canadian Multilingual Standard to US English. On my desktop, I don't even have US English installed as an input method, yet it still switches to it. I've even made registry changes to specifically remove it, to no avail. Disabling the option to switch languages via keyboard shortcut also makes no difference. This seems to happen completely randomly. I'll ctrl+c/ctrl+v a link and the language will change. Putting it back to CMD and ctrl+c/ctrl+v again and it won't change. The change only happens when I copy/paste a link from Firefox. Maybe one out of every 15-20 times on the large scale, but sometimes it will happen twice in a row, or not at all for a week. Does anyone have any insight on this issue, or how I can fix it permanently? It's such a weird issue and it's infrequent enough, but every time it happens it feels like tripping in a full sprint. Very unpleasant. Currently running 113.0.1 (64-bit), but again, this has been plaguing me for years. I first thought it was a Windows install issue, but it's happening on two different systems. Thanks in advance

Tất cả các câu trả lời (4)

more options

I think that Windows would only switch the layout if you use the shortcut to select this layout or have a key sequence for rotating the layout. The latter can be a combination of modifier keys (Shift, Ctrl, Alt, Windows).

more options

cor-el said

I think that Windows would only switch the layout if you use the shortcut to select this layout or have a key sequence for rotating the layout. The latter can be a combination of modifier keys (Shift, Ctrl, Alt, Windows).

The option to switch layouts via keyboard shortcuts is entirely disabled on my desktop. In fact, I have to click on the language selector in the task bar to change it back. It is enabled on the laptop, but I can assure you that I'm not inputting the shortcut (which is alt+shift in my case).

Được chỉnh sửa bởi stranger vào

more options

Firefox has a lot of shortcuts that use the alt+shift modifier (i.e. this is used for menu items and access keys on websites) unlike other application Firefox needs so many shortcuts that a lot of modifier combinations are used. Best is to set this key sequence to rotate the layout to a key sequence that include a key and not only modifier keys, you can test if this makes a difference.

more options

cor-el said

Firefox has a lot of shortcuts that use the alt+shift modifier (i.e. this is used for menu items and access keys on websites) unlike other application Firefox needs so many shortcuts that a lot of modifier combinations are used. Best is to set this key sequence to rotate the layout to a key sequence that include a key and not only modifier keys, you can test if this makes a difference.

Key sequence to rotate the layout is entirely disabled on one system, yet the layout continues to rotate, randomly, when I copy and paste a url in Firefox. This is the issue.