Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Using the 'Chat' facility on the HSBC website

  • 7 trả lời
  • 1 gặp vấn đề này
  • 32 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

Hi,

Let me start with two points: (a) this is the first time that I've used this site, so if I do anything wrong please just tell me and I won't do it again, and, (b) I'm no technician (I deliberately use Firefox because I believe in Mozilla's business principles, not because I think Firefox is technically superior to other browsers - although I'm quite prepared to believe that it is) but I can follow instructions. OK, so having said that …

I am using the latest version of Firefox [98.0.2 (64-bit)] on a bog standard Dell laptop under Windows 10 [Edition Windows 10 Home, Version 21H2, OS build 19044.1620, Windows Feature Experience Pack 120.2212.4170.0].

I have recently opened an HSBC bank account. If I try to access their UK online banking site (https://www.hsbc.co.uk/) using Firefox (which I should very much prefer to do than with any other browser), it is missing the most important feature of 'Chat' (the only sensible way of talking to HSBC without having to endure a half-hour wait). However, if I access it using any other browser (e.g., Microsoft Edge) the 'Chat' facility is available in the bottom right-hand corner of the screen. Please note that with Firefox I am using a 'container' (called HSBC) - I don't think that Edge has similar facilities.

Can anybody please tell me whether I might have some setting or other (e.g., say something to do with 'pop-ups' which I think that the HSBC's 'Chat' facility uses) set incorrectly?

Thank you and best regards

John

Hi, Let me start with two points: (a) this is the first time that I've used this site, so if I do anything wrong please just tell me and I won't do it again, and, (b) I'm no technician (I deliberately use Firefox because I believe in Mozilla's business principles, not because I think Firefox is technically superior to other browsers - although I'm quite prepared to believe that it is) but I can follow instructions. OK, so having said that … I am using the latest version of Firefox [98.0.2 (64-bit)] on a bog standard Dell laptop under Windows 10 [Edition Windows 10 Home, Version 21H2, OS build 19044.1620, Windows Feature Experience Pack 120.2212.4170.0]. I have recently opened an HSBC bank account. If I try to access their UK online banking site (https://www.hsbc.co.uk/) using Firefox (which I should very much prefer to do than with any other browser), it is missing the most important feature of 'Chat' (the only sensible way of talking to HSBC without having to endure a half-hour wait). However, if I access it using any other browser (e.g., Microsoft Edge) the 'Chat' facility is available in the bottom right-hand corner of the screen. Please note that with Firefox I am using a 'container' (called HSBC) - I don't think that Edge has similar facilities. Can anybody please tell me whether I might have some setting or other (e.g., say something to do with 'pop-ups' which I think that the HSBC's 'Chat' facility uses) set incorrectly? Thank you and best regards John

Giải pháp được chọn

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes), any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address box to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (7)

more options

I do not think the chat uses pop-ups (it looks like just Javascript and HTML), but you can try enabling pop-ups (about:preferences#privacy->Permissions->Uncheck Block Pop-ups).

Most likely, this is an issue with your extensions/privacy settings. Does the issue persist if you Start Firefox in Troubleshoot Mode? If it works in Troubleshoot Mode:

  1. Set Enhanced Tracking Protection to Standard instead of Strict in about:preferences#privacy. Also enable cookies (Cookies and Site Data -> Manage Exceptions -> Add "https://www.hsbc.co.uk/" and choose Allow.
  2. Disable any ad-blockers and content blockers by clicking on their icon in the toolbar. Or disable them entirely by going to about:addons and toggling them off under Extensions.

Hữu ích?

more options

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version?

Version 98.0, first offered to Release channel users on March 8, 2022 Version 99.0, first offered to Release channel users on April 5, 2022 Version 99.0.1, first offered to Release channel users on April 12, 2022

Hữu ích?

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Hữu ích?

more options

Thank you both (Zian & FredMcD) - that was most helpful. Starting Firefox in Troubleshoot (Safe) mode does indeed allow HSBC's 'Chat' facility to work. However, no matter how I try to adjust the various settings (e.g., 'Enhanced Tracking Protection is OFF for this site - so that the little shield symbol at the start of the address bar has a stroke across it), 'Chat' will not work other than in Troubleshoot mode. This may sound a naïve question (and that's because I am naïve), but is there any harm in always accessing just this one site in Troubleshoot mode?

Hữu ích?

more options

Giải pháp được chọn

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes), any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address box to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Hữu ích?

more options

Thank you very much FredMcD - you were 'spot on' right - the 'offending' add-on which was preventing the 'Chat' facility working on the HSBC website was "DuckDuckGo Privacy Essentials".

I note that within the add-on menu (three dots on the right) there is the opportunity to 'report' the add-on. Tell me, is that a report to Mozilla that the add-on is in some way 'bad/dangerous' or is it a report to DuckDuckGo that there is a potential issue/bug? If it is the latter, I shall use it to report the issue but if it is the former, I shall find some other way to contact DuckDuckGo to report the issue.

Thanks again - very helpful - have a good day

John

Hữu ích?

more options

the.sharps said

. . . within the add-on menu (three dots on the right) there is the opportunity to 'report' the add-on. Tell me, is that a report to Mozilla that the add-on is in some way 'bad/dangerous'

That I think sends a message to the Mozilla add-on people. As to the add-on, this should work; Load the web page. After the page is loaded, click the AdBlock icon. Now select Disable on <website>. After, reload the page.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.