Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How to remove fixed items from bookmarks menu

  • 3 trả lời
  • 1 gặp vấn đề này
  • 4 lượt xem
  • Trả lời mới nhất được viết bởi james.wilkinson

more options

The following css used to work to remove items from Bookmarks menu:

#bookmarksToolbarSeparator,#bookmarksMenuItemsSeparator{display: none !important;}
#bookmarksToolbarSeparator,#organizeBookmarksSeparator{display: none !important;}
#bookmarksToolbarSeparator,#menu_bookmarkAllTabs{display: none !important;}
#bookmarksToolbarSeparator,#bookmarksShowAll{display: none !important;}

It no longer works in FF88. How to fix?

N.B. There wasn't a way to hide "other bookmarks" from the bookmarks MENU (This has nothing to do with the unrelated TOOLBAR issue, and the settings for that do not affect the menu)

Đính kèm ảnh chụp màn hình

Được chỉnh sửa bởi cor-el vào

Giải pháp được chọn

You can possibly leave a space at the start of a line to force rendering as a PRE tag.

The IDs you use look correct, so you can check for other issues like a hidden .txt appended or not having enabled userChrome.css.

Does other CSS code in userChrome.css still work in case you have more rules in your file ?


In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true
Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (3)

more options

For reasons best known to itself the page replaced the hashes with the numbers 1-4 it ACTUALLY looked like this (... added to stop bizarre autoformatting)

... #bookmarksToolbarSeparator,#bookmarksMenuItemsSeparator{display: none !important;} ... #bookmarksToolbarSeparator,#organizeBookmarksSeparator{display: none !important;} ... #bookmarksToolbarSeparator,#menu_bookmarkAllTabs{display: none !important;} ... #bookmarksToolbarSeparator,#bookmarksShowAll{display: none !important;}

Hữu ích?

more options

Giải pháp được chọn

You can possibly leave a space at the start of a line to force rendering as a PRE tag.

The IDs you use look correct, so you can check for other issues like a hidden .txt appended or not having enabled userChrome.css.

Does other CSS code in userChrome.css still work in case you have more rules in your file ?


In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

Hữu ích?

more options

Added spaces at the start of the line and moved the code to the top of the CSS. Did the trick, thanks.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.